aboutsummaryrefslogtreecommitdiffstats
path: root/meta-mentor-staging/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta-mentor-staging/recipes-core')
-rw-r--r--meta-mentor-staging/recipes-core/glibc/glibc-locale_%.bbappend20
-rw-r--r--meta-mentor-staging/recipes-core/initrdscripts/initramfs-framework_1.0.bbappend4
-rw-r--r--meta-mentor-staging/recipes-core/initrdscripts/initramfs-live-boot_1.0.bbappend4
-rw-r--r--meta-mentor-staging/recipes-core/meta/buildtools-tarball.bbappend10
-rw-r--r--meta-mentor-staging/recipes-core/meta/meta-environment.bbappend23
-rw-r--r--meta-mentor-staging/recipes-core/systemd/systemd-boot_%.bbappend4
-rw-r--r--meta-mentor-staging/recipes-core/udev/udev-extraconf_%.bbappend4
7 files changed, 69 insertions, 0 deletions
diff --git a/meta-mentor-staging/recipes-core/glibc/glibc-locale_%.bbappend b/meta-mentor-staging/recipes-core/glibc/glibc-locale_%.bbappend
new file mode 100644
index 00000000..ae6f962f
--- /dev/null
+++ b/meta-mentor-staging/recipes-core/glibc/glibc-locale_%.bbappend
@@ -0,0 +1,20 @@
+# ---------------------------------------------------------------------------------------------------------------------
+# SPDX-License-Identifier: MIT
+# ---------------------------------------------------------------------------------------------------------------------
+
+# Work around long standing periodic host-user-contaminated QA failure by
+# explicitly correcting the ownership.
+#
+# See `glibc-locale: Rewrite do_install using install utility instead of cp`
+# on the oe-core mailing list for discussion. This should be dropped when
+# a real fix is implemented.
+
+do_prep_locale_tree:append () {
+ chown -R root:root $treedir
+}
+
+# Explicitly disable host-user-contaminated to further work around the
+# pseudo bug. With pseudo acting up, even if the ownership is correct,
+# it may well think it is not, so just sidestep the issue until upstream
+# fixes the root cause.
+ERROR_QA:remove = "host-user-contaminated"
diff --git a/meta-mentor-staging/recipes-core/initrdscripts/initramfs-framework_1.0.bbappend b/meta-mentor-staging/recipes-core/initrdscripts/initramfs-framework_1.0.bbappend
index c47f7511..ce9fade0 100644
--- a/meta-mentor-staging/recipes-core/initrdscripts/initramfs-framework_1.0.bbappend
+++ b/meta-mentor-staging/recipes-core/initrdscripts/initramfs-framework_1.0.bbappend
@@ -1,2 +1,6 @@
+# ---------------------------------------------------------------------------------------------------------------------
+# SPDX-License-Identifier: MIT
+# ---------------------------------------------------------------------------------------------------------------------
+
FILESEXTRAPATHS:prepend:feature-mentor-staging := "${THISDIR}/files:"
SRC_URI:append:feature-mentor-staging = " file://0001-initramfs-framework-finish-move-mounts-to-rootfs-bef.patch"
diff --git a/meta-mentor-staging/recipes-core/initrdscripts/initramfs-live-boot_1.0.bbappend b/meta-mentor-staging/recipes-core/initrdscripts/initramfs-live-boot_1.0.bbappend
index fb85b3fe..2e062946 100644
--- a/meta-mentor-staging/recipes-core/initrdscripts/initramfs-live-boot_1.0.bbappend
+++ b/meta-mentor-staging/recipes-core/initrdscripts/initramfs-live-boot_1.0.bbappend
@@ -1,3 +1,7 @@
+# ---------------------------------------------------------------------------------------------------------------------
+# SPDX-License-Identifier: MIT
+# ---------------------------------------------------------------------------------------------------------------------
+
FILESEXTRAPATHS:prepend:feature-mentor-staging := "${THISDIR}/files:"
SRC_URI:append:feature-mentor-staging = " file://0001-initrdscripts-init-live.sh-Fixed-mounts-fail-to-move.patch"
diff --git a/meta-mentor-staging/recipes-core/meta/buildtools-tarball.bbappend b/meta-mentor-staging/recipes-core/meta/buildtools-tarball.bbappend
new file mode 100644
index 00000000..d9310a18
--- /dev/null
+++ b/meta-mentor-staging/recipes-core/meta/buildtools-tarball.bbappend
@@ -0,0 +1,10 @@
+# ---------------------------------------------------------------------------------------------------------------------
+# SPDX-License-Identifier: MIT
+# ---------------------------------------------------------------------------------------------------------------------
+
+# buildtools-tarball is host only, and does not add TOOLCHAIN_TARGET_TASK to
+# RDEPENDS. Forcibly empty it, otherwise a TOOLCHAIN_TARGET_TASK:append at the
+# config level will break the buildtools-tarball build
+python () {
+ d.setVar('TOOLCHAIN_TARGET_TASK', '')
+}
diff --git a/meta-mentor-staging/recipes-core/meta/meta-environment.bbappend b/meta-mentor-staging/recipes-core/meta/meta-environment.bbappend
new file mode 100644
index 00000000..ba39ff05
--- /dev/null
+++ b/meta-mentor-staging/recipes-core/meta/meta-environment.bbappend
@@ -0,0 +1,23 @@
+# ---------------------------------------------------------------------------------------------------------------------
+# SPDX-License-Identifier: MIT
+# ---------------------------------------------------------------------------------------------------------------------
+
+create_sdk_files:append () {
+ script=${SDK_OUTPUT}/${SDKPATH}/environment-setup-${REAL_MULTIMACH_TARGET_SYS}
+ cat >"${script}.new" <<END
+if [ -n "\$BASH_SOURCE" ] || [ -n "\$ZSH_NAME" ]; then
+ if [ -n "\$BASH_SOURCE" ]; then
+ scriptdir="\$(cd "\$(dirname "\$BASH_SOURCE")" && pwd)"
+ elif [ -n "\$ZSH_NAME" ]; then
+ scriptdir="\$(cd "\$(dirname "\$0")" && pwd)"
+ fi
+else
+ if [ ! -d "${SDKPATH}" ]; then
+ echo >&2 "Warning: Unable to determine SDK install path from environment setup script location, using default of ${SDKPATH}."
+ fi
+ scriptdir="${SDKPATH}"
+fi
+END
+ sed -e "s#${SDKPATH}#\$scriptdir#g" "$script" >>"${script}.new"
+ mv "${script}.new" "${script}"
+}
diff --git a/meta-mentor-staging/recipes-core/systemd/systemd-boot_%.bbappend b/meta-mentor-staging/recipes-core/systemd/systemd-boot_%.bbappend
index 2572f0e6..537f51a1 100644
--- a/meta-mentor-staging/recipes-core/systemd/systemd-boot_%.bbappend
+++ b/meta-mentor-staging/recipes-core/systemd/systemd-boot_%.bbappend
@@ -1,3 +1,7 @@
+# ---------------------------------------------------------------------------------------------------------------------
+# SPDX-License-Identifier: MIT
+# ---------------------------------------------------------------------------------------------------------------------
+
FILESEXTRAPATHS:prepend:feature-mentor-staging := "${THISDIR}/${PN}:"
SRC_URI:append:feature-mentor-staging = " file://0001-Use-an-array-for-efi-ld-to-allow-for-ld-arguments.patch"
diff --git a/meta-mentor-staging/recipes-core/udev/udev-extraconf_%.bbappend b/meta-mentor-staging/recipes-core/udev/udev-extraconf_%.bbappend
index d2642cd5..844a9e4a 100644
--- a/meta-mentor-staging/recipes-core/udev/udev-extraconf_%.bbappend
+++ b/meta-mentor-staging/recipes-core/udev/udev-extraconf_%.bbappend
@@ -1,3 +1,7 @@
+# ---------------------------------------------------------------------------------------------------------------------
+# SPDX-License-Identifier: MIT
+# ---------------------------------------------------------------------------------------------------------------------
+
FILESEXTRAPATHS:prepend:feature-mentor-staging := "${THISDIR}/${PN}:"
SRC_URI:append:feature-mentor-staging = " file://0001-udev-extraconf-mount.sh-add-LABELs-to-mountpoints.patch \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'file://systemd-udevd.service', '', d)} \