aboutsummaryrefslogtreecommitdiffstats
path: root/meta-mentor-staging/gplv2/recipes-devtools/rsync/rsync_2.6.9+git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-mentor-staging/gplv2/recipes-devtools/rsync/rsync_2.6.9+git.bb')
-rw-r--r--meta-mentor-staging/gplv2/recipes-devtools/rsync/rsync_2.6.9+git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-mentor-staging/gplv2/recipes-devtools/rsync/rsync_2.6.9+git.bb b/meta-mentor-staging/gplv2/recipes-devtools/rsync/rsync_2.6.9+git.bb
new file mode 100644
index 00000000..896669b8
--- /dev/null
+++ b/meta-mentor-staging/gplv2/recipes-devtools/rsync/rsync_2.6.9+git.bb
@@ -0,0 +1,28 @@
+# ---------------------------------------------------------------------------------------------------------------------
+# SPDX-License-Identifier: MIT
+# ---------------------------------------------------------------------------------------------------------------------
+
+require recipes-devtools/rsync/rsync_2.6.9.bb
+
+SRC_URI = "git://git.samba.org/rsync.git;protocol=https;branch=master \
+ file://rsyncd.conf \
+ file://addrinfo.h \
+ file://0001-If-we-re-cross-compiling-tell-the-user-to-run-mkroun.patch \
+ file://0002-Changed-the-creation-of-rounding.h-to-use-a-set-of-c.patch \
+ file://0003-Renamed-mkrounding.c-to-rounding.c.patch \
+ file://0004-Improved-the-manpage-install-rules.patch \
+ file://force-protocol-version-29.patch \
+"
+
+SRCREV = "496c809f8cf529c5a95f9578b34a9299b0d92ffb"
+PV .= "${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+do_configure:prepend () {
+ install ${WORKDIR}/addrinfo.h ${S}/lib/
+}
+
+do_configure:append () {
+ oe_runmake proto
+}