aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/xml-commons
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/xml-commons')
-rw-r--r--recipes-core/xml-commons/jaxp1.3_1.4.01.bb4
-rw-r--r--recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb6
-rw-r--r--recipes-core/xml-commons/xpp2_2.1.10.bb2
-rw-r--r--recipes-core/xml-commons/xpp3_1.1.3.4.O.bb2
4 files changed, 10 insertions, 4 deletions
diff --git a/recipes-core/xml-commons/jaxp1.3_1.4.01.bb b/recipes-core/xml-commons/jaxp1.3_1.4.01.bb
index 765b766..a6eeb57 100644
--- a/recipes-core/xml-commons/jaxp1.3_1.4.01.bb
+++ b/recipes-core/xml-commons/jaxp1.3_1.4.01.bb
@@ -11,7 +11,9 @@ LIC_FILES_CHKSUM = " \
SRC_URI = "http://archive.apache.org/dist/xml/commons/source/xml-commons-external-${PV}-src.tar.gz;subdir=${BPN}-${PV}"
-inherit java-library java-bootstrap-components
+inherit java-library
+
+DEPENDS = "fastjar-native"
JARFILENAME = "jaxp-1.3.jar"
ALTJARFILENAMES = "xml-apis.jar"
diff --git a/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb b/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb
index ca1f2f2..5853895 100644
--- a/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb
+++ b/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb
@@ -6,12 +6,12 @@ LIC_FILES_CHKSUM = "file://LICENSE.resolver.txt;md5=d229da563da18fe5d58cd95a6467
SRC_URI = "http://archive.apache.org/dist/xml/commons/xml-commons-resolver-${PV}.tar.gz"
-inherit java-library java-bootstrap-components
+inherit java-library
S = "${WORKDIR}/xml-commons-resolver-${PV}"
-DEPENDS = "jaxp1.3"
-DEPENDS_virtclass-native = "jaxp1.3-native"
+DEPENDS = "fastjar-native jaxp1.3"
+DEPENDS_virtclass-native = "fastjar-native jaxp1.3-native"
do_unpackpost() {
find src -exec \
diff --git a/recipes-core/xml-commons/xpp2_2.1.10.bb b/recipes-core/xml-commons/xpp2_2.1.10.bb
index 402d38d..d3baca4 100644
--- a/recipes-core/xml-commons/xpp2_2.1.10.bb
+++ b/recipes-core/xml-commons/xpp2_2.1.10.bb
@@ -9,6 +9,8 @@ S = "${WORKDIR}/PullParser${PV}"
inherit java-library
+DEPENDS = "fastjar-native virtual/javac-native"
+
do_compile() {
if [ -d build-oe ]; then
rm -rf build-oe
diff --git a/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb b/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb
index a472a0d..bedb8a9 100644
--- a/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb
+++ b/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb
@@ -8,6 +8,8 @@ SRC_URI = "http://www.extreme.indiana.edu/dist/java-repository/xpp3/distribution
inherit java-library
+DEPENDS = "fastjar-native virtual/javac-native"
+
PACKAGES = "libxpp3-xpath-java ${JPN}"
do_compile() {