aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb')
-rw-r--r--recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb b/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
index aa165f5..57827d9 100644
--- a/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
+++ b/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
FILESPATH =. "${FILE_DIRNAME}/patches-openjdk-7:"
-inherit distro_features_check
+inherit features_check
REQUIRED_DISTRO_FEATURES = "x11"
@@ -41,6 +41,7 @@ OEPATCHES = "\
file://build-hacks.patch \
file://fix_hotspot_crosscompile.patch \
file://icedtea-makefile-unzip.patch \
+ file://icedtea-m4-fix-xattr-include-path.patch \
"
ICEDTEAPATCHES = "\
@@ -50,6 +51,7 @@ ICEDTEAPATCHES = "\
file://icedtea-crosscompile-fix.patch;apply=no \
file://icedtea-xawt-crosscompile-fix.patch;apply=no \
file://icedtea-jdk-unzip.patch;apply=no \
+ file://icedtea-jdk-fix-xattr-include.patch;apply=no \
file://icedtea-dtrace-std_h.patch;apply=no \
file://icedtea-hotspot-fix-string-literal-marcos.patch;apply=no \
file://icedtea-flags-to-compile-with-GCC-6.patch;apply=no \
@@ -63,6 +65,7 @@ DISTRIBUTION_PATCHES = "\
patches/icedtea-crosscompile-fix.patch \
patches/icedtea-xawt-crosscompile-fix.patch \
patches/icedtea-jdk-unzip.patch \
+ patches/icedtea-jdk-fix-xattr-include.patch \
patches/icedtea-dtrace-std_h.patch \
patches/icedtea-hotspot-fix-string-literal-marcos.patch \
patches/icedtea-flags-to-compile-with-GCC-6.patch \
@@ -77,4 +80,4 @@ export DISTRIBUTION_PATCHES
# to avoid this error add -fpermissive
#
# NOTE: When updating the recipe, please check if this is still needed
-CFLAGS_append = " -Wno-error=deprecated-declarations -Wno-error=narrowing -fpermissive"
+CFLAGS:append = " -Wno-error=deprecated-declarations -Wno-error=narrowing -fpermissive"