aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/cacao/cacao-initial-native_0.98.bb (renamed from recipes-core/cacao/cacao-initial_0.98.bb)2
-rw-r--r--recipes-core/cacao/cacao_1.6.1.bb2
-rw-r--r--recipes-core/classpath/classpath-initial-native_0.93.bb (renamed from recipes-core/classpath/classpath-initial_0.93.bb)0
-rw-r--r--recipes-core/classpath/classpath-native_0.99.bb2
-rw-r--r--recipes-core/ecj/ecj-bootstrap-native.bb2
-rw-r--r--recipes-core/ecj/ecj-initial-native.bb (renamed from recipes-core/ecj/ecj-initial.bb)2
-rw-r--r--recipes-core/ecj/libecj-bootstrap-native_3.6.2.bb (renamed from recipes-core/ecj/libecj-bootstrap_3.6.2.bb)0
-rw-r--r--recipes-core/ecj/libecj-bootstrap.inc2
-rw-r--r--recipes-core/jamvm/jamvm-initial-native_1.4.5.bb (renamed from recipes-core/jamvm/jamvm-initial_1.4.5.bb)2
-rw-r--r--recipes-core/jamvm/jamvm.inc2
-rw-r--r--recipes-core/jikes/jikes-initial-native.bb (renamed from recipes-core/jikes/jikes-initial.bb)2
11 files changed, 9 insertions, 9 deletions
diff --git a/recipes-core/cacao/cacao-initial_0.98.bb b/recipes-core/cacao/cacao-initial-native_0.98.bb
index ad9436b..181faca 100644
--- a/recipes-core/cacao/cacao-initial_0.98.bb
+++ b/recipes-core/cacao/cacao-initial-native_0.98.bb
@@ -8,7 +8,7 @@ PROVIDES = "virtual/java-initial"
inherit native autotools-brokensep
-DEPENDS = "zlib-native libtool-native fastjar-native classpath-initial jikes-initial"
+DEPENDS = "zlib-native libtool-native fastjar-native classpath-initial-native jikes-initial-native"
SRC_URI = "\
http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.bz2; \
diff --git a/recipes-core/cacao/cacao_1.6.1.bb b/recipes-core/cacao/cacao_1.6.1.bb
index 2bd06c6..9f07946 100644
--- a/recipes-core/cacao/cacao_1.6.1.bb
+++ b/recipes-core/cacao/cacao_1.6.1.bb
@@ -4,7 +4,7 @@ LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
SECTION = "interpreters"
-DEPENDS_class-native = "zlib-native libtool-native ecj-initial fastjar-native classpath-native"
+DEPENDS_class-native = "zlib-native libtool-native ecj-initial-native fastjar-native classpath-native"
PROVIDES_class-native = "virtual/java-native"
DEPENDS = "zlib libtool classpath virtual/javac-native"
diff --git a/recipes-core/classpath/classpath-initial_0.93.bb b/recipes-core/classpath/classpath-initial-native_0.93.bb
index 0cfa693..0cfa693 100644
--- a/recipes-core/classpath/classpath-initial_0.93.bb
+++ b/recipes-core/classpath/classpath-initial-native_0.93.bb
diff --git a/recipes-core/classpath/classpath-native_0.99.bb b/recipes-core/classpath/classpath-native_0.99.bb
index ece10c3..02951b9 100644
--- a/recipes-core/classpath/classpath-native_0.99.bb
+++ b/recipes-core/classpath/classpath-native_0.99.bb
@@ -1,7 +1,7 @@
require classpath-native.inc
LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510"
-DEPENDS += "ecj-initial"
+DEPENDS += "ecj-initial-native"
PR = "${INC_PR}.0"
diff --git a/recipes-core/ecj/ecj-bootstrap-native.bb b/recipes-core/ecj/ecj-bootstrap-native.bb
index c9be269..e159c9d 100644
--- a/recipes-core/ecj/ecj-bootstrap-native.bb
+++ b/recipes-core/ecj/ecj-bootstrap-native.bb
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d
"
PR = "r1"
-DEPENDS = "libecj-bootstrap virtual/java-native"
+DEPENDS = "libecj-bootstrap-native virtual/java-native"
PROVIDES = "virtual/javac-native"
diff --git a/recipes-core/ecj/ecj-initial.bb b/recipes-core/ecj/ecj-initial-native.bb
index 45317a6..ed334ed 100644
--- a/recipes-core/ecj/ecj-initial.bb
+++ b/recipes-core/ecj/ecj-initial-native.bb
@@ -8,7 +8,7 @@ HOMEPAGE = "http://www.eclipse.org/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-DEPENDS = "libecj-bootstrap"
+DEPENDS = "libecj-bootstrap-native"
SRC_URI = "file://ecj-initial.in"
diff --git a/recipes-core/ecj/libecj-bootstrap_3.6.2.bb b/recipes-core/ecj/libecj-bootstrap-native_3.6.2.bb
index 51dbca0..51dbca0 100644
--- a/recipes-core/ecj/libecj-bootstrap_3.6.2.bb
+++ b/recipes-core/ecj/libecj-bootstrap-native_3.6.2.bb
diff --git a/recipes-core/ecj/libecj-bootstrap.inc b/recipes-core/ecj/libecj-bootstrap.inc
index cd9d90f..9fb4156 100644
--- a/recipes-core/ecj/libecj-bootstrap.inc
+++ b/recipes-core/ecj/libecj-bootstrap.inc
@@ -5,7 +5,7 @@ HOMEPAGE = "http://www.eclipse.org/"
LICENSE = "EPL-1.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/EPL-1.0;md5=57f8d5e2b3e98ac6e088986c12bf94e6"
-DEPENDS = "fastjar-native jikes-initial virtual/java-initial"
+DEPENDS = "fastjar-native jikes-initial-native virtual/java-initial"
INC_PR = "r5"
diff --git a/recipes-core/jamvm/jamvm-initial_1.4.5.bb b/recipes-core/jamvm/jamvm-initial-native_1.4.5.bb
index 4c64f6a..25b42b0 100644
--- a/recipes-core/jamvm/jamvm-initial_1.4.5.bb
+++ b/recipes-core/jamvm/jamvm-initial-native_1.4.5.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://jamvm.sourceforge.net/"
LICENSE = "GPL"
LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
-DEPENDS = "zlib-native classpath-initial jikes-initial libffi-native"
+DEPENDS = "zlib-native classpath-initial-native jikes-initial-native libffi-native"
PROVIDES = "virtual/java-initial"
diff --git a/recipes-core/jamvm/jamvm.inc b/recipes-core/jamvm/jamvm.inc
index 094b22b..5893cbc 100644
--- a/recipes-core/jamvm/jamvm.inc
+++ b/recipes-core/jamvm/jamvm.inc
@@ -4,7 +4,7 @@ LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
DEPENDS = "zlib classpath virtual/javac-native libffi"
-DEPENDS_virtclass-native = "zlib-native classpath-native ecj-initial libffi-native"
+DEPENDS_virtclass-native = "zlib-native classpath-native ecj-initial-native libffi-native"
RDEPENDS_${PN} = "classpath"
RDEPENDS_${PN}_virtclass-native = ""
diff --git a/recipes-core/jikes/jikes-initial.bb b/recipes-core/jikes/jikes-initial-native.bb
index 4e6e870..239dea3 100644
--- a/recipes-core/jikes/jikes-initial.bb
+++ b/recipes-core/jikes/jikes-initial-native.bb
@@ -1,7 +1,7 @@
SUMMARY = "Initial Java 1.4-compatible (and not higher) compiler"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
-DEPENDS = "jikes-native classpath-initial"
+DEPENDS = "jikes-native classpath-initial-native"
S = "${WORKDIR}"