aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-support-ivi
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support-ivi')
-rw-r--r--recipes-support-ivi/ecryptfs-utils/ecryptfs-utils_96.bb31
-rw-r--r--recipes-support-ivi/fuse/fuse-2.8.6/define_GNU_SOURCE.patch12
-rw-r--r--recipes-support-ivi/keyutils/keyutils/keyutils-arm-remove-m32-m64.patch19
-rw-r--r--recipes-support-ivi/keyutils/keyutils/keyutils_fix_library_install.patch30
-rw-r--r--recipes-support-ivi/keyutils/keyutils_1.5.5.bb15
-rw-r--r--recipes-support-ivi/libassuan/libassuan_1.0.1.bb23
-rw-r--r--recipes-support-ivi/libksba/libksba_1.0.1.bb16
-rw-r--r--recipes-support-ivi/ntp/files/ntp31
-rw-r--r--recipes-support-ivi/ntp/files/ntp-4.2.4_p6-nano.patch17
-rw-r--r--recipes-support-ivi/ntp/files/ntp.conf14
-rw-r--r--recipes-support-ivi/ntp/files/ntpd.service11
-rw-r--r--recipes-support-ivi/ntp/files/ntpdate49
-rw-r--r--recipes-support-ivi/ntp/files/ntpdate.service11
-rw-r--r--recipes-support-ivi/ntp/files/tickadj.c.patch32
-rw-r--r--recipes-support-ivi/ntp/ntp-ssl_4.2.6p3.bb11
-rw-r--r--recipes-support-ivi/ntp/ntp.inc32
16 files changed, 354 insertions, 0 deletions
diff --git a/recipes-support-ivi/ecryptfs-utils/ecryptfs-utils_96.bb b/recipes-support-ivi/ecryptfs-utils/ecryptfs-utils_96.bb
new file mode 100644
index 0000000..f1e6c07
--- /dev/null
+++ b/recipes-support-ivi/ecryptfs-utils/ecryptfs-utils_96.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "eCryptfs: A stacked cryptographic filesystem for Linux"
+SECTION = "base"
+LICENSE = "GPLv2"
+DEPENDS = "keyutils libgcrypt libpam"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
+
+SRC_URI = "https://launchpad.net/ecryptfs/trunk/96/+download/ecryptfs-utils_96.orig.tar.gz \
+ file://ecryptfs-fix-disable-nss.patch \
+ "
+SRC_URI[md5sum] = "4f92c9f6e8f62ac00ca7e2c4e480f1d7"
+SRC_URI[sha256sum] = "04c43b6e7a2f6b3644a24bcf718bfde6384e74bb4266c053ac78b9cc852f2c0c"
+
+
+inherit autotools
+
+EXTRA_OECONF += "--disable-nss --disable-pywrap --enable-openssl"
+EXTRA_OEMAKE += "'CFLAGS+= -lgcrypt '"
+
+FILES_${PN} += " \
+ ${libdir}/ecryptfs/* \
+ ${base_libdir}/security/pam_ecryptfs.so \
+ "
+
+FILES_${PN}-dbg += "${libdir}/ecryptfs/.debug \
+ ${base_libdir}/security/.debug \
+ "
+
+# Skip useless warning as we have /usr and / on the same partition
+WARN_QA = "ldflags useless-rpaths rpaths staticdev"
diff --git a/recipes-support-ivi/fuse/fuse-2.8.6/define_GNU_SOURCE.patch b/recipes-support-ivi/fuse/fuse-2.8.6/define_GNU_SOURCE.patch
new file mode 100644
index 0000000..74ccdba
--- /dev/null
+++ b/recipes-support-ivi/fuse/fuse-2.8.6/define_GNU_SOURCE.patch
@@ -0,0 +1,12 @@
+Index: fuse-2.8.6/util/fusermount.c
+===================================================================
+--- fuse-2.8.6.orig/util/fusermount.c 2011-09-13 00:23:14.000000000 -0700
++++ fuse-2.8.6/util/fusermount.c 2011-09-25 00:23:53.051019038 -0700
+@@ -7,6 +7,7 @@
+ */
+ /* This program does the mounting and unmounting of FUSE filesystems */
+
++#define _GNU_SOURCE
+ #include <config.h>
+
+ #include "mount_util.h"
diff --git a/recipes-support-ivi/keyutils/keyutils/keyutils-arm-remove-m32-m64.patch b/recipes-support-ivi/keyutils/keyutils/keyutils-arm-remove-m32-m64.patch
new file mode 100644
index 0000000..4da71ed
--- /dev/null
+++ b/recipes-support-ivi/keyutils/keyutils/keyutils-arm-remove-m32-m64.patch
@@ -0,0 +1,19 @@
+Index: keyutils-1.5.5/Makefile
+===================================================================
+--- keyutils-1.5.5.orig/Makefile 2011-12-20 11:05:10.000000000 +0200
++++ keyutils-1.5.5/Makefile 2011-12-20 11:06:27.000000000 +0200
+@@ -58,12 +58,12 @@
+ LNS := ln -sf
+
+ ifeq ($(BUILDFOR),32-bit)
+-CFLAGS += -m32
++#CFLAGS += -m32
+ LIBDIR := /usr/lib
+ USRLIBDIR := /usr/lib
+ else
+ ifeq ($(BUILDFOR),64-bit)
+-CFLAGS += -m64
++#CFLAGS += -m64
+ LIBDIR := /usr/lib
+ USRLIBDIR := /usr/lib
+ endif
diff --git a/recipes-support-ivi/keyutils/keyutils/keyutils_fix_library_install.patch b/recipes-support-ivi/keyutils/keyutils/keyutils_fix_library_install.patch
new file mode 100644
index 0000000..0b1185f
--- /dev/null
+++ b/recipes-support-ivi/keyutils/keyutils/keyutils_fix_library_install.patch
@@ -0,0 +1,30 @@
+Index: keyutils-1.5.5/Makefile
+===================================================================
+--- keyutils-1.5.5.orig/Makefile 2011-11-30 17:27:43.000000000 +0200
++++ keyutils-1.5.5/Makefile 2011-12-21 16:05:53.000000000 +0200
+@@ -59,13 +59,13 @@
+
+ ifeq ($(BUILDFOR),32-bit)
+ CFLAGS += -m32
+-LIBDIR := /lib
++LIBDIR := /usr/lib
+ USRLIBDIR := /usr/lib
+ else
+ ifeq ($(BUILDFOR),64-bit)
+ CFLAGS += -m64
+-LIBDIR := /lib64
+-USRLIBDIR := /usr/lib64
++LIBDIR := /usr/lib
++USRLIBDIR := /usr/lib
+ endif
+ endif
+
+@@ -152,7 +152,7 @@
+ $(INSTALL) -D $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(LIBNAME)
+ $(LNS) $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SONAME)
+ mkdir -p $(DESTDIR)$(USRLIBDIR)
+- $(LNS) $(LIBDIR)/$(SONAME) $(DESTDIR)$(USRLIBDIR)/$(DEVELLIB)
++ $(LNS) $(SONAME) $(DESTDIR)$(USRLIBDIR)/$(DEVELLIB)
+ $(INSTALL) -D keyctl $(DESTDIR)$(BINDIR)/keyctl
+ $(INSTALL) -D request-key $(DESTDIR)$(SBINDIR)/request-key
+ $(INSTALL) -D request-key-debug.sh $(DESTDIR)$(SHAREDIR)/request-key-debug.sh
diff --git a/recipes-support-ivi/keyutils/keyutils_1.5.5.bb b/recipes-support-ivi/keyutils/keyutils_1.5.5.bb
new file mode 100644
index 0000000..6c1da50
--- /dev/null
+++ b/recipes-support-ivi/keyutils/keyutils_1.5.5.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Linux Key Management Utilities"
+SECTION = "base"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENCE.GPL;md5=5f6e72824f5da505c1f4a7197f004b45"
+
+SRCREV = "5cd9d711f650e03685ba8bf2099b2df30cf6e71a"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/dhowells/keyutils.git;protocol=git \
+ file://keyutils_fix_library_install.patch \
+ "
+SRC_URI_append_arm += "file://keyutils-arm-remove-m32-m64.patch"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
diff --git a/recipes-support-ivi/libassuan/libassuan_1.0.1.bb b/recipes-support-ivi/libassuan/libassuan_1.0.1.bb
new file mode 100644
index 0000000..f5cd815
--- /dev/null
+++ b/recipes-support-ivi/libassuan/libassuan_1.0.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "IPC library used by GnuPG and GPGME"
+HOMEPAGE = "http://www.gnupg.org/related_software/libassuan/"
+BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
+
+LICENSE = "GPLv2 & LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://COPYING.LESSER;md5=a6f89e2100d9b6cdffcea4f398e37343 "
+
+DEPENDS = "libgpg-error pth"
+
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libassuan/libassuan-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "6109ea5c8c34ee5591afbd4618dd5ab4"
+SRC_URI[sha256sum] = "b928acbf04776803699748ae81f1a4e49c68f3102129248cd7562ce194b462b1"
+
+inherit autotools binconfig
+
+
+DEFAULT_PREFERENCE = "1"
+
+do_configure_prepend() {
+ sh autogen.sh
+}
diff --git a/recipes-support-ivi/libksba/libksba_1.0.1.bb b/recipes-support-ivi/libksba/libksba_1.0.1.bb
new file mode 100644
index 0000000..a028779
--- /dev/null
+++ b/recipes-support-ivi/libksba/libksba_1.0.1.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "KSBA is a library designed to build software basedon the X.509 and CMS protocols."
+
+HOMEPAGE = "http://www.gnupg.org/"
+SECTION = "system/libraries"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+DEPENDS = "libgcrypt libgpg-error"
+
+SRC_URI = "http://mirrors.dotsrc.org/gcrypt/libksba/libksba-1.0.1.tar.bz2"
+
+SRC_URI[md5sum] = "43646aa414f28e4962f8db138efbf249"
+SRC_URI[sha256sum] = "e8bc9709e28c6826f275da2107955587711dd88471e66cf492a4b3b36c074f71"
+
+inherit autotools gettext binconfig
diff --git a/recipes-support-ivi/ntp/files/ntp b/recipes-support-ivi/ntp/files/ntp
new file mode 100644
index 0000000..e943d66
--- /dev/null
+++ b/recipes-support-ivi/ntp/files/ntp
@@ -0,0 +1,31 @@
+#! /bin/sh
+
+FLAGS="defaults 23"
+
+test -f /usr/bin/ntpd || exit 0
+
+case "$1" in
+ start)
+ echo -n "Starting NTP server: ntpd"
+ start-stop-daemon --start --quiet --exec /usr/bin/ntpd
+ echo "."
+ ;;
+ stop)
+ echo -n "Stopping NTP server: ntpd"
+ start-stop-daemon --stop --quiet --exec /usr/bin/ntpd
+ echo "."
+ ;;
+ restart|force-reload)
+ echo -n "Restarting NTP server: ntpd... "
+ start-stop-daemon --stop --quiet --exec /usr/bin/ntpd
+ sleep 2
+ start-stop-daemon --start --quiet --exec /usr/bin/ntpd
+ echo "done."
+ ;;
+ *)
+ echo "Usage: /etc/init.d/ntp {start|stop|restart|force-reload}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes-support-ivi/ntp/files/ntp-4.2.4_p6-nano.patch b/recipes-support-ivi/ntp/files/ntp-4.2.4_p6-nano.patch
new file mode 100644
index 0000000..a5004f7
--- /dev/null
+++ b/recipes-support-ivi/ntp/files/ntp-4.2.4_p6-nano.patch
@@ -0,0 +1,17 @@
+--- a/include/ntp_syscall.h.orig 2009-05-19 16:44:55.048156467 -0400
++++ b/include/ntp_syscall.h 2009-05-19 16:46:19.293323686 -0400
+@@ -14,6 +14,14 @@
+ # include <sys/timex.h>
+ #endif
+
++#if defined(ADJ_NANO) && !defined(MOD_NANO)
++#define MOD_NANO ADJ_NANO
++#endif
++
++#if defined(ADJ_TAI) && !defined(MOD_TAI)
++#define MOD_TAI ADJ_TAI
++#endif
++
+ #ifndef NTP_SYSCALLS_LIBC
+ #ifdef NTP_SYSCALLS_STD
+ # define ntp_adjtime(t) syscall(SYS_ntp_adjtime, (t))
diff --git a/recipes-support-ivi/ntp/files/ntp.conf b/recipes-support-ivi/ntp/files/ntp.conf
new file mode 100644
index 0000000..5a12db2
--- /dev/null
+++ b/recipes-support-ivi/ntp/files/ntp.conf
@@ -0,0 +1,14 @@
+# This is the most basic ntp configuration file
+# The driftfile must remain in a place specific to this
+# machine - it records the machine specific clock error
+driftfile /etc/ntp.drift
+# This obtains a random server which will be close
+# (in IP terms) to the machine. Add other servers
+# as required, or change this.
+server pool.ntp.org
+# Using local hardware clock as fallback
+# Disable this when using ntpd -q -g -x as ntpdate or it will sync to itself
+server 127.127.1.0
+fudge 127.127.1.0 stratum 14
+# Defining a default security setting
+restrict default
diff --git a/recipes-support-ivi/ntp/files/ntpd.service b/recipes-support-ivi/ntp/files/ntpd.service
new file mode 100644
index 0000000..d349f9c
--- /dev/null
+++ b/recipes-support-ivi/ntp/files/ntpd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Network Time Service
+After=network.target
+
+[Service]
+Type=forking
+PIDFile=/run/ntpd.pid
+ExecStart=/usr/bin/ntpd -p /run/ntpd.pid
+
+[Install]
+WantedBy=multi-user.target
diff --git a/recipes-support-ivi/ntp/files/ntpdate b/recipes-support-ivi/ntp/files/ntpdate
new file mode 100644
index 0000000..6bc8fb1
--- /dev/null
+++ b/recipes-support-ivi/ntp/files/ntpdate
@@ -0,0 +1,49 @@
+#!/bin/sh
+
+PATH=/sbin:/bin:/usr/bin
+
+test -x /usr/bin/ntpdate || exit 0
+
+if test -f /etc/default/ntpdate ; then
+. /etc/default/ntpdate
+else
+NTPSERVERS="pool.ntp.org"
+fi
+
+test -n "$NTPSERVERS" || exit 0
+
+# This is a heuristic: The idea is that if a static interface is brought
+# up, that is a major event, and we can put in some extra effort to fix
+# the system time. Feel free to change this, especially if you regularly
+# bring up new network interfaces.
+if [ "$METHOD" = static ]; then
+ OPTS="-b"
+fi
+
+if [ "$METHOD" = loopback ]; then
+ exit 0
+fi
+
+(
+
+LOCKFILE=/var/lock/ntpdate
+
+# Avoid running more than one at a time
+if [ -x /usr/bin/lockfile-create ]; then
+ lockfile-create $LOCKFILE
+ lockfile-touch $LOCKFILE &
+ LOCKTOUCHPID="$!"
+fi
+
+if /usr/bin/ntpdate -s $OPTS $NTPSERVERS 2>/dev/null; then
+ if [ "$UPDATE_HWCLOCK" = "yes" ]; then
+ hwclock --systohc || :
+ fi
+fi
+
+if [ -x /usr/bin/lockfile-create ] ; then
+ kill $LOCKTOUCHPID
+ lockfile-remove $LOCKFILE
+fi
+
+) &
diff --git a/recipes-support-ivi/ntp/files/ntpdate.service b/recipes-support-ivi/ntp/files/ntpdate.service
new file mode 100644
index 0000000..97ebb3c
--- /dev/null
+++ b/recipes-support-ivi/ntp/files/ntpdate.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Network Time Service (one-shot ntpdate mode)
+Before=ntpd.service
+
+[Service]
+Type=oneshot
+ExecStart=/usr/bin/ntpd -q -g -x
+RemainAfterExit=yes
+
+[Install]
+WantedBy=multi-user.target
diff --git a/recipes-support-ivi/ntp/files/tickadj.c.patch b/recipes-support-ivi/ntp/files/tickadj.c.patch
new file mode 100644
index 0000000..b8bceda
--- /dev/null
+++ b/recipes-support-ivi/ntp/files/tickadj.c.patch
@@ -0,0 +1,32 @@
+Index: ntp-4.2.2p3-r0/ntp-4.2.2p3/util/tickadj.c
+===================================================================
+--- ntp-4.2.2p3/util/tickadj.c 2004-02-25 06:58:33.000000000 +0100
++++ ntp-4.2.2p3/util/tickadj.c 2007-07-07 01:00:54.000000000 +0200
+@@ -21,7 +21,8 @@
+ # include <unistd.h>
+ #endif /* HAVE_UNISTD_H */
+
+-#ifdef HAVE___ADJTIMEX /* Linux */
++/* proper handling here has been moved to upstream ntp bugzilla */
++#ifdef linux
+
+ #include <sys/timex.h>
+ struct timex txc;
+@@ -91,7 +92,7 @@
+ }
+
+ if (!errflg) {
+- if (__adjtimex(&txc) < 0)
++ if (adjtimex(&txc) < 0)
+ perror("adjtimex");
+ else if (!quiet)
+ printf("tick = %ld\ntick_adj = %d\n",
+@@ -146,7 +147,7 @@
+ #endif
+ }
+
+- if (__adjtimex(&txc) < 0)
++ if (adjtimex(&txc) < 0)
+ {
+ perror("adjtimex");
+ }
diff --git a/recipes-support-ivi/ntp/ntp-ssl_4.2.6p3.bb b/recipes-support-ivi/ntp/ntp-ssl_4.2.6p3.bb
new file mode 100644
index 0000000..735f92b
--- /dev/null
+++ b/recipes-support-ivi/ntp/ntp-ssl_4.2.6p3.bb
@@ -0,0 +1,11 @@
+require ntp_${PV}.bb
+DEPENDS = "openssl"
+
+S = "${WORKDIR}/ntp-${PV}"
+
+EXTRA_OECONF = "--with-openssl-libdir=${STAGING_LIBDIR} \
+ --with-openssl-incdir=${STAGING_INCDIR}/openssl"
+
+
+SRC_URI[md5sum] = "98e16c7aa4ecd4c004b51bff18962e95"
+SRC_URI[sha256sum] = "9f4a5271a285d390c9225e3ea28f70049ea377d30fc6de4659007cfff278671a"
diff --git a/recipes-support-ivi/ntp/ntp.inc b/recipes-support-ivi/ntp/ntp.inc
new file mode 100644
index 0000000..bb48274
--- /dev/null
+++ b/recipes-support-ivi/ntp/ntp.inc
@@ -0,0 +1,32 @@
+DESCRIPTION = "The Network Time Protocol (NTP) is used to \
+synchronize the time of a computer client or server to \
+another server or reference time source, such as a radio \
+or satellite receiver or modem."
+HOMEPAGE = "http://ntp.isc.org/bin/view/Main/WebHome"
+SECTION = "console/network"
+LICENSE = "ntp"
+LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=fea4b50c33b18c2194b4b1c9ca512670"
+RSUGGESTS_${PN} = "iana-etc"
+
+SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/${P}.tar.gz \
+ file://ipv6only-workaround.patch \
+ file://ntpd \
+ file://ntp.conf \
+ file://ntpdate \
+ file://ntpd.service \
+"
+
+inherit autotools
+
+INITSCRIPT_NAME = "ntpd"
+# No dependencies, so just go in at the standard level (20)
+INITSCRIPT_PARAMS = "defaults"
+
+# The ac_cv_header_readline_history is to stop ntpdc depending on either
+# readline or curses
+EXTRA_OECONF = "--without-openssl --without-crypto ac_cv_header_readline_history_h=no"
+CFLAGS_append = " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
+
+PACKAGES += "ntpdate ${PN}-bin ${PN}-tickadj ${PN}-utils"
+# NOTE: you don't need ntpdate, use "ntpd -q -g -x"
+# or the ntpdate systemd service