aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/intltool/intltool-0.50.0/use-nativeperl.patch20
-rw-r--r--recipes-devtools/intltool/intltool.inc20
-rw-r--r--recipes-devtools/intltool/intltool_0.50.0.bb19
-rw-r--r--recipes-devtools/qemu/qemu-2012.01/glflags.patch15
-rw-r--r--recipes-devtools/qemu/qemu-2012.01/larger_default_ram_size.patch22
-rw-r--r--recipes-devtools/qemu/qemu-2012.01/no-strip.patch19
-rw-r--r--recipes-devtools/qemu/qemu_2012.01.bb35
7 files changed, 150 insertions, 0 deletions
diff --git a/recipes-devtools/intltool/intltool-0.50.0/use-nativeperl.patch b/recipes-devtools/intltool/intltool-0.50.0/use-nativeperl.patch
new file mode 100644
index 0000000..209861c
--- /dev/null
+++ b/recipes-devtools/intltool/intltool-0.50.0/use-nativeperl.patch
@@ -0,0 +1,20 @@
+OE has perl binary as 'nativeperl' in native sysroot so we look for it
+in order to avoid intltool searching and finding perl from /usr/bin
+on build system which may not have all the modules that it needs.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Inappropriate [OE specific]
+Index: intltool-0.40.6/intltool.m4
+===================================================================
+--- intltool-0.40.6.orig/intltool.m4 2009-02-14 14:12:28.000000000 -0800
++++ intltool-0.40.6/intltool.m4 2011-08-09 08:07:16.427347846 -0700
+@@ -110,7 +110,7 @@
+ AC_MSG_ERROR([GNU gettext tools not found; required for intltool])
+ fi
+
+-AC_PATH_PROG(INTLTOOL_PERL, perl)
++AC_PATH_PROG(INTLTOOL_PERL, nativeperl)
+ if test -z "$INTLTOOL_PERL"; then
+ AC_MSG_ERROR([perl not found])
+ fi
diff --git a/recipes-devtools/intltool/intltool.inc b/recipes-devtools/intltool/intltool.inc
new file mode 100644
index 0000000..5b7d69a
--- /dev/null
+++ b/recipes-devtools/intltool/intltool.inc
@@ -0,0 +1,20 @@
+DESCRIPTION = "Utility scripts for internationalizing XML"
+SECTION = "devel"
+LICENSE = "GPLv2"
+
+URLV="${@'.'.join(d.getVar('PV',1).split('.')[0:2])}"
+SRC_URI = "http://launchpad.net/intltool/trunk/0.50.0/+download/intltool-0.50.0.tar.gz"
+S = "${WORKDIR}/intltool-${PV}"
+
+DEPENDS = "libxml-parser-perl-native"
+DEPENDS_virtclass-native = "libxml-parser-perl-native"
+#RDEPENDS_${PN} = "libxml-parser-perl"
+RRECOMMENDS_${PN} = "perl-modules"
+RRECOMMENDS_${PN}_virtclass-native = ""
+
+inherit autotools pkgconfig perlnative
+
+export PERL = "${bindir}/env perl"
+PERL_virtclass-native = "/usr/bin/env nativeperl"
+
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/intltool/intltool_0.50.0.bb b/recipes-devtools/intltool/intltool_0.50.0.bb
new file mode 100644
index 0000000..e3cfe05
--- /dev/null
+++ b/recipes-devtools/intltool/intltool_0.50.0.bb
@@ -0,0 +1,19 @@
+require intltool.inc
+LICENSE="GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+PR = "r6"
+
+SRC_URI_append = " file://intltool-nowarn-0.50.0.patch \
+ ${NATIVEPATCHES} \
+ "
+
+#
+# All of the intltool scripts have the correct paths to perl already
+# embedded into them and can find perl fine, so we add the remove xml-check
+# in the intltool.m4 via the remove-xml-check.patch
+NATIVEPATCHES = "file://noperlcheck.patch \
+ file://remove-xml-check.patch"
+NATIVEPATCHES_virtclass-native = "file://use-nativeperl.patch"
+
+SRC_URI[md5sum] = "0da9847a60391ca653df35123b1f7cc0"
+SRC_URI[sha256sum] = "dccfb0b7dd35a170130e8934bfd30c29da6ae73bcd3ca4ba71317c977b2893d6"
diff --git a/recipes-devtools/qemu/qemu-2012.01/glflags.patch b/recipes-devtools/qemu/qemu-2012.01/glflags.patch
new file mode 100644
index 0000000..0814675
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-2012.01/glflags.patch
@@ -0,0 +1,15 @@
+Upstream-Status: Inappropriate [configuration]
+
+Index: qemu-0.14.0/Makefile.target
+===================================================================
+--- qemu-0.14.0.orig/Makefile.target 2011-04-04 12:12:19.142871742 +0100
++++ qemu-0.14.0/Makefile.target 2011-04-04 12:12:21.772871742 +0100
+@@ -362,7 +362,7 @@
+
+ monitor.o: hmp-commands.h qmp-commands.h
+
+-LIBS += -lGL -lGLU
++LIBS += -lGL
+
+ $(obj-y) $(obj-$(TARGET_BASE_ARCH)-y): $(GENERATED_HEADERS)
+
diff --git a/recipes-devtools/qemu/qemu-2012.01/larger_default_ram_size.patch b/recipes-devtools/qemu/qemu-2012.01/larger_default_ram_size.patch
new file mode 100644
index 0000000..be8af8e
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-2012.01/larger_default_ram_size.patch
@@ -0,0 +1,22 @@
+This patch is taken from debian. 128M is too less sometimes if distro
+with lot of packages is booted so this patch raises the default to 384M
+
+It has not been applied to upstream qemu
+
+Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+
+Index: qemu-0.14.0/vl.c
+===================================================================
+--- qemu-0.14.0.orig/vl.c
++++ qemu-0.14.0/vl.c
+@@ -168,7 +168,7 @@ int main(int argc, char **argv)
+ //#define DEBUG_NET
+ //#define DEBUG_SLIRP
+
+-#define DEFAULT_RAM_SIZE 128
++#define DEFAULT_RAM_SIZE 384
+
+ #define MAX_VIRTIO_CONSOLES 1
+
diff --git a/recipes-devtools/qemu/qemu-2012.01/no-strip.patch b/recipes-devtools/qemu/qemu-2012.01/no-strip.patch
new file mode 100644
index 0000000..25e42da
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-2012.01/no-strip.patch
@@ -0,0 +1,19 @@
+Subject: [PATCH] Upstream-Status: Inappropriate [configuration]
+
+---
+ Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index ffd3364..38d8352 100644
+--- a/Makefile
++++ b/Makefile
+@@ -288,7 +288,7 @@ install-sysconfig:
+ install: all $(if $(BUILD_DOCS),install-doc) install-sysconfig
+ $(INSTALL_DIR) "$(DESTDIR)$(bindir)"
+ ifneq ($(TOOLS),)
+- $(INSTALL_PROG) $(STRIP_OPT) $(TOOLS) "$(DESTDIR)$(bindir)"
++ $(INSTALL_PROG) $(TOOLS) "$(DESTDIR)$(bindir)"
+ endif
+ ifneq ($(BLOBS),)
+ $(INSTALL_DIR) "$(DESTDIR)$(datadir)"
diff --git a/recipes-devtools/qemu/qemu_2012.01.bb b/recipes-devtools/qemu/qemu_2012.01.bb
new file mode 100644
index 0000000..45b5773
--- /dev/null
+++ b/recipes-devtools/qemu/qemu_2012.01.bb
@@ -0,0 +1,35 @@
+require recipes-devtools/qemu/qemu.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
+ file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
+
+PR = "r0"
+
+FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
+FILESDIR = "${WORKDIR}"
+
+# Tag 2012.01
+SRCREV = "4b6667af6cd1a58f4d43f3baae432723f47d28fb"
+
+SRC_URI = "\
+ git://git.linaro.org/qemu/qemu-linaro.git;protocol=git \
+ file://powerpc_rom.bin \
+ file://no-strip.patch \
+ file://fallback-to-safe-mmap_min_addr.patch \
+ file://larger_default_ram_size.patch \
+ "
+# Only use the GL passthrough patches for native/nativesdk versions
+QEMUGLPATCHES = "\
+ "
+SRC_URI_append_virtclass-native = "\
+ ${QEMUGLPATCHES} \
+ "
+
+SRC_URI_append_virtclass-nativesdk = "\
+ ${QEMUGLPATCHES} \
+ file://glflags.patch \
+ "
+#SRC_URI[md5sum] = "34f17737baaf1b3495c89cd6d4a607ed"
+#SRC_URI[sha256sum] = "7705b14d9b8e4df4a0b1790980e618084261e8daef0672a1aa7a830a0f3db5ba"
+
+S = "${WORKDIR}/git" \ No newline at end of file