aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core-ivi/busybox/busybox-1.19.3
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core-ivi/busybox/busybox-1.19.3')
-rw-r--r--recipes-core-ivi/busybox/busybox-1.19.3/B921600.patch24
-rw-r--r--recipes-core-ivi/busybox/busybox-1.19.3/busybox-1.19.3-getty.patch17
-rw-r--r--recipes-core-ivi/busybox/busybox-1.19.3/busybox-appletlib-dependency.patch37
-rw-r--r--recipes-core-ivi/busybox/busybox-1.19.3/get_header_tar.patch22
-rw-r--r--recipes-core-ivi/busybox/busybox-1.19.3/udhcpscript.patch24
5 files changed, 124 insertions, 0 deletions
diff --git a/recipes-core-ivi/busybox/busybox-1.19.3/B921600.patch b/recipes-core-ivi/busybox/busybox-1.19.3/B921600.patch
new file mode 100644
index 0000000..47692ba
--- /dev/null
+++ b/recipes-core-ivi/busybox/busybox-1.19.3/B921600.patch
@@ -0,0 +1,24 @@
+Upstream-Status: Inappropriate [configuration]
+
+# copy commit message from OE as the patch comment:
+# commit 5b1ed09b1ab1a60a28a76e4658bc9957cd361b5d
+# Author: Valentin Longchamp <valentin.longchamp@epfl.ch>
+# Date: Mon Dec 8 14:43:23 2008 +0100
+
+# busybox: added support for 921600 speed of serial line
+#
+# above comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-06
+
+diff -upNr busybox-1.7.2/libbb/speed_table.c busybox-1.7.2-921600/libbb/speed_table.c
+--- busybox-1.7.2/libbb/speed_table.c 2007-09-03 13:48:41.000000000 +0200
++++ busybox-1.7.2-921600/libbb/speed_table.c 2008-10-09 16:23:26.269592899 +0200
+@@ -52,6 +52,9 @@ static const struct speed_map speeds[] =
+ #ifdef B460800
+ {B460800, 460800/256 + 0x8000U},
+ #endif
++#ifdef B921600
++ {B921600, 921600/256 + 0x8000U},
++#endif
+ };
+
+ enum { NUM_SPEEDS = ARRAY_SIZE(speeds) };
diff --git a/recipes-core-ivi/busybox/busybox-1.19.3/busybox-1.19.3-getty.patch b/recipes-core-ivi/busybox/busybox-1.19.3/busybox-1.19.3-getty.patch
new file mode 100644
index 0000000..d6d15b2
--- /dev/null
+++ b/recipes-core-ivi/busybox/busybox-1.19.3/busybox-1.19.3-getty.patch
@@ -0,0 +1,17 @@
+Upstream-Status: Backport
+
+Patch is taken from upstream
+http://busybox.net/downloads/fixes-1.19.3/busybox-1.19.3-getty.patch
+
+--- busybox-1.19.3/loginutils/getty.c
++++ busybox-1.19.3-getty/loginutils/getty.c
+@@ -271,7 +271,9 @@ static void termios_init(int speed)
+ #ifdef CMSPAR
+ | CMSPAR /* mark or space parity */
+ #endif
++#ifdef CBAUD
+ | CBAUD /* (output) baud rate */
++#endif
+ #ifdef CBAUDEX
+ | CBAUDEX /* (output) baud rate */
+ #endif
diff --git a/recipes-core-ivi/busybox/busybox-1.19.3/busybox-appletlib-dependency.patch b/recipes-core-ivi/busybox/busybox-1.19.3/busybox-appletlib-dependency.patch
new file mode 100644
index 0000000..2606a2c
--- /dev/null
+++ b/recipes-core-ivi/busybox/busybox-1.19.3/busybox-appletlib-dependency.patch
@@ -0,0 +1,37 @@
+Upstream-Status: Pending
+
+# copy commit message from OE as the patch comment:
+# commit 98c24291aa165f53423c27ae033831ce0b3bb676
+# Author: Roman I Khimov <khimov@altell.ru>
+# Date: Thu Mar 26 23:03:58 2009 +0000
+#
+# busybox: update appletlib dependency patch
+#
+# Previous version still failed from time to time on clean-start builds
+# with 4 bitbake threads and '-j16'. Building busybox as sole target worked
+# well.
+#
+# The reason is that previous version introduced a race between applets make
+# processes spawned from top-level Makefile and from libbb Makefile.
+#
+# Fix it with high-level dependency that doesn't create races.
+#
+# Signed-off-by: Koen Kooi <koen@openembedded.org>
+#
+# above comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-06
+
+Index: busybox-1.13.2/Makefile
+===================================================================
+--- busybox-1.13.2.orig/Makefile 2009-03-19 15:44:37.419270265 +0300
++++ busybox-1.13.2/Makefile 2009-03-19 15:45:57.737521296 +0300
+@@ -471,6 +471,10 @@
+ util-linux/ \
+ util-linux/volume_id/ \
+
++# Lib interdeps
++# libbb uses headers generated in applets
++libbb: applets
++
+ endif # KBUILD_EXTMOD
+
+ ifeq ($(dot-config),1)
diff --git a/recipes-core-ivi/busybox/busybox-1.19.3/get_header_tar.patch b/recipes-core-ivi/busybox/busybox-1.19.3/get_header_tar.patch
new file mode 100644
index 0000000..1ea4396
--- /dev/null
+++ b/recipes-core-ivi/busybox/busybox-1.19.3/get_header_tar.patch
@@ -0,0 +1,22 @@
+Upstream-Status: Pending
+
+# copy commit message from OE as the patch comment:
+# commit 5a0e1d473ca7aca5ffefffe9a2ec44ae7a1f35bc
+# Author: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
+# Date: Wed Feb 11 22:40:21 2009 +0100
+#
+# busybox: fix tar problem with filenames that are exactly 100 bytes
+#
+# above comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-06
+
+--- busybox-1.13.2/archival/libarchive/get_header_tar.c.orig 2008-11-09 18:28:02.000000000 +0100
++++ busybox-1.13.2/archival/libarchive/get_header_tar.c 2009-02-11 22:34:52.000000000 +0100
+@@ -252,6 +252,8 @@
+ file_header->name = concat_path_file(tar.prefix, tar.name);
+ } else
+ file_header->name = xstrdup(tar.name);
++ if (strlen(file_header->name) > 100)
++ file_header->name[100] = 0;
+ }
+
+ /* Set bits 12-15 of the files mode */
diff --git a/recipes-core-ivi/busybox/busybox-1.19.3/udhcpscript.patch b/recipes-core-ivi/busybox/busybox-1.19.3/udhcpscript.patch
new file mode 100644
index 0000000..a40b8f5
--- /dev/null
+++ b/recipes-core-ivi/busybox/busybox-1.19.3/udhcpscript.patch
@@ -0,0 +1,24 @@
+Upstream-Status: Pending
+
+# copy commit message from OE as the patch comment
+# commit c9bb6478a873d6de4c8a0e712435ac9a658a345d
+# Author: Holger Schurig <schurig@mn-solutions.de>
+# Date: Wed Sep 29 08:29:58 2004 +0000
+#
+# udhcpscript: fixes the "deleting routers" error message in case of no existing default routes
+#
+# Above comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-06
+
+Index: busybox-1.15.1/examples/udhcp/simple.script
+===================================================================
+--- busybox-1.15.1.orig/examples/udhcp/simple.script 2009-09-12 17:55:36.000000000 +0200
++++ busybox-1.15.1/examples/udhcp/simple.script 2009-09-16 22:51:06.599693412 +0200
+@@ -22,7 +22,7 @@ case "$1" in
+
+ if [ -n "$router" ] ; then
+ echo "Deleting routers"
+- while route del default gw 0.0.0.0 dev $interface ; do
++ while route del default gw 0.0.0.0 dev $interface 2>/dev/null ; do
+ :
+ done
+