aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi/recipes-extended/dlt-daemon
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi/recipes-extended/dlt-daemon')
-rw-r--r--meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch29
-rw-r--r--meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/modify_systemd_config_dir.patch13
-rw-r--r--meta-ivi/recipes-extended/dlt-daemon/dlt-daemon_2.9.1.bb55
3 files changed, 97 insertions, 0 deletions
diff --git a/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch b/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch
new file mode 100644
index 0000000..45a2deb
--- /dev/null
+++ b/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch
@@ -0,0 +1,29 @@
+From 5ec45ad3942e55d83fd0b13ef4bafa39a54e0578 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Erik=20Bot=C3=B6?= <erik.boto@pelagicore.com>
+Date: Fri, 4 Apr 2014 10:59:18 +0200
+Subject: [PATCH] Fix build with systemd >= 209
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Erik Botö <erik.boto@pelagicore.com>
+---
+ src/system/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/system/CMakeLists.txt b/src/system/CMakeLists.txt
+index d78b2e9..b04e54b 100644
+--- a/src/system/CMakeLists.txt
++++ b/src/system/CMakeLists.txt
+@@ -23,7 +23,7 @@ set(dlt_system_SRCS dlt-system.c dlt-system-options.c dlt-system-process-handlin
+ dlt-system-syslog.c dlt-system-watchdog.c dlt-system-journal.c)
+ add_executable(dlt-system ${dlt_system_SRCS} ${systemd_SRCS})
+ if(WITH_SYSTEMD_JOURNAL)
+- target_link_libraries(dlt-system dlt z systemd-journal systemd-id128)
++ target_link_libraries(dlt-system dlt z systemd)
+ else(WITH_SYSTEMD_JOURNAL)
+ target_link_libraries(dlt-system dlt z)
+ endif(WITH_SYSTEMD_JOURNAL)
+--
+1.9.1
+
diff --git a/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/modify_systemd_config_dir.patch b/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/modify_systemd_config_dir.patch
new file mode 100644
index 0000000..b1c3ea2
--- /dev/null
+++ b/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/modify_systemd_config_dir.patch
@@ -0,0 +1,13 @@
+Index: git/systemd/CMakeLists.txt
+===================================================================
+--- git.orig/systemd/CMakeLists.txt 2013-12-03 21:32:52.000000000 +0200
++++ git/systemd/CMakeLists.txt 2013-12-03 21:33:26.000000000 +0200
+@@ -16,7 +16,7 @@
+
+ if(WITH_SYSTEMD)
+
+- set(SYSTEMD_CONFIGURATIONS_FILES_DIR ${CMAKE_INSTALL_PREFIX}/lib/systemd/system )
++ set(SYSTEMD_CONFIGURATIONS_FILES_DIR /lib/systemd/system )
+
+ if(WITH_SYSTEMD_WATCHDOG)
+ set( DLT_WatchdogSec 2 )
diff --git a/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon_2.9.1.bb b/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon_2.9.1.bb
new file mode 100644
index 0000000..73abdb1
--- /dev/null
+++ b/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon_2.9.1.bb
@@ -0,0 +1,55 @@
+SUMMARY = "Diagnostic Log and Trace"
+DESCRIPTION = "This component provides a standardised log and trace interface, based on \
+ thestandardised protocol specified in the AUTOSAR standard 4.0 DLT.This \
+ component can be used by GENIVI components and other applications aslogging \
+ facility providing \
+ - the DLT shared library \
+ - the DLT daemon, including startup scripts \
+ - the DLT daemon adaptors- the DLT client console utilities \
+ - the DLT test applications \
+ "
+HOMEPAGE = "https://www.genivi.org/"
+SECTION = "console/utils"
+
+inherit gzipnative
+
+LICENSE = "MPLv2"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE.txt;md5=99ba60c3fad7eaf8c56bca6dd75cba09 \
+ file://MPL.txt;md5=ccdb2761cef70c8b2612624c323f89dc \
+ "
+
+DEPENDS = "zlib"
+
+SRCREV = "6ab10c022d4464628fc2b848b5a56bf1eaafe857"
+PR = "r2"
+
+SRC_URI = "git://git.projects.genivi.org/${PN}.git \
+ file://modify_systemd_config_dir.patch \
+ file://0001-Fix-build-with-systemd-209.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+inherit autotools gettext cmake
+
+FILES_${PN}-doc += "/usr/share/*"
+FILES_${PN}-systemd += "${systemd_unitdir}/system/"
+
+PACKAGES =+ "${PN}-systemd"
+
+EXTRA_OECMAKE = "-DWITH_SYSTEMD=ON"
+
+# Remove "User=genivi" option from systemd services
+# as there is no such username
+do_install_append() {
+ sed -i '/User/d' ${D}/${systemd_unitdir}/system/*.service
+
+ if [ ${@base_contains('EXTRA_OECMAKE', '-DWITH_SYSTEMD=ON', 'yes', 'no', d)} = yes ]; then
+ # Install the required systemd services links
+ install -d ${D}${base_libdir}/systemd/system/basic.target.wants
+ ln -sf ../dlt.service ${D}${base_libdir}/systemd/system/basic.target.wants/dlt.service
+ ln -sf ../dlt-system.service ${D}${base_libdir}/systemd/system/basic.target.wants/dlt-system.service
+ fi
+
+}