aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi-test/recipes-extended/common-api
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi-test/recipes-extended/common-api')
-rw-r--r--meta-ivi-test/recipes-extended/common-api/capicxx-perf/capicxx-perf_t.inc15
-rw-r--r--meta-ivi-test/recipes-extended/common-api/capicxx-perf_git.bb6
-rw-r--r--meta-ivi-test/recipes-extended/common-api/common-api-test/common-api-test_t.inc17
-rw-r--r--meta-ivi-test/recipes-extended/common-api/common-api-test_3.1.5.bb6
4 files changed, 42 insertions, 2 deletions
diff --git a/meta-ivi-test/recipes-extended/common-api/capicxx-perf/capicxx-perf_t.inc b/meta-ivi-test/recipes-extended/common-api/capicxx-perf/capicxx-perf_t.inc
new file mode 100644
index 0000000..2503c10
--- /dev/null
+++ b/meta-ivi-test/recipes-extended/common-api/capicxx-perf/capicxx-perf_t.inc
@@ -0,0 +1,15 @@
+#!/bin/sh
+get_list() {
+ return 1
+}
+
+get_title() {
+ echo "Common API C++ test code"
+}
+
+run_1() {
+ /opt/tests/capicxx-perf/capicxx-server &
+ /opt/tests/capicxx-perf/capicxx-client
+ kill -9 `pidof capicxx-server`
+ sleep 1
+}
diff --git a/meta-ivi-test/recipes-extended/common-api/capicxx-perf_git.bb b/meta-ivi-test/recipes-extended/common-api/capicxx-perf_git.bb
index 2263647..f468650 100644
--- a/meta-ivi-test/recipes-extended/common-api/capicxx-perf_git.bb
+++ b/meta-ivi-test/recipes-extended/common-api/capicxx-perf_git.bb
@@ -6,7 +6,9 @@ LIC_FILES_CHKSUM = \
PR = "r0"
SRCREV = "2eacc9d7fb76957e9a5450a559675fddf0a95ce2"
-SRC_URI = "git://github.com/GENIVI/capic-poc.git"
+SRC_URI = "git://github.com/GENIVI/capic-poc.git \
+ file://${BPN}_t.inc \
+ "
S = "${WORKDIR}/git/test/capicxx-perf"
DEPENDS = "common-api-c++ common-api-c++-dbus capicxx-core-native capicxx-dbus-native"
@@ -31,4 +33,6 @@ do_install_append() {
mv ${D}/usr/bin/* ${_DEST}
rmdir ${D}/usr/bin
rmdir ${D}/usr
+
+ install -m 0755 ${WORKDIR}/${BPN}_t.inc ${D}/opt/tests/${PN}
}
diff --git a/meta-ivi-test/recipes-extended/common-api/common-api-test/common-api-test_t.inc b/meta-ivi-test/recipes-extended/common-api/common-api-test/common-api-test_t.inc
new file mode 100644
index 0000000..8b304f1
--- /dev/null
+++ b/meta-ivi-test/recipes-extended/common-api/common-api-test/common-api-test_t.inc
@@ -0,0 +1,17 @@
+#!/bin/sh
+get_list() {
+ return 1
+}
+
+get_title() {
+ echo "Common API C++ runtime"
+}
+
+run_1() {
+ /opt/tests/common-api-test/E05ManagerService &
+ /opt/tests/common-api-test/E05ManagerClient &
+ sleep 5
+ kill -9 `pidof E05ManagerClient`
+ kill -9 `pidof E05ManagerService`
+ sleep 1
+}
diff --git a/meta-ivi-test/recipes-extended/common-api/common-api-test_3.1.5.bb b/meta-ivi-test/recipes-extended/common-api/common-api-test_3.1.5.bb
index a286502..04b8154 100644
--- a/meta-ivi-test/recipes-extended/common-api/common-api-test_3.1.5.bb
+++ b/meta-ivi-test/recipes-extended/common-api/common-api-test_3.1.5.bb
@@ -4,12 +4,13 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
PR = "r0"
-inherit autotools cmake pkgconfig
+inherit cmake pkgconfig
DEPENDS += " common-api-c++ common-api-c++-dbus glib-2.0"
SRC_URI = " \
file://${PN}-${PV}.tar.gz \
+ file://${BPN}_t.inc \
"
S = "${WORKDIR}/${PN}"
@@ -22,6 +23,7 @@ FILES_${PN} = " \
/opt/tests/${PN}/*/commonapi4dbus.ini \
/opt/tests/${PN}/*/*Client \
/opt/tests/${PN}/*/*Service \
+ /opt/tests/${PN}/${BPN}_t.inc \
${libdir}/*.so \
"
@@ -60,4 +62,6 @@ do_install() {
fi
install -m 0755 ${_BIN}/${i}/lib${i}-dbus.so ${D}${libdir}
done
+
+ install -m 0755 ${WORKDIR}/${BPN}_t.inc ${D}/opt/tests/${PN}
}