aboutsummaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2020.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2020.4.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2020.4.bb61
1 files changed, 0 insertions, 61 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2020.4.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2020.4.bb
deleted file mode 100644
index 31bdb412..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2020.4.bb
+++ /dev/null
@@ -1,61 +0,0 @@
-SUMMARY = "OpenVINO(TM) Toolkit - Open Model Zoo repository"
-HOMEPAGE = "https://github.com/opencv/open_model_zoo"
-DESCRIPTION = "This repository includes optimized deep learning \
-models and a set of demos to expedite development of high-performance \
-deep learning inference applications."
-
-SRC_URI = "git://github.com/opencv/open_model_zoo.git;protocol=git;branch=master \
- file://0001-use-oe-gflags.patch \
- "
-
-SRCREV = "366130da8fc27dd4d896639cb526a079acc07831"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://../LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
-"
-
-inherit cmake
-
-S = "${WORKDIR}/git/demos"
-
-DEPENDS += "openvino-inference-engine opencv gflags"
-
-RDEPENDS_${PN} += " \
- python3-decorator \
- python3-defusedxml \
- python3-networkx \
- python3-protobuf \
- python3-test-generator \
- python3-requests \
- python3-pyyaml \
-"
-
-COMPATIBLE_HOST = '(x86_64).*-linux'
-
-EXTRA_OECMAKE += " \
- -DIE_MAIN_SOURCE_DIR=${B} \
- -DENABLE_SAMPLES=ON \
- -DIE_INCLUDE_DIR=${STAGING_EXECPREFIXDIR} \
- -DIE_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine.so \
- -DIE_C_API_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine_c_api.so \
- -DIE_LEGACY_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine_legacy.so \
- -DIE_NN_BUILDER_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine_nn_builder.so \
- -DIE_ROOT_DIR=${WORKDIR}/InferenceEngine \
-"
-
-do_configure_prepend(){
- mkdir -p ${WORKDIR}/InferenceEngine/share
- cp ${STAGING_LIBDIR}/cmake/InferenceEngine/* ${WORKDIR}/InferenceEngine/share/
-}
-
-do_install(){
- install -d ${D}${libdir}
- install -d ${D}${bindir}
- install -d ${D}${datadir}/openvino/open-model-zoo/tools
- cp -rf ${WORKDIR}/build/intel64/Release/lib/*.a ${D}${libdir}
- cp -rf ${WORKDIR}/build/intel64/Release/*_demo* ${D}${bindir}
- cp -rf ${WORKDIR}/git/models ${D}${datadir}/openvino/open-model-zoo
- cp -rf ${WORKDIR}/git/tools/downloader ${D}${datadir}/openvino/open-model-zoo/tools
-}
-
-FILES_${PN} += "${datadir}/openvino"