aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-connectivity/mdns/files/build.patch72
-rw-r--r--recipes-connectivity/mdns/mdns_765.50.9.bb (renamed from recipes-connectivity/mdns/mdns_544.bb)38
2 files changed, 40 insertions, 70 deletions
diff --git a/recipes-connectivity/mdns/files/build.patch b/recipes-connectivity/mdns/files/build.patch
index a1a2c89..31be71d 100644
--- a/recipes-connectivity/mdns/files/build.patch
+++ b/recipes-connectivity/mdns/files/build.patch
@@ -1,36 +1,13 @@
---- a/Clients/Makefile
-+++ b/Clients/Makefile
-@@ -30,9 +30,17 @@ TARGETS = build/dns-sd build/dns-sd64
- LIBS =
- else
- TARGETS = build/dns-sd
-+# Set up diverging paths for debug vs. prod builds
-+DEBUG?=1
-+ifeq ($(DEBUG),1)
-+LIBS = -L../mDNSPosix/build/debug/ -ldns_sd
-+else
- LIBS = -L../mDNSPosix/build/prod/ -ldns_sd
- endif
-
-+
-+endif
-+
- all: $(TARGETS)
-
- clean:
-@@ -42,10 +50,10 @@ build:
- mkdir build
-
- build/dns-sd: build dns-sd.c ClientCommon.c
-- cc $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@
-+ $(CC) $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@
-
- build/dns-sd64: build dns-sd.c ClientCommon.c
-- cc $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@ -m64
-+ $(CC) $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@ -m64
-
- # Note, we can make a 'fat' version of dns-sd using 'lipo', as shown below, but we
- # don't, because we don't want or need a 'fat' version of dns-sd, because it will
+From 43b6e98c9c37afd0d914949dcff4eab81f5a995f Mon Sep 17 00:00:00 2001
+From: Brendan Le Foll <brendan.le.foll@intel.com>
+Date: Tue, 3 Mar 2015 11:42:57 +0000
+
+---
+ mDNSPosix/Makefile | 54 +++++++++++++++++++++++++-----------------------------
+ 1 file changed, 25 insertions(+), 29 deletions(-)
+
+diff --git a/mDNSPosix/Makefile b/mDNSPosix/Makefile
+index 4f98e90..8ac97ad 100755
--- a/mDNSPosix/Makefile
+++ b/mDNSPosix/Makefile
@@ -50,6 +50,7 @@
@@ -41,10 +18,10 @@
COREDIR = ../mDNSCore
SHAREDDIR ?= ../mDNSShared
JDK = /usr/jdk
-@@ -57,11 +58,11 @@ JDK = /usr/jdk
- CC = @cc
+@@ -58,11 +59,11 @@ CC = @cc
BISON = @bison
FLEX = @flex
+ ST = @strip
-LD = ld -shared
+LD =@LD
CP = cp
@@ -55,24 +32,16 @@
CFLAGS_PTHREAD =
LINKOPTS =
LINKOPTS_PTHREAD = -lpthread
-@@ -69,7 +70,7 @@ LDSUFFIX = so
+@@ -70,7 +71,7 @@ LDSUFFIX = so
JAVACFLAGS_OS = -fPIC -shared -ldns_sd
# Set up diverging paths for debug vs. prod builds
-DEBUG=0
+DEBUG?=1
ifeq ($(DEBUG),1)
- CFLAGS_DEBUG = -g -DMDNS_DEBUGMSGS=2
+ CFLAGS_DEBUG = -g -DMDNS_DEBUGMSGS=2
OBJDIR = objects/debug
-@@ -103,6 +104,7 @@ else
- ifeq ($(findstring linux,$(os)),linux)
- CFLAGS_OS = -D_GNU_SOURCE -DHAVE_IPV6 -DNOT_HAVE_SA_LEN -DUSES_NETLINK -DHAVE_LINUX -DTARGET_OS_LINUX -fno-strict-aliasing
- LD = gcc -shared
-+LINKOPTS = --hash-style=gnu
- FLEXFLAGS_OS = -l
- JAVACFLAGS_OS += -I$(JDK)/include/linux
-
-@@ -210,7 +212,7 @@ endif
+@@ -213,7 +214,7 @@ endif
endif
endif
@@ -81,7 +50,7 @@
#############################################################################
-@@ -246,8 +248,7 @@ Daemon: setup $(BUILDDIR)/mdnsd
+@@ -249,8 +250,7 @@ Daemon: setup $(BUILDDIR)/mdnsd
@echo "Responder daemon done"
$(BUILDDIR)/mdnsd: $(DAEMONOBJS)
@@ -91,13 +60,13 @@
# libdns_sd target builds the client library
libdns_sd: setup $(BUILDDIR)/libdns_sd.$(LDSUFFIX)
-@@ -256,22 +257,18 @@ libdns_sd: setup $(BUILDDIR)/libdns_sd.$
+@@ -259,22 +259,18 @@ libdns_sd: setup $(BUILDDIR)/libdns_sd.$(LDSUFFIX)
CLIENTLIBOBJS = $(OBJDIR)/dnssd_clientlib.c.so.o $(OBJDIR)/dnssd_clientstub.c.so.o $(OBJDIR)/dnssd_ipc.c.so.o
$(BUILDDIR)/libdns_sd.$(LDSUFFIX): $(CLIENTLIBOBJS)
- @$(LD) $(LINKOPTS) -o $@ $+
- @$(STRIP) $@
-+ $(LD) -shared $(LINKOPTS) -o $@ $+
++ $(LD) -shared $(LINKOPTS) -Wl,-soname,libdns_sd.$(LDSUFFIX).1 -o $@ $+
-Clients: setup libdns_sd ../Clients/build/dns-sd
+Clients: setup libdns_sd
@@ -118,7 +87,7 @@
#############################################################################
-@@ -469,55 +466,55 @@ dnsextd: setup $(BUILDDIR)/dnsextd
+@@ -470,55 +466,55 @@ dnsextd: setup $(BUILDDIR)/dnsextd
@echo "dnsextd done"
$(BUILDDIR)/mDNSClientPosix: $(APPOBJ) $(OBJDIR)/Client.c.o
@@ -189,3 +158,6 @@
$(FLEX) $(FLEXFLAGS_OS) -i -o$(OBJDIR)/$*.l.c $<
- $(CC) $(CFLAGS) -Wno-error -c -o $@ $(OBJDIR)/$*.l.c
+ $(CC) $(CFLAGS_BUILD) -Wno-error -c -o $@ $(OBJDIR)/$*.l.c
+--
+2.9.5
+
diff --git a/recipes-connectivity/mdns/mdns_544.bb b/recipes-connectivity/mdns/mdns_765.50.9.bb
index dbdbb98..3d76981 100644
--- a/recipes-connectivity/mdns/mdns_544.bb
+++ b/recipes-connectivity/mdns/mdns_765.50.9.bb
@@ -1,58 +1,56 @@
DESCRIPTION = "Bonjour, also known as zero-configuration networking, enables automatic discovery of computers, devices, and services on IP networks."
HOMEPAGE = "http://developer.apple.com/networking/bonjour/"
LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=31c50371921e0fb731003bbc665f29bf"
+LIC_FILES_CHKSUM = "file://../LICENSE;md5=31c50371921e0fb731003bbc665f29bf"
-PR = "r1"
RPROVIDES_${PN} += "libdns_sd.so"
SRC_URI = "http://opensource.apple.com/tarballs/mDNSResponder/mDNSResponder-${PV}.tar.gz \
- file://build.patch \
+ file://build.patch;patchdir=.. \
file://mdns.service \
-"
+ "
-SRC_URI[md5sum] = "39142ab70bd82a096801ce346f86cbab"
-SRC_URI[sha256sum] = "c6ad1d53c28d28c0e3689bdf5efd9ce6f5c4c3692e8ad76e5eeb4d0c248929ac"
+SRC_URI[md5sum] = "4a6bc1628851002634ea3833a4dca317"
+SRC_URI[sha256sum] = "de61dd0034357aa50c60806726fb1f70fa8e953ff9cb62eccfb73efad10dba0a"
PARALLEL_MAKE = ""
-S = "${WORKDIR}/mDNSResponder-544"
+S = "${WORKDIR}/mDNSResponder-${PV}/mDNSPosix"
-do_compile() {
- cd mDNSPosix
- oe_runmake os=linux DEBUG=0
-}
+EXTRA_OEMAKE += "os=linux DEBUG=0 'CC=${CC}' 'LD=${CCLD} ${LDFLAGS}'"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
do_install () {
install -d ${D}${sbindir}
- install -m 0755 mDNSPosix/build/prod/mdnsd ${D}${sbindir}
+ install -m 0755 build/prod/mdnsd ${D}${sbindir}
install -d ${D}${libdir}
- cp mDNSPosix/build/prod/libdns_sd.so ${D}${libdir}/libdns_sd.so.1
+ cp build/prod/libdns_sd.so ${D}${libdir}/libdns_sd.so.1
chmod 0644 ${D}${libdir}/libdns_sd.so.1
ln -s libdns_sd.so.1 ${D}${libdir}/libdns_sd.so
install -d ${D}${includedir}
- install -m 0644 mDNSShared/dns_sd.h ${D}${includedir}
+ install -m 0644 ../mDNSShared/dns_sd.h ${D}${includedir}
install -d ${D}${mandir}/man8
- install -m 0644 mDNSShared/mDNSResponder.8 ${D}${mandir}/man8/mdnsd.8
+ install -m 0644 ../mDNSShared/mDNSResponder.8 ${D}${mandir}/man8/mdnsd.8
install -d ${D}${bindir}
- install -m 0755 Clients/build/dns-sd ${D}${bindir}
+ install -m 0755 ../Clients/build/dns-sd ${D}${bindir}
install -d ${D}${libdir}
- oe_libinstall -C mDNSPosix/build/prod -so libnss_mdns-0.2 ${D}${libdir}
+ oe_libinstall -C build/prod -so libnss_mdns-0.2 ${D}${libdir}
ln -s libnss_mdns-0.2.so ${D}${libdir}/libnss_mdns.so.2
install -d ${D}${sysconfdir}
- install -m 0644 mDNSPosix/nss_mdns.conf ${D}${sysconfdir}
+ install -m 0644 nss_mdns.conf ${D}${sysconfdir}
install -d ${D}${mandir}/man5
- install -m 0644 mDNSPosix/nss_mdns.conf.5 ${D}${mandir}/man5
+ install -m 0644 nss_mdns.conf.5 ${D}${mandir}/man5
install -d ${D}${mandir}/man8
- install -m 0644 mDNSPosix/libnss_mdns.8 ${D}${mandir}/man8
+ install -m 0644 libnss_mdns.8 ${D}${mandir}/man8
install -d ${D}${systemd_unitdir}/system/
install -m 0644 ${WORKDIR}/mdns.service ${D}${systemd_unitdir}/system/