aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/bash/bash.inc22
-rw-r--r--recipes-extended/bash/bash_3.2.57.bb2
-rw-r--r--recipes-extended/bc/bc_1.06.bb4
-rw-r--r--recipes-extended/cpio/cpio_2.8.bb2
-rw-r--r--recipes-extended/cpio/cpio_v2.inc6
-rw-r--r--recipes-extended/diffutils/diffutils.inc2
-rw-r--r--recipes-extended/diffutils/diffutils_2.8.1.bb4
-rw-r--r--recipes-extended/ed/ed_0.5.bb8
-rw-r--r--recipes-extended/findutils/findutils.inc9
-rw-r--r--recipes-extended/findutils/findutils_4.2.31.bb2
-rw-r--r--recipes-extended/gawk/gawk_3.1.5.bb16
-rw-r--r--recipes-extended/gperf/gperf.inc4
-rw-r--r--recipes-extended/gperf/gperf_3.0.3.bb2
-rw-r--r--recipes-extended/grep/grep-2.5.1a/autoconf270.patch19
-rw-r--r--recipes-extended/grep/grep_2.5.1a.bb9
-rw-r--r--recipes-extended/groff/groff_1.18.1.4.bb6
-rw-r--r--recipes-extended/gzip/gzip.inc8
-rw-r--r--recipes-extended/gzip/gzip_1.3.12.bb2
-rw-r--r--recipes-extended/libidn/libidn_0.6.14.bb6
-rw-r--r--recipes-extended/mc/mc_4.7.5.2.bb20
-rw-r--r--recipes-extended/msmtp/msmtp_1.4.12.bb6
-rw-r--r--recipes-extended/sed/sed_4.1.2.bb8
-rw-r--r--recipes-extended/tar/tar.inc14
-rw-r--r--recipes-extended/tar/tar_1.17.bb2
-rw-r--r--recipes-extended/texinfo/texinfo_4.8.bb20
-rw-r--r--recipes-extended/time/time_1.7.bb4
-rw-r--r--recipes-extended/which/which_2.18.bb6
27 files changed, 114 insertions, 99 deletions
diff --git a/recipes-extended/bash/bash.inc b/recipes-extended/bash/bash.inc
index 0f0d679..4767618 100644
--- a/recipes-extended/bash/bash.inc
+++ b/recipes-extended/bash/bash.inc
@@ -14,21 +14,21 @@ EXTRA_OECONF = "--enable-job-control --without-bash-malloc"
# This is what other major distros do. And this is what we wanted. See bug#5359 and bug#7137.
CFLAGS += "-DNON_INTERACTIVE_LOGIN_SHELLS"
-ALTERNATIVE_${PN} = "bash sh"
+ALTERNATIVE:${PN} = "bash sh"
ALTERNATIVE_LINK_NAME[bash] = "${base_bindir}/bash"
ALTERNATIVE_TARGET[bash] = "${base_bindir}/bash"
ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
ALTERNATIVE_TARGET[sh] = "${base_bindir}/bash.${BPN}"
ALTERNATIVE_PRIORITY = "100"
-RDEPENDS_${PN} += "base-files"
-RDEPENDS_${PN}_class-nativesdk = ""
-RDEPENDS_${PN}-ptest += "make"
+RDEPENDS:${PN} += "base-files"
+RDEPENDS:${PN}:class-nativesdk = ""
+RDEPENDS:${PN}-ptest += "make"
USERADD_PACKAGES = "${PN}-ptest"
-USERADD_PARAM_${PN}-ptest = "--create-home --user-group test"
+USERADD_PARAM:${PN}-ptest = "--create-home --user-group test"
-do_configure_prepend () {
+do_configure:prepend () {
if [ ! -e ${S}/acinclude.m4 ]; then
cat ${S}/aclocal.m4 > ${S}/acinclude.m4
fi
@@ -38,14 +38,14 @@ do_compile_ptest () {
oe_runmake buildtest
}
-do_install_append () {
+do_install:append () {
# Move /usr/bin/bash to /bin/bash, if need
if [ "${base_bindir}" != "${bindir}" ]; then
mkdir -p ${D}${base_bindir}
mv ${D}${bindir}/bash ${D}${base_bindir}
fi
}
-do_install_append_class-target () {
+do_install:append:class-target () {
# Clean host path in bashbug
sed -i -e "s,--sysroot=${STAGING_DIR_TARGET},,g" \
-e "s,-I${WORKDIR}/\S* ,,g" ${D}${bindir}/bashbug
@@ -58,12 +58,12 @@ do_install_ptest () {
-e "s,${S},,g" -e "s,${B},,g" -e "s,${STAGING_DIR_NATIVE},,g" ${D}${PTEST_PATH}/Makefile
}
-pkg_postinst_${PN} () {
+pkg_postinst:${PN} () {
grep -q "^${base_bindir}/bash$" $D${sysconfdir}/shells || echo ${base_bindir}/bash >> $D${sysconfdir}/shells
}
-pkg_postrm_${PN} () {
+pkg_postrm:${PN} () {
printf "$(grep -v "^${base_bindir}/bash$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells
}
-RPROVIDES_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', '/bin/sh /bin/bash', '', d)}"
+RPROVIDES:${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', '/bin/sh /bin/bash', '', d)}"
diff --git a/recipes-extended/bash/bash_3.2.57.bb b/recipes-extended/bash/bash_3.2.57.bb
index 5c288b3..189bdc2 100644
--- a/recipes-extended/bash/bash_3.2.57.bb
+++ b/recipes-extended/bash/bash_3.2.57.bb
@@ -1,6 +1,6 @@
require bash.inc
-LICENSE = "GPLv2+"
+LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=fd5d9bcabd8ed5a54a01ce8d183d592a"
SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
diff --git a/recipes-extended/bc/bc_1.06.bb b/recipes-extended/bc/bc_1.06.bb
index 3de1b24..2319f95 100644
--- a/recipes-extended/bc/bc_1.06.bb
+++ b/recipes-extended/bc/bc_1.06.bb
@@ -1,7 +1,7 @@
SUMMARY = "Arbitrary precision calculator language"
HOMEPAGE = "http://www.gnu.org/software/bc/bc.html"
-LICENSE = "GPLv2+ & LGPLv2.1"
+LICENSE = "GPL-2.0-or-later & LGPL-2.1-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
file://COPYING.LIB;md5=d8045f3b8f929c1cb29a1e3fd737b499 \
file://bc/bcdefs.h;endline=31;md5=46dffdaf10a99728dd8ce358e45d46d8 \
@@ -20,7 +20,7 @@ SRC_URI[sha256sum] = "4ef6d9f17c3c0d92d8798e35666175ecd3d8efac4009d6457b5c99cea7
inherit autotools texinfo update-alternatives
-ALTERNATIVE_${PN} = "bc dc"
+ALTERNATIVE:${PN} = "bc dc"
ALTERNATIVE_PRIORITY = "100"
BBCLASSEXTEND = "native"
diff --git a/recipes-extended/cpio/cpio_2.8.bb b/recipes-extended/cpio/cpio_2.8.bb
index 624906b..581fe1f 100644
--- a/recipes-extended/cpio/cpio_2.8.bb
+++ b/recipes-extended/cpio/cpio_2.8.bb
@@ -1,6 +1,6 @@
require cpio_v2.inc
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=b7f772ea3a2489231cb4872656cac34b"
PR = "r4"
diff --git a/recipes-extended/cpio/cpio_v2.inc b/recipes-extended/cpio/cpio_v2.inc
index 31adb71..f202d5f 100644
--- a/recipes-extended/cpio/cpio_v2.inc
+++ b/recipes-extended/cpio/cpio_v2.inc
@@ -26,14 +26,14 @@ do_install () {
PACKAGES =+ "${PN}-rmt"
-FILES_${PN}-rmt = "${base_sbindir}/rmt*"
+FILES:${PN}-rmt = "${base_sbindir}/rmt*"
inherit update-alternatives
ALTERNATIVE_PRIORITY = "100"
-ALTERNATIVE_${PN} = "cpio"
-ALTERNATIVE_${PN}-rmt = "rmt"
+ALTERNATIVE:${PN} = "cpio"
+ALTERNATIVE:${PN}-rmt = "rmt"
ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
diff --git a/recipes-extended/diffutils/diffutils.inc b/recipes-extended/diffutils/diffutils.inc
index c81348b..08ebaa9 100644
--- a/recipes-extended/diffutils/diffutils.inc
+++ b/recipes-extended/diffutils/diffutils.inc
@@ -6,6 +6,6 @@ SECTION = "base"
inherit autotools texinfo update-alternatives gettext
-ALTERNATIVE_${PN} = "diff cmp"
+ALTERNATIVE:${PN} = "diff cmp"
ALTERNATIVE_PRIORITY = "100"
diff --git a/recipes-extended/diffutils/diffutils_2.8.1.bb b/recipes-extended/diffutils/diffutils_2.8.1.bb
index 7c43c4b..d5d5845 100644
--- a/recipes-extended/diffutils/diffutils_2.8.1.bb
+++ b/recipes-extended/diffutils/diffutils_2.8.1.bb
@@ -1,4 +1,4 @@
-LICENSE = "GPLv2+"
+LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
require diffutils.inc
@@ -21,6 +21,6 @@ CACHED_CONFIGUREVARS = "\
jm_cv_func_working_realloc=yes \
"
-do_configure_prepend () {
+do_configure:prepend () {
chmod u+w ${S}/po/Makefile.in.in
}
diff --git a/recipes-extended/ed/ed_0.5.bb b/recipes-extended/ed/ed_0.5.bb
index e2df13f..8e0e05e 100644
--- a/recipes-extended/ed/ed_0.5.bb
+++ b/recipes-extended/ed/ed_0.5.bb
@@ -1,7 +1,7 @@
SUMMARY = "Line-oriented text editor"
HOMEPAGE = "http://www.gnu.org/software/ed/"
SECTION = "base"
-LICENSE = "GPLv2+"
+LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=6ddd5335ef96fb858a138230af773710 \
file://main.c;beginline=1;endline=17;md5=36d4b85e5ae9028e918d1cc775c2475e"
@@ -15,6 +15,6 @@ inherit autotools texinfo
EXTRA_OECONF = "'CC=${CC}' 'CXX=${CXX}' 'CFLAGS=${CFLAGS}' 'CXXFLAGS=${CXXFLAGS}' 'CPPFLAGS=${CPPFLAGS}' 'LDFLAGS=${LDFLAGS}'"
-CONFIGUREOPTS_remove = "--disable-dependency-tracking"
-CONFIGUREOPTS_remove = "--disable-silent-rules"
-EXTRA_OECONF_remove = "--disable-static"
+CONFIGUREOPTS:remove = "--disable-dependency-tracking"
+CONFIGUREOPTS:remove = "--disable-silent-rules"
+EXTRA_OECONF:remove = "--disable-static"
diff --git a/recipes-extended/findutils/findutils.inc b/recipes-extended/findutils/findutils.inc
index bfedf87..8887675 100644
--- a/recipes-extended/findutils/findutils.inc
+++ b/recipes-extended/findutils/findutils.inc
@@ -10,14 +10,7 @@ SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz"
inherit autotools gettext texinfo update-alternatives upstream-version-is-even
-ALTERNATIVE_${PN} = "find xargs"
+ALTERNATIVE:${PN} = "find xargs"
ALTERNATIVE_PRIORITY = "100"
-# diffutils assumes non-glibc compilation with uclibc and
-# this causes it to generate its own implementations of
-# standard functionality. regex.c actually breaks compilation
-# because it uses __mempcpy, there are other things (TBD:
-# see diffutils.mk in buildroot)
-EXTRA_OECONF_libc-uclibc = "--without-included-regex"
-
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-extended/findutils/findutils_4.2.31.bb b/recipes-extended/findutils/findutils_4.2.31.bb
index 7dee018..ef4500b 100644
--- a/recipes-extended/findutils/findutils_4.2.31.bb
+++ b/recipes-extended/findutils/findutils_4.2.31.bb
@@ -1,4 +1,4 @@
-LICENSE = "GPLv2+"
+LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
PR = "r4"
diff --git a/recipes-extended/gawk/gawk_3.1.5.bb b/recipes-extended/gawk/gawk_3.1.5.bb
index 63fd32f..2a75ff2 100644
--- a/recipes-extended/gawk/gawk_3.1.5.bb
+++ b/recipes-extended/gawk/gawk_3.1.5.bb
@@ -8,11 +8,11 @@ SECTION = "console/utils"
# gawk <= 3.1.5: GPLv2
# gawk >= 3.1.6: GPLv3
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
-RDEPENDS_gawk += "gawk-common"
-RDEPENDS_pgawk += "gawk-common"
+RDEPENDS:gawk += "gawk-common"
+RDEPENDS:pgawk += "gawk-common"
PR = "r2"
SRC_URI = "\
@@ -28,17 +28,17 @@ inherit autotools gettext texinfo update-alternatives
PACKAGES += "gawk-common pgawk"
-FILES_${PN} = "${bindir}/gawk* ${bindir}/igawk"
-FILES_gawk-common += "${datadir}/awk/* ${libexecdir}/awk/*"
-FILES_pgawk = "${bindir}/pgawk*"
+FILES:${PN} = "${bindir}/gawk* ${bindir}/igawk"
+FILES:gawk-common += "${datadir}/awk/* ${libexecdir}/awk/*"
+FILES:pgawk = "${bindir}/pgawk*"
-ALTERNATIVE_${PN} = "awk"
+ALTERNATIVE:${PN} = "awk"
ALTERNATIVE_TARGET[awk] = "${bindir}/gawk"
ALTERNATIVE_PRIORITY = "100"
CFLAGS += "-D PROTOTYPES"
-do_install_append() {
+do_install:append() {
# remove the link since we don't package it
rm ${D}${bindir}/awk
}
diff --git a/recipes-extended/gperf/gperf.inc b/recipes-extended/gperf/gperf.inc
index a8ce230..37fc334 100644
--- a/recipes-extended/gperf/gperf.inc
+++ b/recipes-extended/gperf/gperf.inc
@@ -1,7 +1,7 @@
DESCRIPTION = "GNU gperf is a perfect hash function generator"
HOMEPAGE = "http://www.gnu.org/software/gperf"
SUMMARY = "Generate a perfect hash function from a set of keywords"
-LICENSE = "GPLv3+"
+LICENSE = "GPL-3.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
file://src/main.cc;beginline=8;endline=19;md5=dec8f611845d047387ed56b5b85fa99b"
@@ -13,7 +13,7 @@ inherit autotools
# duplicating acinclude.m4 in every subdirectory, use absolute include path to aclocal
EXTRA_AUTORECONF += " -I ${S}"
-do_configure_prepend() {
+do_configure:prepend() {
if [ ! -e ${S}/acinclude.m4 ]; then
cat ${S}/aclocal.m4 > ${S}/acinclude.m4
fi
diff --git a/recipes-extended/gperf/gperf_3.0.3.bb b/recipes-extended/gperf/gperf_3.0.3.bb
index 7728861..d9e4928 100644
--- a/recipes-extended/gperf/gperf_3.0.3.bb
+++ b/recipes-extended/gperf/gperf_3.0.3.bb
@@ -1,6 +1,6 @@
require gperf.inc
-LICENSE = "GPLv2+"
+LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=a5f84abb0070adf8a0925d7d534b6e0a \
file://src/main.cc;beginline=8;endline=19;md5=72a3034a19e72f08ee48ef8244a121fd"
diff --git a/recipes-extended/grep/grep-2.5.1a/autoconf270.patch b/recipes-extended/grep/grep-2.5.1a/autoconf270.patch
new file mode 100644
index 0000000..954ae14
--- /dev/null
+++ b/recipes-extended/grep/grep-2.5.1a/autoconf270.patch
@@ -0,0 +1,19 @@
+Update to work with autoconf 2.71
+
+The script needs CPP so add the appropriate macro.
+
+Upstream-Status: Inappropriate [needed for old GPLv2 version only]
+RP - 2021/1/28
+
+Index: grep-2.5.1a/configure.in
+===================================================================
+--- grep-2.5.1a.orig/configure.in
++++ grep-2.5.1a/configure.in
+@@ -27,6 +27,7 @@ AC_PROG_AWK
+ AC_PROG_CC
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
++AC_PROG_CPP
+
+ dnl Checks for typedefs, structures, and compiler characteristics.
+ AC_SYS_LARGEFILE
diff --git a/recipes-extended/grep/grep_2.5.1a.bb b/recipes-extended/grep/grep_2.5.1a.bb
index d3b4ddc..c9c076b 100644
--- a/recipes-extended/grep/grep_2.5.1a.bb
+++ b/recipes-extended/grep/grep_2.5.1a.bb
@@ -2,7 +2,7 @@ SUMMARY = "Pattern matching utilities"
DESCRIPTION = "The GNU versions of commonly used grep utilities. The grep command searches one or more input \
files for lines containing a match to a specified pattern."
SECTION = "console/utils"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
PR = "r2"
@@ -18,6 +18,7 @@ SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.bz2 \
file://grep-egrep-fgrep-Fix-LSB-NG-cases.patch \
file://search-fix-compilation-error-with-security-flags-ena.patch \
file://0001-Fix-builds-with-gettext-0.20.patch \
+ file://autoconf270.patch \
"
SRC_URI[md5sum] = "52202fe462770fa6be1bb667bd6cf30c"
@@ -26,13 +27,13 @@ SRC_URI[sha256sum] = "38c8a2bb9223d1fb1b10bdd607cf44830afc92fd451ac4cd07619bf92b
inherit autotools gettext texinfo
EXTRA_OECONF_INCLUDED_REGEX = "--without-included-regex"
-EXTRA_OECONF_INCLUDED_REGEX_libc-musl = "--with-included-regex"
+EXTRA_OECONF_INCLUDED_REGEX:libc-musl = "--with-included-regex"
EXTRA_OECONF = "--disable-perl-regexp \
${EXTRA_OECONF_INCLUDED_REGEX}"
CFLAGS += "-D PROTOTYPES"
-do_configure_prepend () {
+do_configure:prepend () {
rm -f ${S}/m4/init.m4
cp -f ${WORKDIR}/Makevars ${S}/po/
}
@@ -52,7 +53,7 @@ inherit update-alternatives
ALTERNATIVE_PRIORITY = "100"
-ALTERNATIVE_${PN} = "grep egrep fgrep"
+ALTERNATIVE:${PN} = "grep egrep fgrep"
ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
diff --git a/recipes-extended/groff/groff_1.18.1.4.bb b/recipes-extended/groff/groff_1.18.1.4.bb
index a31cbf1..293043c 100644
--- a/recipes-extended/groff/groff_1.18.1.4.bb
+++ b/recipes-extended/groff/groff_1.18.1.4.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "The groff (GNU troff) software is a typesetting package which rea
formatting commands and produces formatted output."
SECTION = "console/utils"
HOMEPAGE = "http://www.gnu.org/software/groff/"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
PR = "r1"
LIC_FILES_CHKSUM = "file://COPYING;md5=e43fc16fccd8519fba405f0a0ff6e8a3"
@@ -30,7 +30,7 @@ do_configure (){
oe_runconf
}
-do_install_append() {
+do_install:append() {
# Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
# for target as /usr/bin/perl, so fix it to /usr/bin/perl.
for i in afmtodit mmroff; do
@@ -44,7 +44,7 @@ do_install_append() {
cp -rf ${D}${datadir}/groff/site-tmac/* ${D}${datadir}/groff/${PV}/tmac/
}
-pkg_postinst_${PN}() {
+pkg_postinst:${PN}() {
ln -s tbl $D${bindir}/gtbl
echo "export GROFF_FONT_PATH=/usr/share/groff/${PV}/font" >> $D${sysconfdir}/profile
echo "export GROFF_TMAC_PATH=/usr/share/groff/${PV}/tmac" >> $D${sysconfdir}/profile
diff --git a/recipes-extended/gzip/gzip.inc b/recipes-extended/gzip/gzip.inc
index 04f8f95..15fd665 100644
--- a/recipes-extended/gzip/gzip.inc
+++ b/recipes-extended/gzip/gzip.inc
@@ -8,10 +8,10 @@ SECTION = "console/utils"
inherit autotools texinfo
export DEFS="NO_ASM"
-EXTRA_OEMAKE_class-target = "GREP=${base_bindir}/grep"
-EXTRA_OECONF_append_libc-musl = " gl_cv_func_fflush_stdin=yes "
+EXTRA_OEMAKE:class-target = "GREP=${base_bindir}/grep"
+EXTRA_OECONF:append:libc-musl = " gl_cv_func_fflush_stdin=yes "
-do_install_append () {
+do_install:append () {
if [ "${base_bindir}" != "${bindir}" ]; then
# Rename and move files into /bin (FHS), which is typical place for gzip
install -d ${D}${base_bindir}
@@ -25,7 +25,7 @@ do_install_append () {
inherit update-alternatives
ALTERNATIVE_PRIORITY = "100"
-ALTERNATIVE_${PN} = "gunzip gzip zcat"
+ALTERNATIVE:${PN} = "gunzip gzip zcat"
ALTERNATIVE_LINK_NAME[gunzip] = "${base_bindir}/gunzip"
ALTERNATIVE_LINK_NAME[gzip] = "${base_bindir}/gzip"
ALTERNATIVE_LINK_NAME[zcat] = "${base_bindir}/zcat"
diff --git a/recipes-extended/gzip/gzip_1.3.12.bb b/recipes-extended/gzip/gzip_1.3.12.bb
index 5f7f6cd..94998ca 100644
--- a/recipes-extended/gzip/gzip_1.3.12.bb
+++ b/recipes-extended/gzip/gzip_1.3.12.bb
@@ -1,6 +1,6 @@
require gzip.inc
-LICENSE = "GPLv2+"
+LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
file://gzip.h;endline=22;md5=c0934ad1900d927f86556153d4c76d23 \
file://lzw.h;endline=19;md5=c273e09a02edd9801cc74d39683049e9 "
diff --git a/recipes-extended/libidn/libidn_0.6.14.bb b/recipes-extended/libidn/libidn_0.6.14.bb
index c681560..f5153a1 100644
--- a/recipes-extended/libidn/libidn_0.6.14.bb
+++ b/recipes-extended/libidn/libidn_0.6.14.bb
@@ -2,7 +2,7 @@ SUMMARY = "Internationalized Domain Name support library"
DESCRIPTION = "Implementation of the Stringprep, Punycode and IDNA specifications defined by the IETF Internationalized Domain Names (IDN) working group."
HOMEPAGE = "http://www.gnu.org/software/libidn/"
SECTION = "libs"
-LICENSE = "LGPLv2.1+ & GPLv2+"
+LICENSE = "LGPL-2.1-or-later & GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
file://lib/idna.h;beginline=6;endline=18;md5=1336e848ca7b8e25767c3c7e8fa38a89 \
@@ -16,7 +16,7 @@ SRC_URI = "http://alpha.gnu.org/gnu/libidn/${BPN}-${PV}.tar.gz"
SRC_URI[md5sum] = "040f012a45feb56168853998bb87ad4d"
SRC_URI[sha256sum] = "98910c2ad664bdf4eed2c2fff88e24f8882636ec9d26669366ff03b469c05ae3"
-do_configure_prepend() {
+do_configure:prepend() {
# this version of libidn copies AC_USE_SYSTEM_EXTENSIONS from
# autoconf CVS because atm the autoconf it uses is a bit old
# now with cross autotool, that macro is already there and this
@@ -27,7 +27,7 @@ do_configure_prepend() {
rm -f ${S}/lib/gl/m4/extensions.m4
}
-do_install_append() {
+do_install:append() {
rm -rf ${D}${libdir}/Libidn.dll
rm -rf ${D}${datadir}/emacs
}
diff --git a/recipes-extended/mc/mc_4.7.5.2.bb b/recipes-extended/mc/mc_4.7.5.2.bb
index 5f56641..0fe4ab0 100644
--- a/recipes-extended/mc/mc_4.7.5.2.bb
+++ b/recipes-extended/mc/mc_4.7.5.2.bb
@@ -1,10 +1,10 @@
SUMMARY = "Midnight Commander is an ncurses based file manager"
HOMEPAGE = "http://www.midnight-commander.org/"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
SECTION = "console/utils"
DEPENDS = "ncurses glib-2.0"
-RDEPENDS_${PN} = "ncurses-terminfo"
+RDEPENDS:${PN} = "ncurses-terminfo"
PR = "r3"
@@ -21,7 +21,7 @@ inherit autotools gettext pkgconfig
EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --without-samba"
-do_install_append () {
+do_install:append () {
sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
# These use python2 which is no longer supported
rm ${D}${libexecdir}/mc/extfs.d/s3+
@@ -30,18 +30,18 @@ do_install_append () {
PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers ${BPN}-fish"
-SUMMARY_${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts"
-FILES_${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
+SUMMARY:${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts"
+FILES:${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \
${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \
${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \
${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \
${libexecdir}/mc/extfs.d/uzip"
-RDEPENDS_${BPN}-helpers-perl = "perl"
+RDEPENDS:${BPN}-helpers-perl = "perl"
-SUMMARY_${BPN}-helpers = "Midnight Commander shell helper scripts"
-FILES_${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
+SUMMARY:${BPN}-helpers = "Midnight Commander shell helper scripts"
+FILES:${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
-SUMMARY_${BPN}-fish = "Midnight Commander Fish scripts"
-FILES_${BPN}-fish = "${libexecdir}/mc/fish"
+SUMMARY:${BPN}-fish = "Midnight Commander Fish scripts"
+FILES:${BPN}-fish = "${libexecdir}/mc/fish"
diff --git a/recipes-extended/msmtp/msmtp_1.4.12.bb b/recipes-extended/msmtp/msmtp_1.4.12.bb
index e03d432..f77b2b7 100644
--- a/recipes-extended/msmtp/msmtp_1.4.12.bb
+++ b/recipes-extended/msmtp/msmtp_1.4.12.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "A sendmail replacement for use in MTAs like mutt"
HOMEPAGE = "http://msmtp.sourceforge.net/"
SECTION = "console/network"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
@@ -24,12 +24,12 @@ PACKAGECONFIG[libidn] = "--with-libidn,--without-libidn,libidn"
inherit gettext autotools update-alternatives
-ALTERNATIVE_${PN} = "sendmail"
+ALTERNATIVE:${PN} = "sendmail"
ALTERNATIVE_TARGET[sendmail] = "${bindir}/msmtp"
ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail"
ALTERNATIVE_PRIORITY = "100"
-pkg_postinst_${PN}_linuxstdbase () {
+pkg_postinst:${PN}:linuxstdbase () {
# /usr/lib/sendmail is required by LSB specification
[ ! -L $D/usr/lib/sendmail ] && ln -sf ${sbindir}/sendmail $D/usr/lib
}
diff --git a/recipes-extended/sed/sed_4.1.2.bb b/recipes-extended/sed/sed_4.1.2.bb
index 4a58442..cd7993c 100644
--- a/recipes-extended/sed/sed_4.1.2.bb
+++ b/recipes-extended/sed/sed_4.1.2.bb
@@ -1,6 +1,6 @@
SUMMARY = "Stream EDitor (text filtering utility)"
HOMEPAGE = "http://www.gnu.org/software/sed/"
-LICENSE = "GPLv2+"
+LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
file://sed/sed.h;beginline=1;endline=17;md5=e00ffd1837f298439a214fd197f6a407"
SECTION = "console/utils"
@@ -18,7 +18,7 @@ SRC_URI[sha256sum] = "638e837ba765d5da0a30c98b57c2953cecea96827882f594612acace93
inherit autotools texinfo update-alternatives gettext
-do_configure_prepend () {
+do_configure:prepend () {
cp ${WORKDIR}/Makevars ${S}/po/
}
@@ -31,7 +31,9 @@ do_install () {
fi
}
-ALTERNATIVE_${PN} = "sed"
+ALTERNATIVE:${PN} = "sed"
ALTERNATIVE_LINK_NAME[sed] = "${base_bindir}/sed"
ALTERNATIVE_PRIORITY = "100"
+RPROVIDES:${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', '/bin/sed', '', d)}"
+
diff --git a/recipes-extended/tar/tar.inc b/recipes-extended/tar/tar.inc
index 93e4da1..e035fa6 100644
--- a/recipes-extended/tar/tar.inc
+++ b/recipes-extended/tar/tar.inc
@@ -21,7 +21,7 @@ do_install () {
ln -s tar ${D}${bindir}/gtar
}
-do_install_append_class-target() {
+do_install:append:class-target() {
if [ "${base_bindir}" != "${bindir}" ]; then
install -d ${D}${base_bindir}
mv ${D}${bindir}/tar ${D}${base_bindir}/tar
@@ -32,21 +32,21 @@ do_install_append_class-target() {
PACKAGES =+ "${PN}-rmt"
-FILES_${PN}-rmt = "${base_sbindir}/rmt*"
+FILES:${PN}-rmt = "${base_sbindir}/rmt*"
inherit update-alternatives
ALTERNATIVE_PRIORITY = "100"
-ALTERNATIVE_${PN} = "tar"
-ALTERNATIVE_${PN}-rmt = "rmt"
-ALTERNATIVE_${PN}_class-nativesdk = ""
-ALTERNATIVE_${PN}-rmt_class-nativesdk = ""
+ALTERNATIVE:${PN} = "tar"
+ALTERNATIVE:${PN}-rmt = "rmt"
+ALTERNATIVE:${PN}:class-nativesdk = ""
+ALTERNATIVE:${PN}-rmt:class-nativesdk = ""
ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
ALTERNATIVE_LINK_NAME[rmt] = "${base_sbindir}/rmt"
-PROVIDES_append_class-native = " tar-replacement-native"
+PROVIDES:append:class-native = " tar-replacement-native"
NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-extended/tar/tar_1.17.bb b/recipes-extended/tar/tar_1.17.bb
index 1ee5e34..e4d4746 100644
--- a/recipes-extended/tar/tar_1.17.bb
+++ b/recipes-extended/tar/tar_1.17.bb
@@ -1,6 +1,6 @@
require tar.inc
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
PR = "r3"
diff --git a/recipes-extended/texinfo/texinfo_4.8.bb b/recipes-extended/texinfo/texinfo_4.8.bb
index 13678e0..c975f48 100644
--- a/recipes-extended/texinfo/texinfo_4.8.bb
+++ b/recipes-extended/texinfo/texinfo_4.8.bb
@@ -4,18 +4,18 @@ online information and printed output from a single source file. The \
GNU Project uses the Texinfo file format for most of its documentation."
HOMEPAGE = "http://www.gnu.org/software/texinfo/"
SECTION = "console/utils"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-PROVIDES_append_class-native = " texinfo-4.8-replacement-native"
+PROVIDES:append:class-native = " texinfo-4.8-replacement-native"
DEPENDS = "zlib ncurses texinfo-4.8-replacement-native"
-DEPENDS_class-native = "zlib-native ncurses-native"
+DEPENDS:class-native = "zlib-native ncurses-native"
TARGET_PATCH = "file://use_host_makedoc.patch \
file://using-native-makeinfo.patch \
"
-TARGET_PATCH_class-native = ""
+TARGET_PATCH:class-native = ""
SRC_URI = "${GNU_MIRROR}/texinfo/${BP}.tar.gz \
file://check-locale-h.patch \
@@ -30,25 +30,25 @@ tex_texinfo = "texmf/tex/texinfo"
inherit gettext autotools
-do_install_append() {
+do_install:append() {
mkdir -p ${D}${datadir}/${tex_texinfo}
install -p -m644 ${S}/doc/texinfo.tex ${S}/doc/txi-??.tex ${D}${datadir}/${tex_texinfo}
}
-do_install_append_class-native() {
+do_install:append:class-native() {
install -m 755 info/makedoc ${D}${bindir}
install -m 755 makeinfo/makeinfo ${D}${bindir}
}
PACKAGES += "info info-doc"
-FILES_info = "${bindir}/info ${bindir}/infokey ${bindir}/install-info"
-FILES_info-doc = "${infodir}/info.info ${infodir}/dir ${infodir}/info-*.info \
+FILES:info = "${bindir}/info ${bindir}/infokey ${bindir}/install-info"
+FILES:info-doc = "${infodir}/info.info ${infodir}/dir ${infodir}/info-*.info \
${mandir}/man1/info.1* ${mandir}/man5/info.5* \
${mandir}/man1/infokey.1* ${mandir}/man1/install-info.1*"
-FILES_${PN} = "${bindir}/makeinfo ${bindir}/texi* ${bindir}/pdftexi2dvi ${bindir}/pod2texi ${datadir}/texinfo"
-FILES_${PN}-doc = "${infodir}/texinfo* \
+FILES:${PN} = "${bindir}/makeinfo ${bindir}/texi* ${bindir}/pdftexi2dvi ${bindir}/pod2texi ${datadir}/texinfo"
+FILES:${PN}-doc = "${infodir}/texinfo* \
${datadir}/${tex_texinfo} \
${mandir}/man1 ${mandir}/man5"
diff --git a/recipes-extended/time/time_1.7.bb b/recipes-extended/time/time_1.7.bb
index e5713db..8807334 100644
--- a/recipes-extended/time/time_1.7.bb
+++ b/recipes-extended/time/time_1.7.bb
@@ -3,12 +3,12 @@ DESCRIPTION = "time measures many of the CPU resources, such as time and \
memory, that other programs use."
HOMEPAGE = "http://www.gnu.org/software/time/"
SECTION = "utils"
-LICENSE = "GPLv2+"
+LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
inherit texinfo update-alternatives
-ALTERNATIVE_${PN} = "time"
+ALTERNATIVE:${PN} = "time"
ALTERNATIVE_PRIORITY = "100"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-extended/which/which_2.18.bb b/recipes-extended/which/which_2.18.bb
index eb6cc99..42d0bf2 100644
--- a/recipes-extended/which/which_2.18.bb
+++ b/recipes-extended/which/which_2.18.bb
@@ -6,7 +6,7 @@ It does this by using the exact same algorithm as bash."
SECTION = "libs"
HOMEPAGE = "http://carlo17.home.xs4all.nl/which/"
-LICENSE = "GPLv2+"
+LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
PR = "r2"
@@ -23,12 +23,12 @@ DEPENDS = "cwautomacros-native"
inherit autotools texinfo update-alternatives
-do_configure_prepend() {
+do_configure:prepend() {
OLD="@ACLOCAL_CWFLAGS@"
NEW="-I ${STAGING_DIR_NATIVE}/${datadir}/cwautomacros/m4"
sed -i "s#${OLD}#${NEW}#g" `grep -rl ${OLD} ${S}`
}
-ALTERNATIVE_${PN} = "which"
+ALTERNATIVE:${PN} = "which"
ALTERNATIVE_PRIORITY = "100"