aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/sed
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/sed')
-rw-r--r--recipes-extended/sed/sed-4.1.2/0001-Fix-builds-with-gettext-0.20.patch38
-rw-r--r--recipes-extended/sed/sed_4.1.2.bb12
2 files changed, 46 insertions, 4 deletions
diff --git a/recipes-extended/sed/sed-4.1.2/0001-Fix-builds-with-gettext-0.20.patch b/recipes-extended/sed/sed-4.1.2/0001-Fix-builds-with-gettext-0.20.patch
new file mode 100644
index 0000000..e366b5a
--- /dev/null
+++ b/recipes-extended/sed/sed-4.1.2/0001-Fix-builds-with-gettext-0.20.patch
@@ -0,0 +1,38 @@
+From 2792bccbfd41427a79edd462906aba78144b8c6a Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Tue, 17 Dec 2019 16:40:58 +0100
+Subject: [PATCH] Fix builds with gettext 0.20
+
+Upstream-Status: Inappropriate [fixing an old version]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ Makefile.am | 2 +-
+ configure.ac | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index f0aaa7f..1ebc805 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -6,7 +6,7 @@ ACLOCAL_AMFLAGS = -I config
+
+ PACKAGE = sed
+
+-SUBDIRS = intl lib po sed doc testsuite
++SUBDIRS = lib po sed testsuite
+
+ noinst_DATA = bootstrap.sh
+ noinst_HEADERS = basicdefs.h
+diff --git a/configure.ac b/configure.ac
+index e08c9a3..df20044 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -130,7 +130,7 @@ AM_CONDITIONAL(TEXI2HTML_HTML, test "x$enable_html" = xtexi2html)
+
+ ALL_LINGUAS="af ca cs da de el eo es et fi fr ga gl he hr hu id it ja ko nl pl pt_BR ro ru sk sl sr sv tr zh_CN"
+ AM_GNU_GETTEXT_VERSION(0.11)
+-AM_GNU_GETTEXT(, need-ngettext)
++AM_GNU_GETTEXT([external], need-ngettext)
+
+ AC_CONFIG_FILES([bootstrap.sh], chmod +x bootstrap.sh)
+ AC_CONFIG_FILES([Makefile doc/Makefile \
diff --git a/recipes-extended/sed/sed_4.1.2.bb b/recipes-extended/sed/sed_4.1.2.bb
index 40e3a53..cd7993c 100644
--- a/recipes-extended/sed/sed_4.1.2.bb
+++ b/recipes-extended/sed/sed_4.1.2.bb
@@ -1,6 +1,6 @@
SUMMARY = "Stream EDitor (text filtering utility)"
HOMEPAGE = "http://www.gnu.org/software/sed/"
-LICENSE = "GPLv2+"
+LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
file://sed/sed.h;beginline=1;endline=17;md5=e00ffd1837f298439a214fd197f6a407"
SECTION = "console/utils"
@@ -9,14 +9,16 @@ PR = "r7"
SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz \
file://fix_return_type.patch \
file://sed-4.1.2_fix_for_automake-1.12.patch \
- file://Makevars"
+ file://Makevars \
+ file://0001-Fix-builds-with-gettext-0.20.patch \
+ "
SRC_URI[md5sum] = "928f0e06422f414091917401f1a834d0"
SRC_URI[sha256sum] = "638e837ba765d5da0a30c98b57c2953cecea96827882f594612acace93ceeeab"
inherit autotools texinfo update-alternatives gettext
-do_configure_prepend () {
+do_configure:prepend () {
cp ${WORKDIR}/Makevars ${S}/po/
}
@@ -29,7 +31,9 @@ do_install () {
fi
}
-ALTERNATIVE_${PN} = "sed"
+ALTERNATIVE:${PN} = "sed"
ALTERNATIVE_LINK_NAME[sed] = "${base_bindir}/sed"
ALTERNATIVE_PRIORITY = "100"
+RPROVIDES:${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', '/bin/sed', '', d)}"
+