aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-security/optee
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/optee')
-rw-r--r--recipes-security/optee/optee-client-qoriq_3.8.0.bb28
-rw-r--r--recipes-security/optee/optee-os-qoriq/0001-allow-setting-sysroot-for-libgcc-lookup.patch13
-rw-r--r--recipes-security/optee/optee-os-qoriq/0001-arm64-Disable-outline-atomics-when-compiling.patch41
-rw-r--r--recipes-security/optee/optee-os-qoriq_3.8.0.bb83
-rw-r--r--recipes-security/optee/optee-test-qoriq_3.8.0.bb47
5 files changed, 0 insertions, 212 deletions
diff --git a/recipes-security/optee/optee-client-qoriq_3.8.0.bb b/recipes-security/optee/optee-client-qoriq_3.8.0.bb
deleted file mode 100644
index 0cd9eeab..00000000
--- a/recipes-security/optee/optee-client-qoriq_3.8.0.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-SUMMARY = "OPTEE Client"
-HOMEPAGE = "https://github.com/OP-TEE/optee_client"
-
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=69663ab153298557a59c67a60a743e5b"
-
-inherit python3native systemd
-
-SRC_URI = "git://github.com/OP-TEE/optee_client;nobranch=1"
-SRCREV = "be4fa2e36f717f03ca46e574aa66f697a897d090"
-
-S = "${WORKDIR}/git"
-
-EXTRA_OEMAKE = "ARCH=arm64"
-
-do_install() {
- oe_runmake install
-
- install -D -p -m0755 ${S}/out/export/usr/sbin/tee-supplicant ${D}${bindir}/tee-supplicant
- install -D -p -m0755 ${S}/out/export/usr/lib/libteec.so.1.0.0 ${D}${libdir}/libteec.so.1.0.0
- ln -sf libteec.so.1.0.0 ${D}${libdir}/libteec.so.1.0
- ln -sf libteec.so.1.0.0 ${D}${libdir}/libteec.so.1
- ln -sf libteec.so.1 ${D}${libdir}/libteec.so
-
- cp -a ${S}/out/export/usr/include ${D}/usr/
-}
-
-COMPATIBLE_MACHINE = "(qoriq-arm64)"
diff --git a/recipes-security/optee/optee-os-qoriq/0001-allow-setting-sysroot-for-libgcc-lookup.patch b/recipes-security/optee/optee-os-qoriq/0001-allow-setting-sysroot-for-libgcc-lookup.patch
deleted file mode 100644
index 17127d0b..00000000
--- a/recipes-security/optee/optee-os-qoriq/0001-allow-setting-sysroot-for-libgcc-lookup.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/mk/gcc.mk b/mk/gcc.mk
-index fc38c4d..77b8d74 100644
---- a/mk/gcc.mk
-+++ b/mk/gcc.mk
-@@ -12,7 +12,7 @@ nostdinc$(sm) := -nostdinc -isystem $(shell $(CC$(sm)) \
- -print-file-name=include 2> /dev/null)
-
- # Get location of libgcc from gcc
--libgcc$(sm) := $(shell $(CC$(sm)) $(CFLAGS$(arch-bits-$(sm))) $(comp-cflags$(sm)) \
-+libgcc$(sm) := $(shell $(CC$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CFLAGS$(arch-bits-$(sm))) $(comp-cflags$(sm)) \
- -print-libgcc-file-name 2> /dev/null)
-
- # Define these to something to discover accidental use
diff --git a/recipes-security/optee/optee-os-qoriq/0001-arm64-Disable-outline-atomics-when-compiling.patch b/recipes-security/optee/optee-os-qoriq/0001-arm64-Disable-outline-atomics-when-compiling.patch
deleted file mode 100644
index 086d4333..00000000
--- a/recipes-security/optee/optee-os-qoriq/0001-arm64-Disable-outline-atomics-when-compiling.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From f94d9558d9eae48e92ce8d651539b6cf69eb4394 Mon Sep 17 00:00:00 2001
-From: Joshua Watt <JPEWhacker@gmail.com>
-Date: Mon, 18 May 2020 20:00:00 -0500
-Subject: [PATCH] arm64: Disable outline-atomics when compiling
-
-Disables the automatic detection of LSE (Large System Extension)
-instructions when compiling AArch64 code. GCC 10 implements this
-detection in libgcc using __getauxval(), which optee doesn't implement.
-This requires that the proper -mcpu is passed to GCC so that the code
-can be correctly compiled to use either LSE or load-store-exclusive.
-
-Fixes linker errors like the following when compiling with GCC 10:
-
- aarch64-linux-ld.bfd: libgcc.a(lse-init.o):
- in function `init_have_lse_atomics':
- lse-init.c:44: undefined reference to `__getauxval'
- core/arch/arm/kernel/link.mk:38:
- recipe for target 'build/core/all_objs.o' failed
-
-Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
-Upstream-Status: Submitted [https://github.com/OP-TEE/optee_os/pull/3874]
----
- core/arch/arm/arm.mk | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/core/arch/arm/arm.mk b/core/arch/arm/arm.mk
-index a18eda3b..07069c66 100644
---- a/core/arch/arm/arm.mk
-+++ b/core/arch/arm/arm.mk
-@@ -115,7 +115,7 @@ arm32-platform-aflags-no-hard-float ?=
-
- arm64-platform-cflags-no-hard-float ?= -mgeneral-regs-only
- arm64-platform-cflags-hard-float ?=
--arm64-platform-cflags-generic ?= -mstrict-align
-+arm64-platform-cflags-generic ?= -mstrict-align $(call cc-option,-mno-outline-atomics,)
-
- ifeq ($(DEBUG),1)
- # For backwards compatibility
---
-2.17.1
-
diff --git a/recipes-security/optee/optee-os-qoriq_3.8.0.bb b/recipes-security/optee/optee-os-qoriq_3.8.0.bb
deleted file mode 100644
index b8d764ff..00000000
--- a/recipes-security/optee/optee-os-qoriq_3.8.0.bb
+++ /dev/null
@@ -1,83 +0,0 @@
-SUMMARY = "OP-TEE Trusted OS"
-DESCRIPTION = "OPTEE OS"
-
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=c1f21c4f72f372ef38a5a4aee55ec173"
-
-PV = "3.8+git${SRCPV}"
-
-DEPENDS += "python3-pyelftools-native python3-pycryptodome-native python3-pycryptodomex-native dtc-native"
-
-inherit deploy python3native
-
-SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_os;nobranch=1 \
- file://0001-allow-setting-sysroot-for-libgcc-lookup.patch \
- file://0001-arm64-Disable-outline-atomics-when-compiling.patch \
- "
-SRCREV = "0cb01f7f6aee552ead49990c06f69f73f459cc65"
-
-S = "${WORKDIR}/git"
-
-OPTEEMACHINE ?= "${MACHINE}"
-OPTEEMACHINE_ls1088ardb-pb = "ls1088ardb"
-OPTEEMACHINE_ls1046afrwy = "ls1046ardb"
-OPTEEMACHINE_lx2162aqds = "lx2160aqds"
-
-EXTRA_OEMAKE = "PLATFORM=ls-${OPTEEMACHINE} CFG_ARM64_core=y \
- ARCH=arm \
- CROSS_COMPILE_core=${HOST_PREFIX} \
- CROSS_COMPILE_ta_arm64=${HOST_PREFIX} \
- NOWERROR=1 \
- LDFLAGS= \
- LIBGCC_LOCATE_CFLAGS=--sysroot=${STAGING_DIR_HOST} \
- "
-EXTRA_OEMAKE_append_lx2162aqds = " CFG_EMBED_DTB_SOURCE_FILE=fsl-lx2160a-qds.dts CFG_EMBED_DT=y"
-
-OPTEE_ARCH_armv7a = "arm32"
-OPTEE_ARCH_aarch64 = "arm64"
-
-do_compile() {
- unset LDFLAGS
- oe_runmake all CFG_TEE_TA_LOG_LEVEL=0
- ${OBJCOPY} -v -O binary ${B}/out/arm-plat-ls/core/tee.elf ${B}/out/arm-plat-ls/core/tee.bin
-
- if [ ${MACHINE} = ls1012afrwy ]; then
- mv ${B}/out/arm-plat-ls/core/tee.bin ${B}/out/arm-plat-ls/core/tee_512mb.bin
- oe_runmake CFG_DRAM0_SIZE=0x40000000 all CFG_TEE_TA_LOG_LEVEL=0
- ${OBJCOPY} -v -O binary ${B}/out/arm-plat-ls/core/tee.elf ${B}/out/arm-plat-ls/core/tee.bin
- fi
-}
-
-do_install() {
- #install core on boot directory
- install -d ${D}/lib/firmware/
- if [ ${MACHINE} = ls1012afrwy ]; then
- install -m 644 ${B}/out/arm-plat-ls/core/tee_512mb.bin ${D}/lib/firmware/tee_${MACHINE}_512mb.bin
- fi
- install -m 644 ${B}/out/arm-plat-ls/core/tee.bin ${D}/lib/firmware/tee_${MACHINE}.bin
- #install TA devkit
- install -d ${D}/usr/include/optee/export-user_ta/
-
- for f in ${B}/out/arm-plat-ls/export-ta_${OPTEE_ARCH}/* ; do
- cp -aR $f ${D}/usr/include/optee/export-user_ta/
- done
-}
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-do_deploy() {
- install -d ${DEPLOYDIR}/optee
- for f in ${D}/lib/firmware/*; do
- cp $f ${DEPLOYDIR}/optee/
- done
-}
-
-addtask deploy before do_build after do_install
-
-FILES_${PN} = "/lib/firmware/"
-FILES_${PN}-dev = "/usr/include/optee"
-
-INSANE_SKIP_${PN}-dev = "staticdev"
-
-INHIBIT_PACKAGE_STRIP = "1"
-COMPATIBLE_MACHINE = "(qoriq-arm64)"
diff --git a/recipes-security/optee/optee-test-qoriq_3.8.0.bb b/recipes-security/optee/optee-test-qoriq_3.8.0.bb
deleted file mode 100644
index 94cd00c2..00000000
--- a/recipes-security/optee/optee-test-qoriq_3.8.0.bb
+++ /dev/null
@@ -1,47 +0,0 @@
-SUMMARY = "OP-TEE sanity testsuite"
-HOMEPAGE = "https://github.com/OP-TEE/optee_test"
-
-LICENSE = "BSD & GPLv2"
-LIC_FILES_CHKSUM = "file://${S}/LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa"
-
-DEPENDS = "optee-client-qoriq optee-os-qoriq python3-pycryptodome-native python3-pycryptodomex-native"
-
-inherit python3native
-
-SRC_URI = "git://github.com/OP-TEE/optee_test;nobranch=1"
-SRCREV = "30481e381cb4285706e7516853495a7699c93b2c"
-
-S = "${WORKDIR}/git"
-
-OPTEE_CLIENT_EXPORT = "${STAGING_DIR_HOST}${prefix}"
-TEEC_EXPORT = "${STAGING_DIR_HOST}${prefix}"
-TA_DEV_KIT_DIR = "${STAGING_INCDIR}/optee/export-user_ta"
-
-EXTRA_OEMAKE = " TA_DEV_KIT_DIR=${TA_DEV_KIT_DIR} \
- OPTEE_CLIENT_EXPORT=${OPTEE_CLIENT_EXPORT} \
- CFG_ARM64=y \
- CROSS_COMPILE_HOST=${TARGET_PREFIX} \
- CROSS_COMPILE_TA=${TARGET_PREFIX} \
- V=1 \
- "
-
-do_compile() {
- # Top level makefile doesn't seem to handle parallel make gracefully
- oe_runmake xtest
- oe_runmake ta
-}
-
-do_install () {
- install -D -p -m0755 ${S}/out/xtest/xtest ${D}${bindir}/xtest
-
- # install path should match the value set in optee-client/tee-supplicant
- # default TEEC_LOAD_PATH is /lib
- mkdir -p ${D}/lib/optee_armtz/
- install -D -p -m0444 ${S}/out/ta/*/*.ta ${D}/lib/optee_armtz/
-}
-
-FILES_${PN} += "/lib/optee_armtz/"
-
-# Imports machine specific configs from staging to build
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "(qoriq-arm64)"