aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kernel-modules
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/kernel-modules')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-ar_git.bb14
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/Add-makefile.patch4
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.4.p1.8.bb26
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.11.p2.2+fslc.bb (renamed from recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.4.p1.2+fslc.bb)8
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.11.p2.4.bb24
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-ipc-multi_git.bb13
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-ipc-single_git.bb13
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-ipc.inc4
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.24.1.bb20
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-ls-debug_git.bb4
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb22
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-perf-qoriq_0.8.2.bb18
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-qca6174/0001-MLK-18491-02-qcacld-2.0-fix-the-overflow-of-bounce-b.patch92
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-qca6174_2.0.bb13
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-qca9377_2.0.bb15
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc23
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-scatter-gather_git.bb12
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-uio-seville_0.1.bb4
18 files changed, 87 insertions, 242 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-ar_git.bb b/recipes-kernel/kernel-modules/kernel-module-ar_git.bb
index feddc8fa..553e2013 100644
--- a/recipes-kernel/kernel-modules/kernel-module-ar_git.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-ar_git.bb
@@ -1,10 +1,10 @@
SUMMARY = "Auto Response Control Module"
-LICENSE = "GPLv2 & BSD"
+LICENSE = "GPL-2.0-only & BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
inherit module
-SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-yocto-sdk/auto-resp;branch=nxp/sdk-v2.0.x"
+SRC_URI = "git://github.com/nxp-qoriq-yocto-sdk/auto-resp;branch=nxp/sdk-v2.0.x;protocol=https"
SRCREV = "9a74743167dcfcfbca5056eedbff9a52337c9712"
S = "${WORKDIR}/git"
@@ -14,19 +14,19 @@ export KERNEL_PATH
INHIBIT_PACKAGE_STRIP = "1"
-do_compile_prepend() {
+do_compile:prepend() {
sed -i -e 's,EXTRA_CFLAGS += -I$(PWD),EXTRA_CFLAGS += -I${S},' ${S}/armodule/source/Makefile
}
do_install(){
- install -d ${D}/lib/modules/${KERNEL_VERSION}
+ install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}
install -d ${D}${bindir}
- install -m 644 ${B}/bin/ar.ko ${D}/lib/modules/${KERNEL_VERSION}/
+ install -m 644 ${B}/bin/ar.ko ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/
cp -f ${S}/bin/ar_* ${D}${bindir}/
}
-FILES_${PN} += "${bindir}/"
-INSANE_SKIP_${PN} = "ldflags"
+FILES:${PN} += "${bindir}/"
+INSANE_SKIP:${PN} = "ldflags"
COMPATIBLE_MACHINE = "(t1040|t1042)"
CLEANBROKEN = "1"
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/Add-makefile.patch b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/Add-makefile.patch
index 63f408c5..efe6cec6 100644
--- a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/Add-makefile.patch
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/Add-makefile.patch
@@ -1,3 +1,7 @@
+Add makefile to kernel-module-imx-gpu-viv
+
+Upstream-Status: Pending
+Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Index: git/Makefile
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.4.p1.8.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.4.p1.8.bb
deleted file mode 100644
index 9201dd27..00000000
--- a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.4.p1.8.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright (C) 2015-2016 Freescale Semiconductor
-# Copyright 2017-2018 NXP
-
-SUMMARY = "Kernel loadable module for Vivante GPU"
-DESCRIPTION = "Builds the Vivante GPU kernel driver as a loadable kernel module, \
-allowing flexibility to use a newer graphics release with an older kernel."
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-
-SRCBRANCH = "imx_4.9.123_imx8mm_ga"
-LOCALVERSION = "-${SRCBRANCH}"
-KERNEL_SRC ?= "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https"
-SRC_URI = " \
- ${KERNEL_SRC};branch=${SRCBRANCH};subpath=drivers/mxc/gpu-viv;destsuffix=git/src \
- file://Add-makefile.patch \
-"
-SRCREV = "6a71cbc089755afd6a86c005c22a1af6eab24a70"
-
-S = "${WORKDIR}/git"
-
-inherit module
-
-EXTRA_OEMAKE += "CONFIG_MXC_GPU_VIV=m"
-
-KERNEL_MODULE_AUTOLOAD = "galcore"
-COMPATIBLE_MACHINE = "(imx)"
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.4.p1.2+fslc.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.11.p2.2+fslc.bb
index f9307fb4..13793132 100644
--- a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.4.p1.2+fslc.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.11.p2.2+fslc.bb
@@ -4,17 +4,17 @@
SUMMARY = "Kernel loadable module for Vivante GPU"
DESCRIPTION = "This package uses an exact copy of the GPU kernel driver source code of \
the same version as base and include fixes and improvements developed by FSL Community"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
PV .= "+git${SRCPV}"
-SRCREV = "86354002bea77acd9ce1812712e9d8485b377ec8"
-SRC_URI = "git://github.com/Freescale/kernel-module-imx-gpu-viv.git;protocol=https"
+SRCREV = "4d035200e7b15d2713d49979a1d05f201b92cf4c"
+SRC_URI = "git://github.com/Freescale/kernel-module-imx-gpu-viv.git;protocol=https;branch=master"
S = "${WORKDIR}/git"
inherit module
KERNEL_MODULE_AUTOLOAD = "galcore"
-COMPATIBLE_MACHINE = "(imx)"
+COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.11.p2.4.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.11.p2.4.bb
new file mode 100644
index 00000000..e48d7258
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.11.p2.4.bb
@@ -0,0 +1,24 @@
+# Copyright (C) 2015-2016 Freescale Semiconductor
+# Copyright (C) 2017-2024 NXP
+
+SUMMARY = "Kernel loadable module for Vivante GPU"
+DESCRIPTION = "Builds the Vivante GPU kernel driver as a loadable kernel module, \
+allowing flexibility to use a newer graphics release with an older kernel."
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
+
+SRC_URI = "${KERNEL_SRC};subpath=drivers/mxc/gpu-viv;destsuffix=git/src \
+ file://Add-makefile.patch"
+KERNEL_SRC ?= "git://github.com/nxp-imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}"
+SRCBRANCH = "lf-6.6.y"
+LOCALVERSION = "-6.6.3-1.0.0"
+SRCREV = "3571388e9660f96b65b5fdcc093cc973ee502949"
+
+S = "${WORKDIR}/git"
+
+inherit module
+
+EXTRA_OEMAKE += "CONFIG_MXC_GPU_VIV=m"
+
+KERNEL_MODULE_AUTOLOAD = "galcore"
+COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-kernel/kernel-modules/kernel-module-ipc-multi_git.bb b/recipes-kernel/kernel-modules/kernel-module-ipc-multi_git.bb
deleted file mode 100644
index 74e01bd9..00000000
--- a/recipes-kernel/kernel-modules/kernel-module-ipc-multi_git.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-require kernel-module-ipc.inc
-
-EXTRA_OEMAKE ="KERNEL_DIR=${STAGING_KERNEL_DIR} B4860=1 CONFIG_MULTI_RAT=1"
-
-do_install(){
- install -d ${D}/usr/driver/IPC/multi_rat
- install -m 755 ${S}/kernel/*.ko ${D}/usr/driver/IPC/multi_rat
-}
-
-FILES_${PN} += "/usr/driver/IPC/multi_rat/*.ko"
-FILES_${PN}-dbg += "/usr/driver/IPC/multi_rat/.debug"
-
-COMPATIBLE_MACHINE = "(b4860qds|b4420qds)"
diff --git a/recipes-kernel/kernel-modules/kernel-module-ipc-single_git.bb b/recipes-kernel/kernel-modules/kernel-module-ipc-single_git.bb
deleted file mode 100644
index 86155423..00000000
--- a/recipes-kernel/kernel-modules/kernel-module-ipc-single_git.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-require kernel-module-ipc.inc
-
-EXTRA_OEMAKE ="KERNEL_DIR=${STAGING_KERNEL_DIR} B4860=1"
-
-do_install(){
- install -d ${D}/usr/driver/IPC/single_rat
- install -m 755 ${S}/kernel/*.ko ${D}/usr/driver/IPC/single_rat
-}
-
-FILES_${PN} += "/usr/driver/IPC/single_rat/*.ko"
-FILES_${PN}-dbg += "/usr/driver/IPC/single_rat/.debug"
-
-COMPATIBLE_MACHINE = "(b4860qds|b4420qds)"
diff --git a/recipes-kernel/kernel-modules/kernel-module-ipc.inc b/recipes-kernel/kernel-modules/kernel-module-ipc.inc
index e3c92f3a..d2316fe0 100644
--- a/recipes-kernel/kernel-modules/kernel-module-ipc.inc
+++ b/recipes-kernel/kernel-modules/kernel-module-ipc.inc
@@ -5,13 +5,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fa38cd73d71527dc6efb546474f64d10"
inherit module qoriq_build_64bit_kernel
-SRC_URI = "git://git.freescale.com/ppc/sdk/ipc.git;branch=sdk-v2.0.x"
+SRC_URI = "git://github.com/nxp-qoriq-yocto-sdk/ipc;protocol=https;nobranch=1"
SRCREV = "74d662707558290f070f9589177db730444bc435"
S = "${WORKDIR}/git"
do_configure[depends] += "virtual/kernel:do_shared_workdir"
-do_compile_prepend () {
+do_compile:prepend () {
cd ${S}/kernel
}
diff --git a/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.24.1.bb b/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.24.1.bb
new file mode 100644
index 00000000..d2c63aa0
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.24.1.bb
@@ -0,0 +1,20 @@
+# Copyright 2020-2023 NXP
+
+DESCRIPTION = "Kernel loadable module for ISP"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://${S}/../LICENSE;md5=64381a6ea83b48c39fe524c85f65fb44"
+
+SRC_URI = "${ISP_KERNEL_SRC};branch=${SRCBRANCH}"
+ISP_KERNEL_SRC ?= "git://github.com/nxp-imx/isp-vvcam.git;protocol=https"
+SRCBRANCH = "lf-6.6.3_1.0.0"
+SRCREV = "2102360b58d9d1b36bc0c654c8301e4014b33951"
+
+S = "${WORKDIR}/git/vvcam/v4l2"
+
+inherit module
+
+DEBUG_PREFIX_MAP:prepend = " \
+ -fmacro-prefix-map=${WORKDIR}/git/vvcam=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR} \
+ -fdebug-prefix-map=${WORKDIR}/git/vvcam=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR} "
+
+COMPATIBLE_MACHINE = "(mx8mp-nxp-bsp)"
diff --git a/recipes-kernel/kernel-modules/kernel-module-ls-debug_git.bb b/recipes-kernel/kernel-modules/kernel-module-ls-debug_git.bb
index cad18b69..ba156161 100644
--- a/recipes-kernel/kernel-modules/kernel-module-ls-debug_git.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-ls-debug_git.bb
@@ -2,12 +2,12 @@ SUMMARY = "Layerscape Debug File System Module"
DESCRIPTION = "This package is the kernel module which is used for \
ls102xa targets debug."
SECTION = "ls-debug"
-LICENSE = "GPLv2+"
+LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=94263f12f9416f9fd0493c8f9e8085a3"
inherit module autotools-brokensep
-SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-yocto-sdk/ls-dbg;branch=nxp/master"
+SRC_URI = "git://github.com/nxp-qoriq-yocto-sdk/ls-dbg;branch=nxp/master;protocol=https"
SRCREV = "40501f6659e880d38508cdd34a4df2d348d1c68e"
S = "${WORKDIR}/git"
diff --git a/recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb b/recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb
new file mode 100644
index 00000000..48e9cc3b
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "NXP Wi-Fi driver for module 88w8801/8987/8997/9098 IW416/612"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://../../LICENSE;md5=ab04ac0f249af12befccb94447c08b77"
+
+# For backwards compatibility
+PROVIDES += "kernel-module-nxp89xx"
+RREPLACES:${PN} = "kernel-module-nxp89xx"
+RPROVIDES:${PN} = "kernel-module-nxp89xx"
+RCONFLICTS:${PN} = "kernel-module-nxp89xx"
+
+SRCBRANCH = "lf-6.6.3_1.0.0"
+MRVL_SRC ?= "git://github.com/nxp-imx/mwifiex.git;protocol=https"
+SRC_URI = "${MRVL_SRC};branch=${SRCBRANCH}"
+SRCREV = "a84df583155bad2a396a937056805550bdf655ab"
+
+S = "${WORKDIR}/git/mxm_wifiex/wlan_src"
+
+inherit module
+
+EXTRA_OEMAKE = "KERNELDIR=${STAGING_KERNEL_BUILDDIR} -C ${STAGING_KERNEL_BUILDDIR} M=${S}"
+
+COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-kernel/kernel-modules/kernel-module-perf-qoriq_0.8.2.bb b/recipes-kernel/kernel-modules/kernel-module-perf-qoriq_0.8.2.bb
deleted file mode 100644
index 4a31f1e3..00000000
--- a/recipes-kernel/kernel-modules/kernel-module-perf-qoriq_0.8.2.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-DESCRIPTION = "QorIQ extension to Perf for supporting non core counters"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=e29234dd5d40dc352cc60cc0c93437ba"
-
-SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-yocto-sdk/qoriq-perf;branch=nxp/master"
-SRCREV = "7beb3783edac66bab00c85d99a7b073f569af7fd"
-
-S = "${WORKDIR}/git"
-
-inherit module autotools-brokensep qoriq_build_64bit_kernel
-
-PROCESSOR_REV ?= "B4860_R1"
-EXTRA_OECONF += "--with-linux=${STAGING_KERNEL_DIR} \
- --with-processor=${PROCESSOR_REV}"
-
-EXTRA_OEMAKE += 'SYSROOT="${D}"'
-
-COMPATIBLE_MACHINE = "(b4860qds)"
diff --git a/recipes-kernel/kernel-modules/kernel-module-qca6174/0001-MLK-18491-02-qcacld-2.0-fix-the-overflow-of-bounce-b.patch b/recipes-kernel/kernel-modules/kernel-module-qca6174/0001-MLK-18491-02-qcacld-2.0-fix-the-overflow-of-bounce-b.patch
deleted file mode 100644
index 3ab1ccdd..00000000
--- a/recipes-kernel/kernel-modules/kernel-module-qca6174/0001-MLK-18491-02-qcacld-2.0-fix-the-overflow-of-bounce-b.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-From e480b6825d3670f3517c3b7be0c13fd318cbe985 Mon Sep 17 00:00:00 2001
-From: Hangtian Zhu <hangtian@qti.qualcomm.com>
-Date: Thu, 14 Jun 2018 11:10:05 +0800
-Subject: [PATCH] MLK-18491-02 qcacld-2.0: fix the overflow of bounce buffer
-
-Patch a41baa51cbc5("MLK-18491 qcacld-2.0: avoid overflow of bounce buffer")
-is not reasonable to fix overflow of bounce buffer issue.
-
-The patch is released by Qualcomm to fix the issue.
-(Case Number:03515221)
-
-Upstream-Status: Pending
-
-Signed-off-by: Hangtian Zhu <hangtian@qti.qualcomm.com>
----
- CORE/SERVICES/HTC/htc.c | 2 +-
- CORE/SERVICES/HTC/htc_send.c | 28 ++++++++++++++--------------
- 2 files changed, 15 insertions(+), 15 deletions(-)
-
-diff --git a/CORE/SERVICES/HTC/htc.c b/CORE/SERVICES/HTC/htc.c
-index 1e2450d..09936a0 100644
---- a/CORE/SERVICES/HTC/htc.c
-+++ b/CORE/SERVICES/HTC/htc.c
-@@ -657,7 +657,7 @@ static void ResetEndpointStates(HTC_TARGET *target)
- INIT_HTC_PACKET_QUEUE(&pEndpoint->RxBufferHoldQueue);
- pEndpoint->target = target;
- //pEndpoint->TxCreditFlowEnabled = (A_BOOL)htc_credit_flow;
-- pEndpoint->TxCreditFlowEnabled = (A_BOOL)0;
-+ pEndpoint->TxCreditFlowEnabled = (A_BOOL)1;
- adf_os_atomic_init(&pEndpoint->TxProcessCount);
- }
- }
-diff --git a/CORE/SERVICES/HTC/htc_send.c b/CORE/SERVICES/HTC/htc_send.c
-index 1a3dd28..19d8065 100644
---- a/CORE/SERVICES/HTC/htc_send.c
-+++ b/CORE/SERVICES/HTC/htc_send.c
-@@ -105,12 +105,12 @@ void HTCGetControlEndpointTxHostCredits(HTC_HANDLE HTCHandle, int *credits)
-
- static INLINE void RestoreTxPacket(HTC_TARGET *target, HTC_PACKET *pPacket)
- {
-+ adf_nbuf_t netbuf = GET_HTC_PACKET_NET_BUF_CONTEXT(pPacket);
- if (pPacket->PktInfo.AsTx.Flags & HTC_TX_PACKET_FLAG_FIXUP_NETBUF) {
-- adf_nbuf_t netbuf = GET_HTC_PACKET_NET_BUF_CONTEXT(pPacket);
- adf_nbuf_unmap(target->osdev, netbuf, ADF_OS_DMA_TO_DEVICE);
-- adf_nbuf_pull_head(netbuf, sizeof(HTC_FRAME_HDR));
- pPacket->PktInfo.AsTx.Flags &= ~HTC_TX_PACKET_FLAG_FIXUP_NETBUF;
- }
-+ adf_nbuf_pull_head(netbuf, sizeof(HTC_FRAME_HDR));
-
- }
-
-@@ -641,12 +641,11 @@ static A_STATUS HTCIssuePackets(HTC_TARGET *target,
- * that is already mapped, or a non-data netbuf that needs to be
- * mapped.
- */
-- if (pPacket->PktInfo.AsTx.Flags & HTC_TX_PACKET_FLAG_FIXUP_NETBUF) {
-- adf_nbuf_map(
-- target->osdev,
-- GET_HTC_PACKET_NET_BUF_CONTEXT(pPacket),
-- ADF_OS_DMA_TO_DEVICE);
-- }
-+ pPacket->PktInfo.AsTx.Flags |= HTC_TX_PACKET_FLAG_FIXUP_NETBUF;
-+ adf_nbuf_map(
-+ target->osdev,
-+ GET_HTC_PACKET_NET_BUF_CONTEXT(pPacket),
-+ ADF_OS_DMA_TO_DEVICE);
- }
- LOCK_HTC_TX(target);
- /* store in look up queue to match completions */
-@@ -1261,12 +1260,13 @@ A_STATUS HTCSendPktsMultiple(HTC_HANDLE HTCHandle, HTC_PACKET_QUEUE *pPktQueue)
- * mapped. This only applies to non-data frames, since data frames
- * were already mapped as they entered into the driver.
- */
-- adf_nbuf_map(
-- target->osdev,
-- GET_HTC_PACKET_NET_BUF_CONTEXT(pPacket),
-- ADF_OS_DMA_TO_DEVICE);
--
-- pPacket->PktInfo.AsTx.Flags |= HTC_TX_PACKET_FLAG_FIXUP_NETBUF;
-+ if(!IS_TX_CREDIT_FLOW_ENABLED(pEndpoint)) {
-+ pPacket->PktInfo.AsTx.Flags |= HTC_TX_PACKET_FLAG_FIXUP_NETBUF;
-+ adf_nbuf_map(
-+ target->osdev,
-+ GET_HTC_PACKET_NET_BUF_CONTEXT(pPacket),
-+ ADF_OS_DMA_TO_DEVICE);
-+ }
- } HTC_PACKET_QUEUE_ITERATE_END;
-
- HTCTrySend(target,pEndpoint,pPktQueue);
---
-1.9.1
-
diff --git a/recipes-kernel/kernel-modules/kernel-module-qca6174_2.0.bb b/recipes-kernel/kernel-modules/kernel-module-qca6174_2.0.bb
deleted file mode 100644
index 6da4c1d8..00000000
--- a/recipes-kernel/kernel-modules/kernel-module-qca6174_2.0.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-require kernel-module-qcacld-lea.inc
-
-SUMMARY = "Qualcomm WiFi driver for QCA module 6174"
-
-SRC_URI += "file://0001-MLK-18491-02-qcacld-2.0-fix-the-overflow-of-bounce-b.patch"
-
-EXTRA_OEMAKE += " \
- CONFIG_ROME_IF=pci \
- CONFIG_WLAN_FEATURE_11W=y \
- CONFIG_WLAN_FEATURE_FILS=y \
- CONFIG_WLAN_WAPI_MODE_11AC_DISABLE=y \
- MODNAME=qca6174 \
-"
diff --git a/recipes-kernel/kernel-modules/kernel-module-qca9377_2.0.bb b/recipes-kernel/kernel-modules/kernel-module-qca9377_2.0.bb
deleted file mode 100644
index da7a440b..00000000
--- a/recipes-kernel/kernel-modules/kernel-module-qca9377_2.0.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-require kernel-module-qcacld-lea.inc
-
-SUMMARY = "Qualcomm WiFi driver for QCA module 9377"
-
-EXTRA_OEMAKE += " \
- CONFIG_CLD_HL_SDIO_CORE=y \
- CONFIG_FEATURE_COEX_PTA_CONFIG_ENABLE=y \
- CONFIG_PER_VDEV_TX_DESC_POOL=1 \
- CONFIG_QCA_LL_TX_FLOW_CT=1 \
- CONFIG_QCA_SUPPORT_TXRX_DRIVER_TCP_DEL_ACK=y \
- CONFIG_WLAN_FEATURE_FILS=y \
- CONFIG_WLAN_WAPI_MODE_11AC_DISABLE=y \
- MODNAME=qca9377 \
- SAP_AUTH_OFFLOAD=1 \
-"
diff --git a/recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc b/recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc
deleted file mode 100644
index c11233ac..00000000
--- a/recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 2018 NXP
-
-SUMMARY = "Qualcomm WiFi driver for QCA module 9377 and 6174"
-LICENSE = "BSD & GPLv2"
-LIC_FILES_CHKSUM = "file://CORE/HDD/src/wlan_hdd_main.c;beginline=1;endline=20;md5=ec8d62116b13db773825ebf7cf91be1d;"
-
-QCACLD_SRC ?= "git://source.codeaurora.org/external/imx/qcacld-2.0-imx.git;protocol=https"
-SRC_URI = "${QCACLD_SRC};branch=IMX_CNSS.LEA.NRT_2.0"
-SRCREV = "72e56eb57e7d756f1f897645f653105541dff1f0"
-
-S = "${WORKDIR}/git"
-
-inherit module
-
-EXTRA_OEMAKE += " \
- CONFIG_CFG80211_INTERNAL_REGDB=y \
- CONFIG_HDD_WLAN_WAIT_TIME=10000 \
- CONFIG_LINUX_QCMBR=y \
- CONFIG_NON_QC_PLATFORM=y \
- CONFIG_PMF_SUPPORT=y \
- TARGET_BUILD_VARIANT=user \
-"
-COMPATIBLE_MACHINE = "(imx)"
diff --git a/recipes-kernel/kernel-modules/kernel-module-scatter-gather_git.bb b/recipes-kernel/kernel-modules/kernel-module-scatter-gather_git.bb
deleted file mode 100644
index 20d894ed..00000000
--- a/recipes-kernel/kernel-modules/kernel-module-scatter-gather_git.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-SUMMARY = "Scatter-gather logic for multiple tables"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=e9605a22ea50467bd2bfe4cdd66e69ae"
-
-inherit module
-
-SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-yocto-sdk/scatter-gather;branch=nxp/master"
-SRCREV = "97db173d08a70abe2b9a6fa928299a117f3febc2"
-
-S = "${WORKDIR}/git"
-
-COMPATIBLE_MACHINE = "(ls1021a)"
diff --git a/recipes-kernel/kernel-modules/kernel-module-uio-seville_0.1.bb b/recipes-kernel/kernel-modules/kernel-module-uio-seville_0.1.bb
index f7beed21..efccc286 100644
--- a/recipes-kernel/kernel-modules/kernel-module-uio-seville_0.1.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-uio-seville_0.1.bb
@@ -1,8 +1,8 @@
DESCRIPTION = "UIO driver for T1040 L2 Switch"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
-SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-yocto-sdk/l2switch-uio;branch=nxp/sdk-v2.0.x"
+SRC_URI = "git://github.com/nxp-qoriq-yocto-sdk/l2switch-uio;branch=nxp/sdk-v2.0.x;protocol=https"
SRCREV = "0f31fbcbe9ab1ab9c424da34f70c82314b16f8de"
inherit module