aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch')
-rw-r--r--recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch30
1 files changed, 12 insertions, 18 deletions
diff --git a/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch b/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch
index 9d5003e2..01b2b040 100644
--- a/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch
+++ b/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch
@@ -14,11 +14,11 @@ Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
meson.build | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
-diff --git a/meson.build b/meson.build
-index efb51f4..0ee3ee5 100644
---- a/meson.build
-+++ b/meson.build
-@@ -72,6 +72,7 @@ dep_udev = _dep_null
+Index: git/meson.build
+===================================================================
+--- git.orig/meson.build
++++ git/meson.build
+@@ -72,6 +72,7 @@ dep_gbm = _dep_null
dep_cocoa = _dep_null
dep_core_foundation = _dep_null
dep_gl_headers = _dep_null
@@ -26,19 +26,13 @@ index efb51f4..0ee3ee5 100644
# Get dependencies
if build_wgl
-@@ -101,12 +102,14 @@ else
- endif
- dep_gbm = dependency('gbm', required : get_option('gbm'))
- dep_udev = dependency('libudev', required : get_option('gbm'))
-+ dep_surfaceless_egl = dependency('egl', required : get_option('surfaceless_egl'))
-+ dep_surfaceless_gbm = dependency('gbm', required : get_option('surfaceless_egl'))
+@@ -99,7 +100,8 @@ else
+ build_gbm = dep_drm.found() and dep_egl.found() and dep_gbm.found()
- build_x11_egl = dep_egl.found()
- build_wayland = dep_wayland_client.found() and dep_wayland_egl.found() and dep_wayland_wayland_egl.found()
- build_glx = dep_gl.found()
- build_gbm = dep_gbm.found() and dep_udev.found()
+ dep_egl = dependency('egl', required : get_option('surfaceless_egl'))
- build_surfaceless = dep_egl.found()
-+ build_surfaceless = dep_surfaceless_egl.found() and dep_surfaceless_gbm.found()
- endif
++ dep_gbm = dependency('gbm', required : get_option('surfaceless_egl'))
++ build_surfaceless = dep_egl.found() and dep_gbm.found()
- dep_bash = dependency('bash-completion', required : false)
+ dep_egl = dependency('egl', required : get_option('wayland'))
+ dep_wayland_client = dependency(