aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa/mesa_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/mesa/mesa_%.bbappend')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend41
1 files changed, 13 insertions, 28 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index fce3802e..acddfbc6 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,8 +1,8 @@
-PROVIDES_remove_imxgpu = "virtual/egl"
-PROVIDES_remove_imxgpu3d = "virtual/libgl virtual/libgles1 virtual/libgles2"
+PROVIDES:remove:imxgpu = "virtual/egl"
+PROVIDES:remove:imxgpu3d = "virtual/libgl virtual/libgles1 virtual/libgles2"
-PACKAGECONFIG_remove_imxgpu = "egl gbm"
-PACKAGECONFIG_remove_imxgpu3d = "gles"
+PACKAGECONFIG:remove:imxgpu = "egl gbm"
+PACKAGECONFIG:remove:imxgpu3d = "gles"
# FIXME: mesa should support 'x11-no-tls' option
python () {
@@ -15,28 +15,13 @@ python () {
}
# Enable Etnaviv and Freedreno support
-PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno"
-
-# For NXP BSP, choose between gallium and osmesa, and between enabling
-# dri and swrast or not. gallium and dri are default.
-#
-# For parts with no GPU, use gallium and dri
-PACKAGECONFIG_REMOVE_NXPBSP = ""
-PACKAGECONFIG_APPEND_NXPBSP = ""
-DRIDRIVERS_NXPBSP = ""
-#
-# For parts with GPU but no DRM, use gallium
-PACKAGECONFIG_REMOVE_NXPBSP_imxgpu = "dri"
-DRIDRIVERS_NXPBSP_imxgpu = ""
-#
-# For parts with GPU and DRM, use osmesa, dri, and swrast
-PACKAGECONFIG_REMOVE_NXPBSP_imxgpu_imxdrm = "gallium"
-PACKAGECONFIG_APPEND_NXPBSP_imxgpu_imxdrm = "osmesa"
-DRIDRIVERS_NXPBSP_imxgpu_imxdrm = "swrast"
-#
-PACKAGECONFIG_remove_use-nxp-bsp = "${PACKAGECONFIG_REMOVE_NXPBSP}"
-PACKAGECONFIG_append_use-nxp-bsp = " ${PACKAGECONFIG_APPEND_NXPBSP}"
-DRIDRIVERS_use-nxp-bsp = "${DRIDRIVERS_NXPBSP}"
+PACKAGECONFIG:append:use-mainline-bsp = " gallium etnaviv kmsro freedreno"
+
+# For NXP BSP, GPU drivers don't support dri
+PACKAGECONFIG:remove:imxgpu:use-nxp-bsp = "dri"
+
+# mainline/etnaviv:
+RRECOMMENDS:${PN}-megadriver:append:use-mainline-bsp = " libdrm-etnaviv mesa-etnaviv-env"
BACKEND = \
"${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \
@@ -44,7 +29,7 @@ BACKEND = \
'fb', d), d)}"
# FIXME: Dirty hack to allow use of Vivante GPU libGL binary
-do_install_append_imxgpu3d () {
+do_install:append:imxgpu3d () {
rm -f ${D}${libdir}/libGL.* \
${D}${includedir}/GL/gl.h \
${D}${includedir}/GL/glcorearb.h \
@@ -56,6 +41,6 @@ do_install_append_imxgpu3d () {
fi
}
-do_install_append_imxgpu () {
+do_install:append:imxgpu () {
rm -rf ${D}${includedir}/KHR
}