aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa/mesa-gl_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/mesa/mesa-gl_%.bbappend')
-rw-r--r--recipes-graphics/mesa/mesa-gl_%.bbappend9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-graphics/mesa/mesa-gl_%.bbappend b/recipes-graphics/mesa/mesa-gl_%.bbappend
index ca1c8f46..6545571f 100644
--- a/recipes-graphics/mesa/mesa-gl_%.bbappend
+++ b/recipes-graphics/mesa/mesa-gl_%.bbappend
@@ -1 +1,8 @@
-COMPATIBLE_MACHINE_imxgpu = "(-)"
+DEPENDS:append:imxgpu = " virtual/egl"
+
+do_install:append:imxgpu() {
+ # imx-gpu-viv and mali-imx both provide /usr/include/KHR, so drop the mesa-gl one
+ rm -rf ${D}${includedir}/KHR
+}
+
+COMPATIBLE_MACHINE:imxgpu = "(imxgpu)"