aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-fsl/packagegroups/packagegroup-fsl-isp.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-fsl/packagegroups/packagegroup-fsl-isp.bb')
-rw-r--r--recipes-fsl/packagegroups/packagegroup-fsl-isp.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-isp.bb b/recipes-fsl/packagegroups/packagegroup-fsl-isp.bb
new file mode 100644
index 00000000..415587a8
--- /dev/null
+++ b/recipes-fsl/packagegroups/packagegroup-fsl-isp.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Add packages for ISP build"
+
+# basler-camera* gets dynamically renamed
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+inherit packagegroup
+
+ISP_PKGS ?= ""
+ISP_PKGS:mx8mp-nxp-bsp = " \
+ isp-imx \
+ basler-camera \
+ basler-camera-dev \
+ kernel-module-isp-vvcam \
+"
+RDEPENDS:${PN} = " \
+ ${ISP_PKGS} \
+"