aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/vpp-core/vpp-core.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/vpp-core/vpp-core.bb')
-rw-r--r--recipes-extended/vpp-core/vpp-core.bb45
1 files changed, 0 insertions, 45 deletions
diff --git a/recipes-extended/vpp-core/vpp-core.bb b/recipes-extended/vpp-core/vpp-core.bb
deleted file mode 100644
index 3155543d..00000000
--- a/recipes-extended/vpp-core/vpp-core.bb
+++ /dev/null
@@ -1,45 +0,0 @@
-DESCRIPTION = "Vector Packet Processing"
-
-S = "${WORKDIR}/git/"
-PV = "19.01"
-
-LICENSE = "Apache-2.0"
-
-LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e"
-
-OECMAKE_SOURCEPATH = "${S}/src"
-
-SRCREV = "ff7bf7bdc0fd5a7029abdf9083178d066a42a9fb"
-
-SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/vpp;nobranch=1 \
- file://0001-GCC-above-5.4-fails-when-we-specify-arch-funattribut.patch \
- file://0001-getcpu-rename-getcpu-to-avoid-conflict-with-glibc-2..patch \
- file://0001-vpp-core-fix-package_qa-error.patch \
-"
-DEPENDS = "dpdkvpp openssl python-ply util-linux vpp-core-native"
-
-DEPENDS_class-native = "openssl-native python-ply-native util-linux-native"
-
-inherit cmake
-inherit pkgconfig
-inherit python-dir pythonnative
-
-export ARCH="arm64"
-export OPENSSL_PATH = "${RECIPE_SYSROOT}"
-export DPDK_PATH= "${RECIPE_SYSROOT}"
-
-EXTRA_OECONF = " \
- --with-libtool-sysroot=${SYSROOT} \
- --srcdir=${S}/src \
- --with-pre-data=128 \
- --without-libnuma \
- --without-ipv6sr \
-"
-
-CFLAGS += " -mtls-dialect=trad -DCLIB_LOG2_CACHE_LINE_BYTES=6 -I${OPENSSL_PATH}/usr/include -L${OPENSSL_PATH}/lib"
-
-include vpp-pkgs.inc
-
-BBCLASSEXTEND = "native nativesdk"
-
-COMPATIBLE_MACHINE_class-target = "(qoriq)"