aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/libpkcs11/libpkcs11_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/libpkcs11/libpkcs11_git.bb')
-rw-r--r--recipes-extended/libpkcs11/libpkcs11_git.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/recipes-extended/libpkcs11/libpkcs11_git.bb b/recipes-extended/libpkcs11/libpkcs11_git.bb
index 30f33a20..731b7a23 100644
--- a/recipes-extended/libpkcs11/libpkcs11_git.bb
+++ b/recipes-extended/libpkcs11/libpkcs11_git.bb
@@ -1,11 +1,11 @@
DESCRIPTION = "PKCS library"
-LICENSE = "GPLv2 & BSD"
+LICENSE = "GPL-2.0-only & BSD"
LIC_FILES_CHKSUM = "file://LICENSE;md5=803852533e29eb1d6d5e55ad3078b625"
-SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/libpkcs11;nobranch=1 \
+SRC_URI = "git://github.com/nxp-qoriq/libpkcs11;protocol=https;nobranch=1 \
file://0001-fix-multiple-definition-error.patch \
"
-SRCREV = "a243fb21772f1bd434d8bc1ac45feb36571afadb"
+SRCREV = "8d85182b7a7cd393ab6dd72930f8d1b69468f741"
DEPENDS = "openssl secure-obj"
@@ -30,10 +30,11 @@ do_install(){
mkdir -p ${D}/${includedir} ${D}/${bindir}
cp ${S}/out/export/lib/libpkcs11.so ${D}/${libdir}
cp ${S}/out/export/include/*.h ${D}/${includedir}
+ rm -f ${D}${includedir}/pkcs11.h
cp ${S}/out/export/app/* ${D}/${bindir}
}
PARALLEL_MAKE = ""
-INSANE_SKIP_${PN} = "ldflags dev-deps"
-INSANE_SKIP_${PN}-dev = "ldflags dev-elf"
+INSANE_SKIP:${PN} = "ldflags dev-deps"
+INSANE_SKIP:${PN}-dev = "ldflags dev-elf"
COMPATIBLE_MACHINE = "(qoriq-arm64)"