aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2/restool/restool_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-dpaa2/restool/restool_git.bb')
-rw-r--r--recipes-dpaa2/restool/restool_git.bb21
1 files changed, 12 insertions, 9 deletions
diff --git a/recipes-dpaa2/restool/restool_git.bb b/recipes-dpaa2/restool/restool_git.bb
index 0211c779..1d1aeffe 100644
--- a/recipes-dpaa2/restool/restool_git.bb
+++ b/recipes-dpaa2/restool/restool_git.bb
@@ -1,17 +1,17 @@
SUMMARY = "DPAA2 Resource Manager Tool"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://COPYING;md5=ec8d84e9cd4de287e290275d09db27f0"
+LICENSE = "BSD-3-Clause | GPL-2.0-or-later"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ec8d84e9cd4de287e290275d09db27f0"
-RDEPENDS_${PN} += "bash dtc"
-
-SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/restool;nobranch=1 \
- file://0001-restool-fix-build-error-with-gcc7.patch"
-
-SRCREV = "f0cec094e4c6d1c975b377203a3bf994ba9325a9"
+SRC_URI = "git://github.com/nxp-qoriq/restool;protocol=https;nobranch=1 \
+ file://disable-manpage-generation.patch \
+"
+SRCREV = "46604e41f4c7e54efa62503c6b4629321b21e056"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = 'CC="${CC}" EXTRA_CFLAGS="-Wno-missing-field-initializers -Wno-missing-braces"'
+inherit bash-completion
+
+EXTRA_OEMAKE = 'CC="${CC}" MANPAGE= EXTRA_CFLAGS="-O2 -Wno-missing-field-initializers -Wno-missing-braces -Wno-maybe-uninitialized -Wno-date-time"'
do_install () {
oe_runmake install DESTDIR=${D}
@@ -20,3 +20,6 @@ do_install () {
COMPATIBLE_MACHINE = "(qoriq-arm64)"
PACKAGE_ARCH = "${MACHINE_ARCH}"
+RDEPENDS:${PN} += "bash dtc"
+RDEPENDS:${PN}-bash-completion += "bash"
+