aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-dpaa/fm-ucode/fm-ucode_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-dpaa/fm-ucode/fm-ucode_git.bb')
-rw-r--r--recipes-dpaa/fm-ucode/fm-ucode_git.bb24
1 files changed, 12 insertions, 12 deletions
diff --git a/recipes-dpaa/fm-ucode/fm-ucode_git.bb b/recipes-dpaa/fm-ucode/fm-ucode_git.bb
index 39e4f9d0..22f04d01 100644
--- a/recipes-dpaa/fm-ucode/fm-ucode_git.bb
+++ b/recipes-dpaa/fm-ucode/fm-ucode_git.bb
@@ -1,25 +1,25 @@
DESCRIPTION = "Fman microcode binary"
SECTION = "fm-ucode"
-LICENSE = "Freescale-Binary-EULA"
-LIC_FILES_CHKSUM = "file://Freescale-Binary-EULA;md5=b784c031868ba1bd5ebc5de372c823fa"
+LICENSE = "NXP-Binary-EULA"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=12e248d404ce1ea8bed0148fcf127e69"
PR = "r1"
inherit deploy
-SRC_URI = "git://github.com/NXP/qoriq-fm-ucode.git;nobranch=1"
-SRCREV = "c275e91392e2adab1ed22f3867b8269ca3c54014"
+SRC_URI = "git://github.com/NXP/qoriq-fm-ucode.git;nobranch=1;protocol=https"
+SRCREV = "41d603a1ad78e0bb61365500828d9f484bf9bf10"
S = "${WORKDIR}/git"
REGLEX ?= "${MACHINE}"
-REGLEX_t1023 = "t1024"
-REGLEX_t1040 = "t1040"
-REGLEX_t1042 = "t1040"
+REGLEX:t1023 = "t1024"
+REGLEX:t1040 = "t1040"
+REGLEX:t1042 = "t1040"
REGLEX_b4420 = "b4860"
-REGLEX_t4160 = "t4240"
-REGLEX_ls1043a = "ls1043"
-REGLEX_ls1046a = "ls1046"
+REGLEX:t4160 = "t4240"
+REGLEX:ls1043a = "ls1043"
+REGLEX:ls1046a = "ls1046"
do_install () {
UCODE=`echo ${REGLEX} | sed -e 's,-.*$,,' -e 's,[a-zA-Z]*$,,'`
@@ -35,8 +35,8 @@ do_deploy () {
addtask deploy before do_build after do_install
PACKAGES += "${PN}-image"
-FILES_${PN}-image += "/boot"
-ALLOW_EMPTY_${PN} = "1"
+FILES:${PN}-image += "/boot"
+ALLOW_EMPTY:${PN} = "1"
COMPATIBLE_MACHINE = "(e500mc|e5500|e5500-64b|e6500|e6500-64b|fsl-lsch2)"
PACKAGE_ARCH = "${MACHINE_SOCARCH}"