aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-downgrade/vulkan/vulkan-headers_1.3.261.1.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-downgrade/vulkan/vulkan-headers_1.3.261.1.imx.bb')
-rw-r--r--recipes-downgrade/vulkan/vulkan-headers_1.3.261.1.imx.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-downgrade/vulkan/vulkan-headers_1.3.261.1.imx.bb b/recipes-downgrade/vulkan/vulkan-headers_1.3.261.1.imx.bb
new file mode 100644
index 00000000..01eb14b9
--- /dev/null
+++ b/recipes-downgrade/vulkan/vulkan-headers_1.3.261.1.imx.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Vulkan Header files and API registry"
+DESCRIPTION = "Vulkan is a 3D graphics and compute API providing cross-platform access \
+to modern GPUs with low overhead and targeting realtime graphics applications such as \
+games and interactive media. This package contains the development headers \
+for packages wanting to make use of Vulkan."
+HOMEPAGE = "https://www.khronos.org/vulkan/"
+BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Headers"
+SECTION = "libs"
+
+LICENSE = "Apache-2.0 & MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=1bc355d8c4196f774c8b87ed1a8dd625"
+SRC_URI = "git://github.com/KhronosGroup/Vulkan-Headers.git;branch=main;protocol=https"
+
+SRCREV = "85c2334e92e215cce34e8e0ed8b2dce4700f4a50"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+FILES:${PN} += "${datadir}/vulkan"
+RDEPENDS:${PN} += "python3-core"
+
+# These recipes need to be updated in lockstep with each other:
+# glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools
+# The tags versions should always be sdk-x.y.z, as this is what
+# upstream considers a release.
+UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"