aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/rcw/rcw_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/rcw/rcw_git.bb')
-rw-r--r--recipes-bsp/rcw/rcw_git.bb33
1 files changed, 18 insertions, 15 deletions
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
index 3808a712..5721313b 100644
--- a/recipes-bsp/rcw/rcw_git.bb
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -1,30 +1,33 @@
SUMMARY = "Reset Configuration Word"
DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=45a017ee5f4cfe64b1cddf2eb06cffc7"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=44a0d0fad189770cc022af4ac6262cbe"
-DEPENDS += "change-file-endianess-native tcl-native"
+DEPENDS += "tcl-native"
inherit deploy siteinfo
-SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/rcw;nobranch=1"
-SRCREV = "93358b4872bc69f1e3757739d70f20c8b18894e4"
+SRC_URI = "git://github.com/nxp-qoriq/rcw;protocol=https;nobranch=1"
+SRCREV = "020dcf0645959afec6705f518e8350476891ef4f"
S = "${WORKDIR}/git"
-export PYTHON = "${USRBINPATH}/python2"
+export PYTHON = "${USRBINPATH}/python3"
M="${@d.getVar('MACHINE').replace('-64b','').replace('-32b','').replace('-${SITEINFO_ENDIANNESS}','')}"
+BOARD_TARGETS="${M}"
+BOARD_TARGETS:ls2088ardb="${M} ${M}_rev1.1"
+BOARD_TARGETS:ls1088ardb-pb="ls1088ardb"
+BOARD_TARGETS:lx2160ardb = "${M} ${M}_rev2"
+BOARD_TARGETS:lx2160ardb-rev2 = "lx2160ardb_rev2"
+
+do_compile () {
+ oe_runmake BOARDS="${BOARD_TARGETS}" DESTDIR=${D}/boot/rcw/
+}
+
do_install () {
- if [ ${M} = ls2088ardb ]; then
- oe_runmake BOARDS=${M} DESTDIR=${D}/boot/rcw/ install
- oe_runmake BOARDS=${M}_rev1.1 DESTDIR=${D}/boot/rcw/ install
- elif [ ${M} = ls1088ardb-pb ]; then
- oe_runmake BOARDS=ls1088ardb DESTDIR=${D}/boot/rcw/ install
- else
- oe_runmake BOARDS=${M} DESTDIR=${D}/boot/rcw/ install
- fi
+ oe_runmake BOARDS="${BOARD_TARGETS}" DESTDIR=${D}/boot/rcw/ install
}
do_deploy () {
@@ -34,7 +37,7 @@ do_deploy () {
addtask deploy after do_install
PACKAGES += "${PN}-image"
-FILES_${PN}-image += "/boot"
+FILES:${PN}-image += "/boot"
COMPATIBLE_MACHINE = "(qoriq)"
PACKAGE_ARCH = "${MACHINE_ARCH}"