aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-vpu')
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch27
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu.inc22
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb8
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu_5.4.28.bb12
4 files changed, 69 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch b/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch
new file mode 100644
index 00000000..13f61b27
--- /dev/null
+++ b/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch
@@ -0,0 +1,27 @@
+Obey CFLAGS, LDFLAGS
+
+Signed-off-by: Christopher Larson <chris_larson@mentor.com>
+Upstream-status: Pending
+
+--- imx-vpu-11.09.02.orig/vpu/Makefile 2014-09-02 13:14:50.862005896 -0700
++++ imx-vpu-11.09.02/vpu/Makefile 2014-09-02 13:15:15.018153222 -0700
+@@ -1,5 +1,6 @@
+ CC ?=$(CROSS_COMPILE)gcc
+ AR ?=$(CROSS_COMPILE)ar
++CFLAGS ?= -O2
+
+ # list of platforms which want this test case
+ INCLUDE_LIST:= IMX27ADS IMX51 IMX53 IMX6Q
+@@ -33,10 +34,10 @@
+ endif
+
+ %.o: %.c
+- $(CC) -D$(PLATFORM) -Wall -O2 -fPIC -c $^ -o $@
++ $(CC) -D$(PLATFORM) -Wall -fPIC $(CFLAGS) -c $^ -o $@
+
+ $(LIBNAME).so.$(SONAMEVERSION): $(OBJ)
+- $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@
++ $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@ $(LDFLAGS)
+
+ $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
+ ln -s $< $@
diff --git a/recipes-bsp/imx-vpu/imx-vpu.inc b/recipes-bsp/imx-vpu/imx-vpu.inc
new file mode 100644
index 00000000..fd59770a
--- /dev/null
+++ b/recipes-bsp/imx-vpu/imx-vpu.inc
@@ -0,0 +1,22 @@
+# Copyright (C) 2013 Freescale Semiconductor
+DESCRIPTION = "Freescale VPU library"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://vpu/EULA.txt;md5=b063366b066c9f10037c59756a9ced54"
+DEPENDS = "virtual/kernel"
+inherit fsl-eula-unpack
+
+PLATFORM_mx5 = "IMX51"
+PLATFORM_mx6 = "IMX6Q"
+
+SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
+
+do_compile () {
+ INCLUDE_DIR="-I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include"
+
+ oe_runmake CROSS_COMPILE="${HOST_PREFIX}" PLATFORM="${PLATFORM}" INCLUDE="${INCLUDE_DIR}" all
+}
+
+do_install () {
+ oe_runmake PLATFORM="${PLATFORM}" DEST_DIR="${D}" install
+}
+
diff --git a/recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb b/recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb
new file mode 100644
index 00000000..c5dd9bd5
--- /dev/null
+++ b/recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb
@@ -0,0 +1,8 @@
+# Copyright (C) 2013 Freescale Semiconductor
+require imx-vpu.inc
+
+SRC_URI += "file://obey-variables.patch"
+SRC_URI[md5sum] = "1988a08687a09ef8590e66ff17ac6ed3"
+SRC_URI[sha256sum] = "783f136aa9b9257d4bffbdaf05bdcb85d177c544c3f8a4674421ba7b065ed5c0"
+
+COMPATIBLE_MACHINE = "(mx5)"
diff --git a/recipes-bsp/imx-vpu/imx-vpu_5.4.28.bb b/recipes-bsp/imx-vpu/imx-vpu_5.4.28.bb
new file mode 100644
index 00000000..6f691562
--- /dev/null
+++ b/recipes-bsp/imx-vpu/imx-vpu_5.4.28.bb
@@ -0,0 +1,12 @@
+# Copyright (C) 2013-2015 Freescale Semiconductor
+
+require imx-vpu.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=acdb807ac7275fe32f9f64992e111241"
+
+PE = "1"
+
+SRC_URI[md5sum] = "774455b57aaa12bae2e2cecf39b63ac4"
+SRC_URI[sha256sum] = "0a05af1a5978175de852b2cf61763ec789f2845df78edb8d02a28611439b57f7"
+
+COMPATIBLE_MACHINE = "(mx6)"