aboutsummaryrefslogtreecommitdiffstats
path: root/meta-fsl-ppc/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-fsl-ppc/recipes-bsp')
-rw-r--r--meta-fsl-ppc/recipes-bsp/apptrk/apptrk_git.bb20
-rw-r--r--meta-fsl-ppc/recipes-bsp/boot-format/boot-format/flags.patch21
-rw-r--r--meta-fsl-ppc/recipes-bsp/boot-format/boot-format_git.bb20
-rw-r--r--meta-fsl-ppc/recipes-bsp/ipc/ipc-ust_git.bb50
-rw-r--r--meta-fsl-ppc/recipes-bsp/ipc/ipc.inc7
-rw-r--r--meta-fsl-ppc/recipes-bsp/pkc-firmware/pkc-firmware_git.bb41
-rw-r--r--meta-fsl-ppc/recipes-bsp/qe-ucode/qe-ucode_git.bb35
-rw-r--r--meta-fsl-ppc/recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch57
-rw-r--r--meta-fsl-ppc/recipes-bsp/rcw/rcw_git.bb36
-rw-r--r--meta-fsl-ppc/recipes-bsp/u-boot/files/0001-u-boot-mpc85xx-u-boot-.lds-remove-_GLOBAL_OFFSET_TAB.patch77
-rw-r--r--meta-fsl-ppc/recipes-bsp/u-boot/files/Fix-the-depend-race-issue.patch38
-rw-r--r--meta-fsl-ppc/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb189
12 files changed, 0 insertions, 591 deletions
diff --git a/meta-fsl-ppc/recipes-bsp/apptrk/apptrk_git.bb b/meta-fsl-ppc/recipes-bsp/apptrk/apptrk_git.bb
deleted file mode 100644
index 09d5de59..00000000
--- a/meta-fsl-ppc/recipes-bsp/apptrk/apptrk_git.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-DESCRIPTION = "Userspace debug agent for PA CodeWarrior"
-LICENSE = "Freescale-EULA"
-LIC_FILES_CHKSUM = "file://COPYING;md5=95560debfde180684364319811cc1421"
-
-DEPENDS = "elfutils"
-
-SRC_URI = "git://git.freescale.com/ppc/sdk/apptrk.git;nobranch=1"
-SRCREV = "cbed10997c5e2a4aaa004fb0e1efec858bf1bbe1"
-
-S = "${WORKDIR}/git"
-
-CFLAGS += " -I${STAGING_INCDIR} -ISource/Linux -ISource/Portable \
- -ISource/Linux_PA -ISource/PA -DPPC \
-"
-CFLAGS_append_powerpc64 = " -DENABLE_64BIT_SUPPORT"
-
-do_install() {
- install -d ${D}/usr/bin
- oe_runmake install DESTDIR=${D}
-}
diff --git a/meta-fsl-ppc/recipes-bsp/boot-format/boot-format/flags.patch b/meta-fsl-ppc/recipes-bsp/boot-format/boot-format/flags.patch
deleted file mode 100644
index cddb34cd..00000000
--- a/meta-fsl-ppc/recipes-bsp/boot-format/boot-format/flags.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Index: git/Makefile
-===================================================================
---- git.orig/Makefile
-+++ git/Makefile
-@@ -3,14 +3,14 @@
- INSTALL=install
- PREFIX=/usr
-
--CFLAGS=-Wall
-+override CFLAGS+=-Wall
-
- all: boot_format
-
- boot_format.o: boot_format.c boot_format.h
-
- boot_format: boot_format.o
-- $(CC) $< -o $@
-+ $(CC) $(CFLAGS) $< -o $@ $(LDFLAGS)
-
- install: boot_format
- $(INSTALL) -d $(DESTDIR)$(PREFIX)/bin
diff --git a/meta-fsl-ppc/recipes-bsp/boot-format/boot-format_git.bb b/meta-fsl-ppc/recipes-bsp/boot-format/boot-format_git.bb
deleted file mode 100644
index 2d9f9b1d..00000000
--- a/meta-fsl-ppc/recipes-bsp/boot-format/boot-format_git.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-DESCRIPTION = "Boot format utility for booting from eSDHC/eSPI"
-LICENSE = "GPLv2"
-PR = "r6"
-LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-
-SRC_URI = "git://git.freescale.com/ppc/sdk/boot-format.git;nobranch=1 \
- file://flags.patch"
-SRCREV = "4eb81a6797ef4e58bf7d9b2d58afb37a21c1f550"
-
-S = "${WORKDIR}/git"
-EXTRA_OEMAKE = 'CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"'
-
-do_install(){
- oe_runmake DESTDIR=${D} PREFIX=${prefix} install
-}
-
-PACKAGES =+ "${PN}-config"
-FILES_${PN}-config += "${datadir}/*"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-fsl-ppc/recipes-bsp/ipc/ipc-ust_git.bb b/meta-fsl-ppc/recipes-bsp/ipc/ipc-ust_git.bb
deleted file mode 100644
index c6b3cfe6..00000000
--- a/meta-fsl-ppc/recipes-bsp/ipc/ipc-ust_git.bb
+++ /dev/null
@@ -1,50 +0,0 @@
-SUMMARY = "Linux IPC Userspace Tool"
-DESCRIPTION = "DSP boot application and ipc test application"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://COPYING;md5=fa38cd73d71527dc6efb546474f64d10"
-
-require ipc.inc
-
-S = "${WORKDIR}/git"
-
-# workaround for issue of parallel build, required a actual fix in ipc source
-PARALLEL_MAKE = ""
-
-EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC}" AR="${AR}"'
-
-do_compile () {
- case ${MACHINE} in
- bsc9132qds|bsc9131rdb) SOC=B913x;;
- b4860qds|b4420qds|b4860qds-64b) SOC=B4860;;
- esac
- oe_runmake ${SOC}=1
-}
-
-do_install () {
- install -d ${D}${bindir}
- install -d ${D}${includedir}
- install -d ${D}/ipc
- install -m 755 ${S}/dsp_boot/dsp_bt ${D}/ipc
- install -m 755 ${S}/ipc/ipc_test ${D}/ipc
- install -m 755 ${S}/ipc/ipc_test67 ${D}/ipc
- install -m 755 ${S}/ipc/l1d_app ${D}/ipc
- install -m 755 ${S}/fsl_shm/app ${D}${bindir}/lg_shm_test
- install -d ${D}${base_libdir}
- install -m 755 ${S}/ipc/libipc.so ${D}${base_libdir}
- install -m 755 ${S}/ipc/libmem.so ${D}${base_libdir}
- install -m 755 ${S}/ipc/libdspboot.so ${D}${base_libdir}
- install -d ${D}${includedir}/ipc
- install -d ${D}${includedir}/ipc/ipc/include
- install -d ${D}${includedir}/ipc/fsl_shm/lib
- install ${S}/ipc/include/*.h ${D}${includedir}/ipc/ipc/include
- install ${S}/dsp_boot/*.h ${D}${includedir}/ipc/ipc/include
- install ${S}/kernel/fsl_ipc_types.h ${D}${includedir}/ipc/ipc/include
- install ${S}/kernel/fsl_heterogeneous_common.h ${D}${includedir}/ipc/ipc/include
- install ${S}/kernel/fsl_heterogeneous_l1_defense.h ${D}${includedir}/ipc/ipc/include
- install ${S}/fsl_shm/include/*.h ${D}${includedir}/ipc/ipc/include
- install ${S}/fsl_shm/lib/*.h ${D}${includedir}/ipc/fsl_shm/lib
-}
-
-FILES_${PN} += "/ipc/*"
-FILES_${PN}-dbg += "/ipc/.debug"
-
diff --git a/meta-fsl-ppc/recipes-bsp/ipc/ipc.inc b/meta-fsl-ppc/recipes-bsp/ipc/ipc.inc
deleted file mode 100644
index 547771ae..00000000
--- a/meta-fsl-ppc/recipes-bsp/ipc/ipc.inc
+++ /dev/null
@@ -1,7 +0,0 @@
-DEPENDS = "virtual/kernel"
-
-SRC_URI = "git://git.freescale.com/ppc/sdk/ipc.git;nobranch=1"
-SRCREV = "c9c92ac6a7a31c9d878096eb7d135c22a38f20ff"
-
-COMPATIBLE_MACHINE = "(bsc9132qds|bsc9131rdb|b4860qds|b4420qds)"
-
diff --git a/meta-fsl-ppc/recipes-bsp/pkc-firmware/pkc-firmware_git.bb b/meta-fsl-ppc/recipes-bsp/pkc-firmware/pkc-firmware_git.bb
deleted file mode 100644
index 3cc5d446..00000000
--- a/meta-fsl-ppc/recipes-bsp/pkc-firmware/pkc-firmware_git.bb
+++ /dev/null
@@ -1,41 +0,0 @@
-DESCRIPTION = "U-boot firmware for c293pcie support "
-HOMEPAGE = "http://u-boot.sf.net"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
-
-INHIBIT_DEFAULT_DEPS = "1"
-DEPENDS = "virtual/${TARGET_PREFIX}gcc libgcc"
-
-inherit deploy
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-firmware.git;nobranch=1"
-SRCREV = "b891873c1eea7a7d53f9472ea601712897cb17b7"
-
-S = "${WORKDIR}/git"
-
-EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
-
-do_compile () {
- unset LDFLAGS
- unset CFLAGS
- unset CPPFLAGS
- oe_runmake C293QDS_36BIT_SDCARD
-}
-
-do_install(){
- install -d ${D}${sysconfdir}/crypto/
- install ${S}/u-boot.bin ${D}${sysconfdir}/crypto/pkc-firmware.bin
-}
-
-do_deploy(){
- install -d ${DEPLOYDIR}/pkc-firmware
- install ${S}/u-boot.bin ${DEPLOYDIR}/pkc-firmware/pkc-firmware.bin
-}
-
-addtask deploy after do_install
-
-FILES_{PN} += "/etc/crypto/pkc-firmware.bin"
-COMPATIBLE_MACHINE = "(c293pcie)"
-
diff --git a/meta-fsl-ppc/recipes-bsp/qe-ucode/qe-ucode_git.bb b/meta-fsl-ppc/recipes-bsp/qe-ucode/qe-ucode_git.bb
deleted file mode 100644
index 028d9bcd..00000000
--- a/meta-fsl-ppc/recipes-bsp/qe-ucode/qe-ucode_git.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-DESCRIPTION = "qe microcode binary"
-SECTION = "qe-ucode"
-LICENSE = "Freescale-EULA"
-LIC_FILES_CHKSUM = "file://EULA;md5=60037ccba533a5995e8d1a838d85799c"
-
-python () {
- if not d.getVar("QE_UCODE", True):
- machine = d.getVar("MACHINE", True)
- raise bb.parse.SkipPackage("QE_UCODE not set in \
- meta-fsl-ppc/conf/machine/%s.conf" % machine)
-}
-
-inherit deploy
-
-SRC_URI = "git://git.freescale.com/ppc/sdk/qe-ucode.git;nobranch=1"
-SRCREV= "49efc94b553de5c2a9bd28093592eff0068e161c"
-
-S = "${WORKDIR}/git"
-
-do_install () {
- install -d ${D}/boot
- install -m 644 ${QE_UCODE} ${D}/boot/
-}
-
-do_deploy () {
- install -d ${DEPLOYDIR}/boot
- install -m 644 ${QE_UCODE} ${DEPLOYDIR}/boot/
-}
-addtask deploy before do_build after do_install
-
-PACKAGES += "${PN}-image"
-FILES_${PN}-image += "/boot/*"
-ALLOW_EMPTY_${PN} = "1"
-COMPATIBLE_MACHINE = "(p1021rdb|p1025twr|t1)"
-
diff --git a/meta-fsl-ppc/recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch b/meta-fsl-ppc/recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch
deleted file mode 100644
index 49d99fc5..00000000
--- a/meta-fsl-ppc/recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From f2e796c903b2a3f81dbd38da3dc087cb7539d307 Mon Sep 17 00:00:00 2001
-From: Zhenhua Luo <zhenhua.luo@freescale.com>
-Date: Wed, 3 Sep 2014 03:03:42 -0500
-Subject: [PATCH] Makefile: make BOARDS/DESTDIR overidable and add endian
- switch
-
-1. For one specific board, no need to build the rcw for all supported
- targets, make BOARDS and DESTDIR overridable to achieve this.
-2. Add the endian swap for qspiboot rcw
-
-Upstream-Status: Pending
-
-Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
----
- Makefile | 4 ++--
- Makefile.inc | 9 +++++++--
- 2 files changed, 9 insertions(+), 4 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 6ec1697..0f94293 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,5 +1,5 @@
--DESTDIR = .
--BOARDS = b4420qds b4860qds \
-+DESTDIR ?= .
-+BOARDS ?= b4420qds b4860qds \
- ls1021aqds ls1021atwr \
- p2041rdb p3041ds p4080ds p5020ds p5040ds \
- t1024qds t1023rdb t1024rdb t1040rdb t1042rdb t1042rdb_pi t1040qds \
-diff --git a/Makefile.inc b/Makefile.inc
-index 4cadb2e..6e8b78f 100644
---- a/Makefile.inc
-+++ b/Makefile.inc
-@@ -1,4 +1,4 @@
--DESTDIR = .
-+DESTDIR ?= .
- INSTALL = install
- PYTHON ?= python2
- RCW = $(PYTHON) ../rcw.py
-@@ -18,7 +18,12 @@ all: $(targets)
- install: $(targets)
- $(INSTALL) -d $(DESTDIR)
- @for file in $^; do \
-- $(INSTALL) -m 644 -D $$file $(DESTDIR)/$$file; \
-+ case $$file in \
-+ *qspiboot*) file_swap="`echo $$file | sed -e 's/qspiboot/qspiboot_swap/'`"; \
-+ tclsh byte_swap.tcl $$file $$file_swap 8 ; \
-+ $(INSTALL) -m 644 -D $$file_swap $(DESTDIR)/$$file_swap ;; \
-+ *) $(INSTALL) -m 644 -D $$file $(DESTDIR)/$$file; \
-+ esac \
- done
- $(INSTALL) -m 644 -D README $(DESTDIR)
-
---
-1.7.9.7
-
diff --git a/meta-fsl-ppc/recipes-bsp/rcw/rcw_git.bb b/meta-fsl-ppc/recipes-bsp/rcw/rcw_git.bb
deleted file mode 100644
index 57f305a6..00000000
--- a/meta-fsl-ppc/recipes-bsp/rcw/rcw_git.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-SUMMARY = "Reset Configuration Word"
-DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets"
-LICENSE = "BSD"
-PR = "r8"
-
-LIC_FILES_CHKSUM = "file://rcw.py;beginline=8;endline=28;md5=9ba0b28922dd187b06b6c8ebcfdd208e"
-
-inherit deploy
-
-SRCBRANCH = "master"
-SRCREV = "426f7a6535d93dac76f5125035e0938a85e778d2"
-SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=${SRCBRANCH} \
- file://rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch \
-"
-
-S = "${WORKDIR}/git"
-
-EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','')} DESTDIR=${D}/boot/rcw/"
-
-do_install () {
- oe_runmake install
-}
-
-do_deploy () {
- install -d ${DEPLOYDIR}/rcw
- cp -r ${D}/boot/rcw/* ${DEPLOYDIR}/rcw/
-}
-addtask deploy after do_install
-
-PACKAGES += "${PN}-image"
-FILES_${PN}-image += "/boot"
-
-ALLOW_EMPTY_${PN} = "1"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "(qoriq-ppc)"
diff --git a/meta-fsl-ppc/recipes-bsp/u-boot/files/0001-u-boot-mpc85xx-u-boot-.lds-remove-_GLOBAL_OFFSET_TAB.patch b/meta-fsl-ppc/recipes-bsp/u-boot/files/0001-u-boot-mpc85xx-u-boot-.lds-remove-_GLOBAL_OFFSET_TAB.patch
deleted file mode 100644
index e6b8d2e5..00000000
--- a/meta-fsl-ppc/recipes-bsp/u-boot/files/0001-u-boot-mpc85xx-u-boot-.lds-remove-_GLOBAL_OFFSET_TAB.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-From 9ba002f1b1afc7af84a352f4ecab32a30d7ba353 Mon Sep 17 00:00:00 2001
-From: Zhenhua Luo <zhenhua.luo@freescale.com>
-Date: Mon, 9 Feb 2015 18:33:56 +0800
-Subject: [PATCH] u-boot/mpc85xx/u-boot*.lds: remove _GLOBAL_OFFSET_TABLE_
- definition
-
-In binutils-2.25, the _GLOBAL_OFFSET_TABLE_ symbols defined by PROVIDE in
-u-boot.lds overrides the linker built-in symbols
-(https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=commitdiff;h=b893397a4b1316610f49819344817715e4305de9),
-so the linker is treating _GLOBAL_OFFSET_TABLE_ as a definition into the .reloc section.
-
-To align with the change of binutils-2.25, the _GLOBAL_OFFSET_TABLE_ symbol
-should not be defined in sections, and the symbols in linker generated .got
-section should be used(https://sourceware.org/ml/binutils/2008-09/msg00122.html).
-
-Fixed the following build errors with binutils-2.25:
-| powerpc-poky-linux-gnuspe-ld.bfd: _GLOBAL_OFFSET_TABLE_ not defined in linker created .got
-
-Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
----
- arch/powerpc/cpu/mpc85xx/u-boot-nand.lds | 1 -
- arch/powerpc/cpu/mpc85xx/u-boot-nand_spl.lds | 1 -
- arch/powerpc/cpu/mpc85xx/u-boot-spl.lds | 1 -
- arch/powerpc/cpu/mpc85xx/u-boot.lds | 1 -
- 4 files changed, 4 deletions(-)
-
-diff --git a/arch/powerpc/cpu/mpc85xx/u-boot-nand.lds b/arch/powerpc/cpu/mpc85xx/u-boot-nand.lds
-index f933b21..0399f93 100644
---- a/arch/powerpc/cpu/mpc85xx/u-boot-nand.lds
-+++ b/arch/powerpc/cpu/mpc85xx/u-boot-nand.lds
-@@ -44,7 +44,6 @@ SECTIONS
- _GOT2_TABLE_ = .;
- KEEP(*(.got2))
- KEEP(*(.got))
-- PROVIDE(_GLOBAL_OFFSET_TABLE_ = . + 4);
- _FIXUP_TABLE_ = .;
- KEEP(*(.fixup))
- }
-diff --git a/arch/powerpc/cpu/mpc85xx/u-boot-nand_spl.lds b/arch/powerpc/cpu/mpc85xx/u-boot-nand_spl.lds
-index b83c553..f044564 100644
---- a/arch/powerpc/cpu/mpc85xx/u-boot-nand_spl.lds
-+++ b/arch/powerpc/cpu/mpc85xx/u-boot-nand_spl.lds
-@@ -22,7 +22,6 @@ SECTIONS
- _GOT2_TABLE_ = .;
- KEEP(*(.got2))
- KEEP(*(.got))
-- PROVIDE(_GLOBAL_OFFSET_TABLE_ = . + 4);
- _FIXUP_TABLE_ = .;
- KEEP(*(.fixup))
- }
-diff --git a/arch/powerpc/cpu/mpc85xx/u-boot-spl.lds b/arch/powerpc/cpu/mpc85xx/u-boot-spl.lds
-index 5ae7b3e..889a4c2 100644
---- a/arch/powerpc/cpu/mpc85xx/u-boot-spl.lds
-+++ b/arch/powerpc/cpu/mpc85xx/u-boot-spl.lds
-@@ -29,7 +29,6 @@ SECTIONS
- _GOT2_TABLE_ = .;
- KEEP(*(.got2))
- KEEP(*(.got))
-- PROVIDE(_GLOBAL_OFFSET_TABLE_ = . + 4);
- _FIXUP_TABLE_ = .;
- KEEP(*(.fixup))
- }
-diff --git a/arch/powerpc/cpu/mpc85xx/u-boot.lds b/arch/powerpc/cpu/mpc85xx/u-boot.lds
-index 2cf0b25..f15eaf3 100644
---- a/arch/powerpc/cpu/mpc85xx/u-boot.lds
-+++ b/arch/powerpc/cpu/mpc85xx/u-boot.lds
-@@ -50,7 +50,6 @@ SECTIONS
- _GOT2_TABLE_ = .;
- KEEP(*(.got2))
- KEEP(*(.got))
-- PROVIDE(_GLOBAL_OFFSET_TABLE_ = . + 4);
- _FIXUP_TABLE_ = .;
- KEEP(*(.fixup))
- }
---
-2.1.0
-
diff --git a/meta-fsl-ppc/recipes-bsp/u-boot/files/Fix-the-depend-race-issue.patch b/meta-fsl-ppc/recipes-bsp/u-boot/files/Fix-the-depend-race-issue.patch
deleted file mode 100644
index 1ddc6675..00000000
--- a/meta-fsl-ppc/recipes-bsp/u-boot/files/Fix-the-depend-race-issue.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Upstream-Status: Pending
-
-From 301832414369b749918e0d5db850eed19b81c0fc Mon Sep 17 00:00:00 2001
-From: Zhenhua Luo <zhenhua.luo@freescale.com>
-Date: Tue, 24 Sep 2013 00:54:40 -0500
-Subject: [PATCH] Fix the depend race issue
-
-| make[3]: Entering directory `/srv/home/pokybuild/yocto-autobuilder-new/yocto-slave/nightly-fsl-ppc/build/build/tmp/work/p1022ds-poky-linux-gnuspe/u-boot/git-r30/git/arch/powerpc/cpu/mpc85xx'
-| /srv/home/pokybuild/yocto-autobuilder-new/yocto-slave/nightly-fsl-ppc/build/build/tmp/work/p1022ds-poky-linux-gnuspe/u-boot/git-r30/git/P1022DS_NAND/spl/arch/powerpc/cpu/mpc85xx/.depend:125: *** missing separator. Stop.
-| make[3]: Leaving directory `/srv/home/pokybuild/yocto-autobuilder-new/yocto-slave/nightly-fsl-ppc/build/build/tmp/work/p1022ds-poky-linux-gnuspe/u-boot/git-r30/git/arch/powerpc/cpu/mpc85xx'
-| make[2]: *** [/srv/home/pokybuild/yocto-autobuilder-new/yocto-slave/nightly-fsl-ppc/build/build/tmp/work/p1022ds-poky-linux-gnuspe/u-boot/git-r30/git/P1022DS_NAND/spl/arch/powerpc/cpu/mpc85xx/start.o] Error 2
-| make[2]: *** Waiting for unfinished jobs....
-
-Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
----
- spl/Makefile | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/spl/Makefile b/spl/Makefile
-index 6dbb105..3156d87 100644
---- a/spl/Makefile
-+++ b/spl/Makefile
-@@ -185,7 +185,11 @@ $(eval $(call make_u_boot_list, $(obj)u-boot.lst, $(LIBS)))
- $(obj)u-boot-spl.lds: $(LDSCRIPT) $(obj)u-boot.lst depend
- $(CPP) $(CPPFLAGS) $(LDPPFLAGS) -I$(obj). -ansi -D__ASSEMBLY__ -P - < $< > $@
-
--depend: $(obj).depend
-+# Explicitly make _depend in subdirs containing multiple targets to prevent
-+# parallel sub-makes creating .depend files simultaneously.
-+depend dep: $(obj).depend
-+ for dir in $(SUBDIRS) $(CPUDIR) $(LDSCRIPT_MAKEFILE_DIR) ; do \
-+ $(MAKE) -C $(SRCTREE)/$$dir _depend ; done
- .PHONY: depend
-
- # defines $(obj).depend target
---
-1.8.2.1
-
diff --git a/meta-fsl-ppc/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb b/meta-fsl-ppc/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb
deleted file mode 100644
index 17c470dc..00000000
--- a/meta-fsl-ppc/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb
+++ /dev/null
@@ -1,189 +0,0 @@
-DESCRIPTION = "U-boot bootloader"
-HOMEPAGE = "http://u-boot.sf.net"
-SECTION = "bootloaders"
-PROVIDES = "virtual/bootloader u-boot"
-LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1"
-LIC_FILES_CHKSUM = " \
- file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
- file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \
- file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \
- file://Licenses/lgpl-2.0.txt;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
- file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
-"
-
-PV = "2014.07+fslgit"
-INHIBIT_DEFAULT_DEPS = "1"
-DEPENDS = "boot-format-native libgcc ${@base_contains('TCMODE', 'external-fsl', '', 'virtual/${TARGET_PREFIX}gcc', d)}"
-
-inherit deploy
-
-SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;nobranch=1 \
- file://0001-u-boot-mpc85xx-u-boot-.lds-remove-_GLOBAL_OFFSET_TAB.patch"
-SRCREV = "6ba8eedbcdc4b063f59a63e6288b938af739e8ad"
-
-python () {
- if d.getVar("TCMODE", True) == "external-fsl":
- return
-
- ml = d.getVar("MULTILIB_VARIANTS", True)
- arch = d.getVar("OVERRIDES", True)
-
- if "e5500-64b:" in arch or "e6500-64b:" in arch:
- if not "lib32" in ml:
- raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled")
- sys_multilib = 'powerpc' + d.getVar('TARGET_VENDOR') + 'mllib32-' + d.getVar('HOST_OS')
- d.setVar('DEPENDS_append', ' lib32-gcc-cross-powerpc lib32-libgcc')
- d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/' + sys_multilib)
- d.setVar('TOOLCHAIN_OPTIONS_append', '/../lib32-' + d.getVar("MACHINE"))
- d.setVar("WRAP_TARGET_PREFIX", sys_multilib + '-')
-}
-
-WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-UBOOT_LOCALVERSION = "${@d.getVar('SDK_VERSION', True).partition(' ')[0]}"
-
-USRC ?= ""
-S = '${@base_conditional("USRC", "", "${WORKDIR}/git", "${USRC}", d)}'
-
-EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
-
-do_compile () {
- unset LDFLAGS
- unset CFLAGS
- unset CPPFLAGS
-
- if [ ! -e ${B}/.scmversion -a ! -e ${S}/.scmversion ]
- then
- head=`git rev-parse --verify --short HEAD 2> /dev/null`
- printf "%s%s%s" ${UBOOT_LOCALVERSION} +g $head > ${B}/.scmversion
- printf "%s%s%s" ${UBOOT_LOCALVERSION} +g $head > ${S}/.scmversion
- fi
-
- if [ "x${UBOOT_MACHINES}" = "x" ]; then
- UBOOT_MACHINES=${UBOOT_MACHINE}
- fi
-
- python ./tools/genboardscfg.py
- for board in ${UBOOT_MACHINES}; do
- if ! grep -wq $board ${S}/boards.cfg;then
- echo "WARNING: $board not supported in boards.cfg"
- continue
- fi
-
- oe_runmake O=${board} distclean
- oe_runmake O=${board} ${board}_config
- oe_runmake O=${board} all
-
- case "${board}" in
- *SDCARD*) UBOOT_TARGET="u-boot-sd";;
- *SPIFLASH*) UBOOT_TARGET="u-boot-spi";;
- *NAND*) UBOOT_TARGET="u-boot-nand";;
- *SRIO*) UBOOT_TARGET="u-boot-srio";;
- *) UBOOT_TARGET="";;
- esac
-
- # deal with sd/spi/nand/srio image
- UBOOT_SOURCE=u-boot.bin
- if [ "x${UBOOT_TARGET}" != "x" ] && echo $board |egrep -qi "SECBOOT|SECURE"; then
- cp ${S}/${board}/${UBOOT_SOURCE} ${S}/${board}/${UBOOT_TARGET}.bin
- elif [ "x${UBOOT_TARGET}" != "x" ]; then
- # some boards' final binary was not named as u-boot.bin
- if [ "${UBOOT_TARGET}" = "u-boot-nand" ];then
- if echo $board |egrep -q "^(BSC|C29|P10|P2020RDB)";then
- UBOOT_SOURCE=u-boot-with-spl.bin
- elif echo $board |egrep -q "^(B4|T1|T2|T4)";then
- UBOOT_SOURCE=u-boot-with-spl-pbl.bin
- elif echo $board |egrep -q "^(P2041|P3|P4|P5)";then
- UBOOT_SOURCE=u-boot.pbl
- fi
- elif [ "${UBOOT_TARGET}" = "u-boot-spi" ];then
- if echo $board |egrep -q "^(P10|P2020RDB)";then
- UBOOT_SOURCE=u-boot-with-spl.bin
- elif echo $board |egrep -q "^(T1|T2)";then
- UBOOT_SOURCE=u-boot-with-spl-pbl.bin
- elif echo $board |egrep -q "^(B4|P2041|P3|P4|P5|T4)";then
- UBOOT_SOURCE=u-boot.pbl
- fi
- elif [ "${UBOOT_TARGET}" = "u-boot-sd" ];then
- if echo $board |egrep -q "^(P10|P2020RDB)";then
- UBOOT_SOURCE=u-boot-with-spl.bin
- elif echo $board |egrep -q "^(B4|T1|T2|T4)";then
- UBOOT_SOURCE=u-boot-with-spl-pbl.bin
- elif echo $board |egrep -q "^(P2041|P3|P4|P5)";then
- UBOOT_SOURCE=u-boot.pbl
- fi
- fi
- cp ${S}/${board}/${UBOOT_SOURCE} ${S}/${board}/${UBOOT_TARGET}.bin
-
- # use boot-format to regenerate spi image if BOOTFORMAT_CONFIG is not empty
- if [ "${UBOOT_TARGET}" = "u-boot-spi" ] && [ -n "${BOOTFORMAT_CONFIG}" ];then
- ${STAGING_BINDIR_NATIVE}/boot_format \
- ${STAGING_DATADIR_NATIVE}/boot_format/${BOOTFORMAT_CONFIG} \
- ${S}/${board}/${UBOOT_SOURCE} -spi ${S}/${board}/${UBOOT_TARGET}.bin
- fi
- fi
- done
-}
-
-do_install(){
- if [ "x${UBOOT_MACHINES}" = "x" ]; then
- UBOOT_MACHINES=${UBOOT_MACHINE}
- fi
-
- for board in ${UBOOT_MACHINES}; do
- if ! grep -wq $board ${S}/boards.cfg;then
- continue
- fi
-
- case "${board}" in
- *SDCARD*) UBOOT_TARGET="u-boot-sd";;
- *SPIFLASH*) UBOOT_TARGET="u-boot-spi";;
- *NAND*) UBOOT_TARGET="u-boot-nand";;
- *SRIO*) UBOOT_TARGET="u-boot-srio";;
- *) UBOOT_TARGET="u-boot";;
- esac
-
- if [ -f ${S}/${board}/${UBOOT_TARGET}.bin ]; then
- mkdir -p ${D}/boot/
- install ${S}/${board}/${UBOOT_TARGET}.bin ${D}/boot/${UBOOT_TARGET}-${board}-${PV}-${PR}.bin
- ln -sf ${UBOOT_TARGET}-${board}-${PV}-${PR}.bin ${D}/boot/${UBOOT_TARGET}.bin
- fi
- done
-}
-
-do_deploy(){
- if [ "x${UBOOT_MACHINES}" = "x" ]; then
- UBOOT_MACHINES=${UBOOT_MACHINE}
- fi
-
- for board in ${UBOOT_MACHINES}; do
- if ! grep -wq $board ${S}/boards.cfg;then
- continue
- fi
-
- case "${board}" in
- *SDCARD*) UBOOT_TARGET="u-boot-sd";;
- *SPIFLASH*) UBOOT_TARGET="u-boot-spi";;
- *NAND*) UBOOT_TARGET="u-boot-nand";;
- *SRIO*) UBOOT_TARGET="u-boot-srio";;
- *) UBOOT_TARGET="u-boot";;
- esac
-
- if [ -f ${S}/${board}/${UBOOT_TARGET}.bin ]; then
- mkdir -p ${DEPLOYDIR}
- install ${S}/${board}/${UBOOT_TARGET}.bin ${DEPLOYDIR}/${UBOOT_TARGET}-${board}-${PV}-${PR}.bin
-
- cd ${DEPLOYDIR}
- rm -f ${UBOOT_TARGET}-${board}.bin
- ln -sf ${UBOOT_TARGET}-${board}-${PV}-${PR}.bin ${UBOOT_TARGET}-${board}.bin
- fi
- done
-}
-addtask deploy after do_install
-
-PACKAGES += "${PN}-images"
-FILES_${PN}-images += "/boot"
-
-ALLOW_EMPTY_${PN} = "1"