aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk_21.11.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk_21.11.5.bb')
-rw-r--r--recipes-extended/dpdk/dpdk_21.11.5.bb77
1 files changed, 77 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk_21.11.5.bb b/recipes-extended/dpdk/dpdk_21.11.5.bb
new file mode 100644
index 00000000..0d460123
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk_21.11.5.bb
@@ -0,0 +1,77 @@
+include dpdk.inc
+
+SRC_URI += " \
+ file://0001-meson.build-march-and-mcpu-already-passed-by-Yocto-21.11.patch \
+"
+
+STABLE = "-stable"
+BRANCH = "21.11"
+SRCREV = "4e50ad4469f7c037e32de5aa3535d1cd25de0741"
+S = "${WORKDIR}/git"
+
+# CVE-2021-3839 has been fixed by commit 4c40d30d2b in 21.11.1
+# NVD database is incomplete
+# CVE-2022-0669 has been fixed by commit 6cb68162e4 in 21.11.1
+# NVD database is incomplete
+CVE_CHECK_IGNORE += "\
+ CVE-2021-3839 \
+ CVE-2022-0669 \
+"
+
+# kernel module is provide by dpdk-module recipe, so disable here
+EXTRA_OEMESON = " -Denable_kmods=false \
+ -Dexamples=all \
+"
+
+COMPATIBLE_MACHINE = "null"
+COMPATIBLE_HOST:libc-musl:class-target = "null"
+COMPATIBLE_HOST:linux-gnux32 = "null"
+
+PACKAGECONFIG ??= " "
+PACKAGECONFIG[afxdp] = ",,libbpf xdp-tools"
+PACKAGECONFIG[libvirt] = ",,libvirt"
+
+RDEPENDS:${PN} += "pciutils python3-core"
+RDEPENDS:${PN}-examples += "bash"
+DEPENDS = "numactl python3-pyelftools-native"
+
+inherit meson pkgconfig
+
+INSTALL_PATH = "${prefix}/share/dpdk"
+
+do_install:append(){
+ # remove source files
+ rm -rf ${D}/${INSTALL_PATH}/examples/*
+
+ # Install examples
+ install -m 0755 -d ${D}/${INSTALL_PATH}/examples/
+ for dirname in ${B}/examples/dpdk-*
+ do
+ if [ ! -d ${dirname} ] && [ -x ${dirname} ]; then
+ install -m 0755 ${dirname} ${D}/${INSTALL_PATH}/examples/
+ fi
+ done
+
+}
+
+PACKAGES =+ "${PN}-examples ${PN}-tools"
+
+FILES:${PN} += " ${bindir}/dpdk-testpmd \
+ ${bindir}/dpdk-proc-info \
+ ${libdir}/*.so* \
+ ${libdir}/dpdk/pmds-22.0/*.so* \
+ "
+FILES:${PN}-examples = " \
+ ${prefix}/share/dpdk/examples/* \
+ "
+
+FILES:${PN}-tools = " \
+ ${bindir}/dpdk-pdump \
+ ${bindir}/dpdk-test \
+ ${bindir}/dpdk-test-* \
+ ${bindir}/dpdk-*.py \
+ "
+
+CVE_PRODUCT = "data_plane_development_kit"
+
+INSANE_SKIP:${PN} = "dev-so"