aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/dpdk/dpdk_23.11.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-extended/dpdk/dpdk_23.11.bb b/recipes-extended/dpdk/dpdk_23.11.bb
index 5f0f9ec7..fc2796a0 100644
--- a/recipes-extended/dpdk/dpdk_23.11.bb
+++ b/recipes-extended/dpdk/dpdk_23.11.bb
@@ -9,8 +9,11 @@ S = "${WORKDIR}/git"
def get_cpu_instruction_set(bb, d):
import re
- march = re.search(r'-march=([^\s]*)', d.getVar('CC')).group(1)
- return march
+ march = re.search(r'-march=([^\s]*)', d.getVar('CC'))
+ if march:
+ return march.group(1)
+ else:
+ return "core2"
EXTRA_OEMESON = " -Dexamples=all -Dcpu_instruction_set=${@get_cpu_instruction_set(bb, d)} "