aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-support/nss-pam-ldapd
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/nss-pam-ldapd')
-rw-r--r--recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch34
-rw-r--r--recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb (renamed from recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb)21
2 files changed, 45 insertions, 10 deletions
diff --git a/recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch b/recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch
new file mode 100644
index 00000000..86e9f7b4
--- /dev/null
+++ b/recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch
@@ -0,0 +1,34 @@
+From fb9c5b955da462695e0a662aebfa13493eaf3978 Mon Sep 17 00:00:00 2001
+From: Yi Zhao <yi.zhao@windriver.com>
+Date: Fri, 13 Oct 2023 22:28:25 +0800
+Subject: [PATCH] utils/Makefile.am: fix shebang for chsh.py and getent.py
+
+Update shebang to python3 for chsh.py and getent.py to fix QA issue:
+
+WARNING: nss-pam-ldapd-0.9.12-r0 do_package_qa: QA Issue: File
+/usr/share/nslcd-utils/chsh.py in package nss-pam-ldapd contains
+reference to TMPDIR
+File /usr/share/nslcd-utils/getent.py in package nss-pam-ldapd contains
+reference to TMPDIR [buildpaths]
+
+Upstream-Status: Inappropriate [embedded specific]
+
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+---
+ utils/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/utils/Makefile.am b/utils/Makefile.am
+index a6bccd3..22a50d8 100644
+--- a/utils/Makefile.am
++++ b/utils/Makefile.am
+@@ -39,5 +39,5 @@ install-data-hook:
+ set -ex; for cmd in getent chsh ; do \
+ [ -L $(DESTDIR)$(bindir)/$$cmd.$(MODULE_NAME) ] || $(LN_S) $(utilsdir)/$$cmd.py $(DESTDIR)$(bindir)/$$cmd.$(MODULE_NAME) ; \
+ chmod a+rx $(DESTDIR)$(utilsdir)/$$cmd.py ; \
+- sed -i -e '1 s|^#!.*|#! $(PYTHON)|;1 s|^#! \([^/].*\)|#! /usr/bin/env \1|' $(DESTDIR)$(utilsdir)/$$cmd.py ; \
++ sed -i -e '1 s|/usr/bin/env python|/usr/bin/env python3|' $(DESTDIR)$(utilsdir)/$$cmd.py ; \
+ done
+--
+2.25.1
+
diff --git a/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb b/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb
index dfa562f7..7f3b9e38 100644
--- a/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
+++ b/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb
@@ -8,23 +8,24 @@ DESCRIPTION = "\
HOMEPAGE = "http://arthurdejong.org/nss-pam-ldapd/"
-LICENSE = "LGPLv2.1"
+LICENSE = "LGPL-2.1-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
SECTION = "base"
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
SRC_URI = "\
http://arthurdejong.org/nss-pam-ldapd/${BPN}-${PV}.tar.gz \
+ file://0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch \
file://nslcd.init \
file://nslcd.service \
"
-inherit autotools distro_features_check
+inherit autotools features_check
REQUIRED_DISTRO_FEATURES = "pam"
-SRC_URI[md5sum] = "8c99fdc54f4bf9aca8c5f53fdb1403ff"
-SRC_URI[sha256sum] = "ef7362e7f2003da8c7beb7bcc03c30494acf712625aaac8badc6e7eb16f3453f"
+SRC_URI[md5sum] = "cc30ee0ab91d6c94b7a343ae09b5dc69"
+SRC_URI[sha256sum] = "c6d661e74693cbf531a790631ca93b73f291fb23cc39465b09deb8da2bfb0e14"
DEPENDS += "libpam openldap krb5"
@@ -34,14 +35,14 @@ EXTRA_OECONF = "\
--with-pam-seclib-dir=${base_libdir}/security \
"
-CONFFILES_${PN} += "${sysconfdir}/nslcd.conf"
+CONFFILES:${PN} += "${sysconfdir}/nslcd.conf"
-FILES_${PN} += "${base_libdir}/security ${datadir}"
-FILES_${PN}-dbg += "${base_libdir}/security/.debug"
+FILES:${PN} += "${base_libdir}/security ${datadir}"
+FILES:${PN}-dbg += "${base_libdir}/security/.debug"
LDAP_DN ?= "dc=my-domain,dc=com"
-do_install_append() {
+do_install:append() {
install -D -m 0755 ${WORKDIR}/nslcd.init ${D}${sysconfdir}/init.d/nslcd
sed -i -e 's/^uid nslcd/# uid nslcd/;' ${D}${sysconfdir}/nslcd.conf
@@ -57,4 +58,4 @@ inherit update-rc.d systemd
INITSCRIPT_NAME = "nslcd"
INITSCRIPT_PARAMS = "defaults"
-SYSTEMD_SERVICE_${PN} = "nslcd.service"
+SYSTEMD_SERVICE:${PN} = "nslcd.service"