aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch')
-rw-r--r--recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch37
1 files changed, 17 insertions, 20 deletions
diff --git a/recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch b/recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch
index e8f99acc..9b807fee 100644
--- a/recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch
+++ b/recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch
@@ -26,24 +26,24 @@ Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com>
geo-replication/src/gsyncd.c | 6 +++---
3 files changed, 7 insertions(+), 4 deletions(-)
-diff --git a/configure.ac b/configure.ac
-index bc4cf93..d55a7b2 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -279,6 +279,8 @@ AC_CANONICAL_HOST
+Index: glusterfs-11.1/configure.ac
+===================================================================
+--- glusterfs-11.1.orig/configure.ac
++++ glusterfs-11.1/configure.ac
+@@ -261,6 +261,8 @@
AC_PROG_CC
AC_DISABLE_STATIC
- AC_PROG_LIBTOOL
+ LT_INIT
+AC_SUBST(TARGET_PYTHON)
+
AC_SUBST([shrext_cmds])
AC_CHECK_PROG([RPCGEN], [rpcgen], [yes], [no])
-diff --git a/geo-replication/src/Makefile.am b/geo-replication/src/Makefile.am
-index 9937a0b..07456fb 100644
---- a/geo-replication/src/Makefile.am
-+++ b/geo-replication/src/Makefile.am
-@@ -22,7 +22,8 @@ noinst_HEADERS = procdiggy.h
+Index: glusterfs-11.1/geo-replication/src/Makefile.am
+===================================================================
+--- glusterfs-11.1.orig/geo-replication/src/Makefile.am
++++ glusterfs-11.1/geo-replication/src/Makefile.am
+@@ -22,7 +22,8 @@
AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \
-I$(top_srcdir)/rpc/xdr/src -I$(top_builddir)/rpc/xdr/src \
-DGSYNCD_PREFIX=\"$(GLUSTERFS_LIBEXECDIR)\" -DUSE_LIBGLUSTERFS \
@@ -53,11 +53,11 @@ index 9937a0b..07456fb 100644
AM_CFLAGS = -Wall $(GF_CFLAGS)
-diff --git a/geo-replication/src/gsyncd.c b/geo-replication/src/gsyncd.c
-index 77af662..8cd0551 100644
---- a/geo-replication/src/gsyncd.c
-+++ b/geo-replication/src/gsyncd.c
-@@ -118,9 +118,9 @@ invoke_gsyncd(int argc, char **argv)
+Index: glusterfs-11.1/geo-replication/src/gsyncd.c
+===================================================================
+--- glusterfs-11.1.orig/geo-replication/src/gsyncd.c
++++ glusterfs-11.1/geo-replication/src/gsyncd.c
+@@ -115,9 +115,9 @@
goto error;
j = 0;
@@ -69,7 +69,7 @@ index 77af662..8cd0551 100644
nargv[j++] = python;
nargv[j++] = GSYNCD_PREFIX "/python/syncdaemon/" GSYNCD_PY;
for (i = 1; i < argc; i++)
-@@ -170,7 +170,7 @@ find_gsyncd(pid_t pid, pid_t ppid, char *name, void *data)
+@@ -167,7 +167,7 @@
ret = 0;
switch (zeros) {
case 2:
@@ -78,6 +78,3 @@ index 77af662..8cd0551 100644
strcmp(basename(buf + strlen(buf) + 1), GSYNCD_PY)) == 0) {
ret = 1;
break;
---
-2.17.1
-