aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/consul/consul_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/consul/consul_git.bb')
-rw-r--r--recipes-connectivity/consul/consul_git.bb20
1 files changed, 12 insertions, 8 deletions
diff --git a/recipes-connectivity/consul/consul_git.bb b/recipes-connectivity/consul/consul_git.bb
index b96499c4..0d084b0d 100644
--- a/recipes-connectivity/consul/consul_git.bb
+++ b/recipes-connectivity/consul/consul_git.bb
@@ -5,14 +5,14 @@ LIC_FILES_CHKSUM = "file://src/github.com/hashicorp/consul/LICENSE;md5=b278a92d2
GO_IMPORT = "github.com/hashicorp/consul"
SRCREV = "944cc71026c007e7de9467ec3f38f0ad14464fcc"
-SRC_URI = "git://${GO_IMPORT}.git \
+SRC_URI = "git://${GO_IMPORT}.git;branch=main;protocol=https \
file://0001-Migration-Rename-imports-throughout.patch \
file://consul.service \
"
S = "${WORKDIR}/git"
-RDEPENDS_${PN}-dev_append = " bash"
+RDEPENDS:${PN}-dev:append = " bash"
# Temporarily workaround an issue with GO 1.12.1
# http://www.lyddzz.com/github_/golang/go/issues/30768
@@ -23,17 +23,21 @@ inherit systemd go
# Besides the hosts specified in goarch, we do not build for mips.
#
-COMPATIBLE_HOST_mipsarch = "null"
+COMPATIBLE_HOST:mipsarch = "null"
-SYSTEMD_SERVICE_${PN} = "consul.service"
-SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+SYSTEMD_SERVICE:${PN} = "consul.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "disable"
-do_install_append() {
+do_compile:prepend () {
+ export GO111MODULE=off
+}
+
+do_install:append() {
install -d ${D}/${systemd_unitdir}/system
cp ${WORKDIR}/consul.service ${D}/${systemd_unitdir}/system
}
-FILES_${PN} += "${systemd_unitdir}/system"
+FILES:${PN} += "${systemd_unitdir}/system"
#for i586, executable consul contains textrel
-INSANE_SKIP_${PN} += "textrel"
+INSANE_SKIP:${PN} += "textrel"