aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support/tgt/tgt_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-support/tgt/tgt_git.bb')
-rw-r--r--meta-openstack/recipes-support/tgt/tgt_git.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta-openstack/recipes-support/tgt/tgt_git.bb b/meta-openstack/recipes-support/tgt/tgt_git.bb
index 5242dd50..9c5c24bf 100644
--- a/meta-openstack/recipes-support/tgt/tgt_git.bb
+++ b/meta-openstack/recipes-support/tgt/tgt_git.bb
@@ -1,13 +1,13 @@
DESCRIPTION = "Linux SCSI target framework (tgt)"
HOMEPAGE = "http://stgt.sourceforge.net"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://scripts/tgtd.spec;beginline=7;endline=7;md5=21c19ea7dad04648b9c2f791b6e29b4c"
DEPENDS = "sg3-utils libaio"
SRCREV = "b43dbc6711e43c0a32cc4d9df22884841d911d51"
PV = "1.0.79+git${SRCPV}"
-SRC_URI = "git://github.com/fujita/tgt.git \
+SRC_URI = "git://github.com/fujita/tgt.git;branch=master;protocol=https \
file://0001-Correct-the-path-of-header-files-check-in-Yocto-buil.patch \
file://0001-usr-Makefile-WARNING-fix.patch \
file://usr-Makefile-apply-LDFLAGS-to-all-executables.patch \
@@ -19,12 +19,12 @@ SRC_URI += "file://tgtd.init \
S = "${WORKDIR}/git"
-CONFFILES_${PN} += "${sysconfdir}/tgt/targets.conf"
+CONFFILES:${PN} += "${sysconfdir}/tgt/targets.conf"
inherit update-rc.d systemd
-SYSTEMD_SERVICE_${PN} = "tgtd.service"
-SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+SYSTEMD_SERVICE:${PN} = "tgtd.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "disable"
CFLAGS += ' -I. -DUSE_SIGNALFD -DUSE_TIMERFD -D_GNU_SOURCE -DTGT_VERSION=\\"1.0.63\\" -DBSDIR=\\"${libdir}/backing-store\\"'
@@ -50,11 +50,11 @@ do_install() {
fi
}
-FILES_${PN} += "${systemd_unitdir}/system/tgtd.service \
+FILES:${PN} += "${systemd_unitdir}/system/tgtd.service \
${sysconfdir}/sysconfig/tgtd \
"
-RDEPENDS_${PN} = " \
+RDEPENDS:${PN} = " \
bash \
libaio \
libconfig-general-perl \
@@ -88,5 +88,5 @@ RDEPENDS_${PN} = " \
perl-module-constant \
"
INITSCRIPT_PACKAGES = "${PN}"
-INITSCRIPT_NAME_${PN} = "tgtd"
+INITSCRIPT_NAME:${PN} = "tgtd"