aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support/chef/chef_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-support/chef/chef_git.bb')
-rw-r--r--meta-openstack/recipes-support/chef/chef_git.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-openstack/recipes-support/chef/chef_git.bb b/meta-openstack/recipes-support/chef/chef_git.bb
index 86e4165a..8a881523 100644
--- a/meta-openstack/recipes-support/chef/chef_git.bb
+++ b/meta-openstack/recipes-support/chef/chef_git.bb
@@ -18,7 +18,7 @@ SRCREV = "1dc20627aa5d742376269dc5b4d5c67f34d08008"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/opscode/chef.git;branch=12.4-stable \
+ git://github.com/opscode/chef.git;branch=12.4-stable;protocol=https \
file://0001-chang-ksh-to-sh.patch \
"
@@ -31,7 +31,7 @@ DEPENDS += " \
bundler-native \
"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
ruby \
chef-zero \
coderay \
@@ -64,9 +64,9 @@ RDEPENDS_${PN} += " \
RUBY_INSTALL_GEMS = "pkg/chef-${BPV}.gem"
-FILES_${PN} += "${libdir}/ruby/gems/2.2.0/build_info"
-FILES_${PN} += "${libdir}/ruby/gems/2.2.0/extensions"
+FILES:${PN} += "${libdir}/ruby/gems/2.2.0/build_info"
+FILES:${PN} += "${libdir}/ruby/gems/2.2.0/extensions"
-do_install_prepend() {
+do_install:prepend() {
rake gem
}