aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb')
-rw-r--r--meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb b/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
index f0c535f9..62e0df42 100644
--- a/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
+++ b/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
@@ -5,7 +5,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=33ab1ce13e2312dddfad07f97f66321f"
SRCNAME = "uwsgi"
-SRC_URI = "git://github.com/unbit/uwsgi.git;branch=uwsgi-2.0 \
+SRC_URI = "git://github.com/unbit/uwsgi.git;branch=uwsgi-2.0;protocol=https \
file://Add-explicit-breaks-to-avoid-implicit-passthrough.patch \
file://more-Add-explicit-breaks-to-avoid-implicit-passthrough.patch \
"
@@ -14,20 +14,20 @@ SRCREV="af44211739136e22471a2897383f34586284bf86"
PV="2.0.14+git${SRCPV}"
S = "${WORKDIR}/git"
-inherit setuptools pkgconfig
+inherit setuptools3 pkgconfig
# prevent host contamination and remove local search paths
export UWSGI_REMOVE_INCLUDES = "/usr/include,/usr/local/include"
DEPENDS += " \
e2fsprogs \
- python-pip \
- python-six \
+ python3-pip \
+ python3-six \
yajl \
"
-# RDEPENDS_default:
-RDEPENDS_${PN} += " \
+# RDEPENDS:default:
+RDEPENDS:${PN} += " \
"
CLEANBROKEN = "1"