aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/bundler_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/chef-zero_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/ruby/coderay_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.9.bb (renamed from meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb)12
-rw-r--r--meta-openstack/recipes-devtools/ruby/cool.io_1.7.0.bb (renamed from meta-openstack/recipes-devtools/ruby/cool.io_1.6.0.bb)5
-rw-r--r--meta-openstack/recipes-devtools/ruby/diff-lcs_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/erubis_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb10
-rw-r--r--meta-openstack/recipes-devtools/ruby/hashie_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/highline_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb (renamed from meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb)8
-rw-r--r--meta-openstack/recipes-devtools/ruby/ipaddress_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/json_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/ruby/method-source_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/mime-types_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/ruby/mixlib-cli_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/mixlib-config_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/mixlib-log_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/mixlib-shellout_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/msgpack_1.3.3.bb5
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/ohai_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/ruby/pry_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/ruby/rack_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/rest-client_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb8
-rw-r--r--meta-openstack/recipes-devtools/ruby/sigdump_0.2.4.bb6
-rw-r--r--meta-openstack/recipes-devtools/ruby/slop_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/strptime_0.2.5.bb (renamed from meta-openstack/recipes-devtools/ruby/strptime_0.2.3.bb)8
-rw-r--r--meta-openstack/recipes-devtools/ruby/systemu_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/tzinfo-data_1.2019.3.bb6
-rw-r--r--meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb8
-rw-r--r--meta-openstack/recipes-devtools/ruby/yajl-ruby_1.4.0.bb6
-rw-r--r--meta-openstack/recipes-devtools/ruby/yard_git.bb2
37 files changed, 98 insertions, 56 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/bundler_git.bb b/meta-openstack/recipes-devtools/ruby/bundler_git.bb
index f7617a0c..a4300a27 100644
--- a/meta-openstack/recipes-devtools/ruby/bundler_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/bundler_git.bb
@@ -25,7 +25,7 @@ SRCREV = "06e3647c117da210ffd15a174624497830addd7b"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/bundler/bundler.git;branch=1-7-stable \
+ git://github.com/bundler/bundler.git;branch=1-7-stable;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb b/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
index 1ade2658..199fd41e 100644
--- a/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
@@ -21,12 +21,12 @@ SRCREV = "28fe2928469885b0138de4d4270c6eccac8ab482"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/opscode/chef-zero.git;branch=master \
+ git://github.com/opscode/chef-zero.git;branch=master;protocol=https \
"
inherit ruby
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
mixlib-log \
json \
hashie \
diff --git a/meta-openstack/recipes-devtools/ruby/coderay_git.bb b/meta-openstack/recipes-devtools/ruby/coderay_git.bb
index 32536993..a45942f6 100644
--- a/meta-openstack/recipes-devtools/ruby/coderay_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/coderay_git.bb
@@ -16,7 +16,7 @@ SRCREV = "a48037b85a12228431b32103786456f36beb355f"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/rubychan/coderay.git \
+ git://github.com/rubychan/coderay.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb b/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.9.bb
index a328203e..e2c99d7d 100644
--- a/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb
+++ b/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.9.bb
@@ -2,11 +2,17 @@ SUMMARY = "Modern concurrency tools including agents, futures, promises, thread
HOMEPAGE = "http://www.concurrent-ruby.com"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.md;md5=fde65ae93d18826f70c6fe125aa04297"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e319104fe1435b64fc0a67032db44f02"
-SRC_URI = "git://github.com/ruby-concurrency/concurrent-ruby.git;protocol=https;tag=v1.1.6\
- file://0001-Removed-check-for-concurrent_ruby.jar.patch"
+SRC_URI = "git://github.com/ruby-concurrency/concurrent-ruby.git;protocol=https;branch=master \
+ file://0001-Removed-check-for-concurrent_ruby.jar.patch \
+ "
+SRCREV = "52c08fca13cc3811673ea2f6fdb244a0e42e0ebe"
S = "${WORKDIR}/git"
+do_install:append () {
+ rmdir --ignore-fail-on-non-empty ${D}${libdir}/ruby/gems/${RUBY_GEM_VERSION}/plugins
+}
+
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/cool.io_1.6.0.bb b/meta-openstack/recipes-devtools/ruby/cool.io_1.7.0.bb
index baa63403..10e9a498 100644
--- a/meta-openstack/recipes-devtools/ruby/cool.io_1.6.0.bb
+++ b/meta-openstack/recipes-devtools/ruby/cool.io_1.7.0.bb
@@ -4,9 +4,12 @@ HOMEPAGE = 'http://coolio.github.com'
LICENSE = 'MIT'
LIC_FILES_CHKSUM = 'file://LICENSE;md5=a5e7701a63eb0a961f98cd10475129b9'
-SRC_URI = 'git://github.com/tarcieri/cool.io.git;protocol=https;tag=v1.6.0'
+SRCREV = 'd7ab8518c11d8fe1b9a679a1686f01a295690fa9'
+
+SRC_URI = 'git://github.com/tarcieri/cool.io.git;protocol=https;branch=master'
S = '${WORKDIR}/git'
inherit ruby
+FILES:${PN} += "${libdir}/*"
diff --git a/meta-openstack/recipes-devtools/ruby/diff-lcs_git.bb b/meta-openstack/recipes-devtools/ruby/diff-lcs_git.bb
index 8566fb3b..6f6758c0 100644
--- a/meta-openstack/recipes-devtools/ruby/diff-lcs_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/diff-lcs_git.bb
@@ -20,7 +20,7 @@ SRCREV = "704bc2c0000b5f9bf49d607dcd0d3989b63b2595"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/halostatue/diff-lcs.git \
+ git://github.com/halostatue/diff-lcs.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/erubis_git.bb b/meta-openstack/recipes-devtools/ruby/erubis_git.bb
index 08e0f281..16fd5429 100644
--- a/meta-openstack/recipes-devtools/ruby/erubis_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/erubis_git.bb
@@ -16,12 +16,12 @@ SRCREV = "1f0b38d9e66885f8af0244d12d1a6702fc04a8de"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/kwatch/erubis.git \
+ git://github.com/kwatch/erubis.git;branch=master;protocol=https \
"
inherit ruby
-do_patch_append() {
+do_patch:append() {
bb.build.exec_func('do_fixup_gemspec', d)
}
diff --git a/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb b/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb
index 768bc218..dc984d3a 100644
--- a/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb
+++ b/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb
@@ -3,17 +3,19 @@ HOMEPAGE = "https://www.fluentd.org/"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=1ffc336af228834e68e0a4d38da165f7"
-SRC_URI = "git://github.com/fluent/fluentd.git;protocol=https;tag=v${PV}"
+SRCREV = "9d113029d4550ce576d8825bfa9612aa3e55bff0"
+
+SRC_URI = "git://github.com/fluent/fluentd.git;protocol=https;branch=master"
S = "${WORKDIR}/git"
-RDEPENDS_${PN} = "cool.io http-parser.rb msgpack serverengine sigdump strptime tzinfo tzinfo-data yajl-ruby"
+RDEPENDS:${PN} = "cool.io http-parser.rb msgpack serverengine sigdump strptime tzinfo tzinfo-data yajl-ruby"
inherit ruby
-do_install_append() {
+do_install:append() {
install -d ${D}/etc/fluent/
install ${S}/fluent.conf ${D}/etc/fluent/fluent.conf
}
-INSANE_SKIP_${PN} = "installed-vs-shipped"
+INSANE_SKIP:${PN} = "installed-vs-shipped"
diff --git a/meta-openstack/recipes-devtools/ruby/hashie_git.bb b/meta-openstack/recipes-devtools/ruby/hashie_git.bb
index f26cadb6..65ccb119 100644
--- a/meta-openstack/recipes-devtools/ruby/hashie_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/hashie_git.bb
@@ -16,7 +16,7 @@ SRCREV = "02df8918dd07ef2da1aceba5fd17e8757027345a"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/intridea/hashie.git \
+ git://github.com/intridea/hashie.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/highline_git.bb b/meta-openstack/recipes-devtools/ruby/highline_git.bb
index 3bfcd882..546bfc9e 100644
--- a/meta-openstack/recipes-devtools/ruby/highline_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/highline_git.bb
@@ -10,7 +10,7 @@ rules and without needing to convert the typed Strings into what your \
program really needs. Just tell HighLine what you're after, and let it \
do all the work."
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://LICENSE;md5=884766faee6a0d2931af978757e1a5fc"
PR = "r0"
@@ -22,7 +22,7 @@ SRCREV = "327051c1c217df2880c3a53f31484f7e815e847f"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/JEG2/highline.git \
+ git://github.com/JEG2/highline.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb b/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb
index db52ebd5..5452c126 100644
--- a/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb
+++ b/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb
@@ -4,7 +4,9 @@ HOMEPAGE = "https://rubygems.org/gems/http_parser.rb"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE-MIT;md5=157efc3766c6d07d3d857ebbab43351a"
-SRC_URI = "git://github.com/tmm1/http_parser.rb.git;protocol=https;tag=v0.6.0"
+SRCREV = "c8dae7c6c2c78a5016d082a7fbda7e362292c14a"
+
+SRC_URI = "gitsm://github.com/tmm1/http_parser.rb.git;protocol=https;branch=master"
S = "${WORKDIR}/git"
@@ -16,7 +18,9 @@ DEPENDS = "git"
inherit ruby
# Download the submodules
-do_configure_prepend() {
+do_configure:prepend() {
cd ${WORKDIR}/git
git submodule update --init --recursive
}
+
+FILES:${PN} += "${libdir}/*"
diff --git a/meta-openstack/recipes-devtools/ruby/ipaddress_git.bb b/meta-openstack/recipes-devtools/ruby/ipaddress_git.bb
index 017c6c73..29a89336 100644
--- a/meta-openstack/recipes-devtools/ruby/ipaddress_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/ipaddress_git.bb
@@ -20,7 +20,7 @@ SRCREV = "96aaf68210d644157bd57a6ec3e38c49f38bfc34"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/ipaddress-gem/ipaddress.git \
+ git://github.com/ipaddress-gem/ipaddress.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/json_git.bb b/meta-openstack/recipes-devtools/ruby/json_git.bb
index f7b3dd79..61655e5a 100644
--- a/meta-openstack/recipes-devtools/ruby/json_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/json_git.bb
@@ -4,7 +4,7 @@
SUMMARY = "An implementation of the JSON specification according to RFC 4627"
DESCRIPTION = "An implementation of the JSON specification according to RFC 4627"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://CHANGES;md5=af8cad0ff27a1593ac5ee461bc2d71ab"
PR = "r0"
@@ -16,7 +16,7 @@ SRCREV = "4cf6c6270f52888997ec1b626b9f557db4f26f2e"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/flori/json.git;branch=v1.8 \
+ git://github.com/flori/json.git;branch=v1.8;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/method-source_git.bb b/meta-openstack/recipes-devtools/ruby/method-source_git.bb
index 39b24d1c..6756f998 100644
--- a/meta-openstack/recipes-devtools/ruby/method-source_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/method-source_git.bb
@@ -16,7 +16,7 @@ SRCREV = "1b1f8323a7c25f29331fe32511f50697e5405dbd"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/banister/method_source.git \
+ git://github.com/banister/method_source.git;branch=master;protocol=https \
file://gemspec-bump-version.patch \
"
diff --git a/meta-openstack/recipes-devtools/ruby/mime-types_git.bb b/meta-openstack/recipes-devtools/ruby/mime-types_git.bb
index 4216db17..989cb626 100644
--- a/meta-openstack/recipes-devtools/ruby/mime-types_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/mime-types_git.bb
@@ -19,7 +19,7 @@ SRCREV = "bc15d62118b59aabbc9cb6e5734b65bf3bc273f0"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/halostatue/mime-types.git \
+ git://github.com/halostatue/mime-types.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb b/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb
index b380e011..d10835d9 100644
--- a/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb
@@ -17,12 +17,12 @@ SRCREV = "db24a56c6f5b99114998a50942220a7023060229"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/opscode/mixlib-authentication.git \
+ git://github.com/opscode/mixlib-authentication.git;branch=master;protocol=https \
"
inherit ruby
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
mixlib-log \
"
diff --git a/meta-openstack/recipes-devtools/ruby/mixlib-cli_git.bb b/meta-openstack/recipes-devtools/ruby/mixlib-cli_git.bb
index 02bf49ca..44309c46 100644
--- a/meta-openstack/recipes-devtools/ruby/mixlib-cli_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/mixlib-cli_git.bb
@@ -17,7 +17,7 @@ SRCREV = "b3b3c12141b5380ec61945770690fc1ae31d92b0"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/opscode/mixlib-cli.git \
+ git://github.com/opscode/mixlib-cli.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/mixlib-config_git.bb b/meta-openstack/recipes-devtools/ruby/mixlib-config_git.bb
index f58c15c2..68eb393e 100644
--- a/meta-openstack/recipes-devtools/ruby/mixlib-config_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/mixlib-config_git.bb
@@ -17,7 +17,7 @@ SRCREV = "d7bdd7c999e13a0bd67607011731a536323dd51c"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/opscode/mixlib-config.git \
+ git://github.com/opscode/mixlib-config.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/mixlib-log_git.bb b/meta-openstack/recipes-devtools/ruby/mixlib-log_git.bb
index cef61cb0..52a95d6e 100644
--- a/meta-openstack/recipes-devtools/ruby/mixlib-log_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/mixlib-log_git.bb
@@ -17,7 +17,7 @@ SRCREV = "b750625a79cc46fffe6b886320f96e7874497fa0"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/opscode/mixlib-log.git \
+ git://github.com/opscode/mixlib-log.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/mixlib-shellout_git.bb b/meta-openstack/recipes-devtools/ruby/mixlib-shellout_git.bb
index 9abe92c8..70e316e5 100644
--- a/meta-openstack/recipes-devtools/ruby/mixlib-shellout_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/mixlib-shellout_git.bb
@@ -20,7 +20,7 @@ SRCREV = "27ba1e882dcab280527aa1764d1b45aca3ef5961"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/opscode/mixlib-shellout.git \
+ git://github.com/opscode/mixlib-shellout.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/msgpack_1.3.3.bb b/meta-openstack/recipes-devtools/ruby/msgpack_1.3.3.bb
index 063a8521..53826767 100644
--- a/meta-openstack/recipes-devtools/ruby/msgpack_1.3.3.bb
+++ b/meta-openstack/recipes-devtools/ruby/msgpack_1.3.3.bb
@@ -4,9 +4,12 @@ HOMEPAGE = "http://msgpack.org/"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
-SRC_URI = "git://github.com/msgpack/msgpack-ruby.git;protocol=https;tag=v${PV}"
+SRCREV = "64db1bac56359c9257d22f3ffb7506b578d76741"
+
+SRC_URI = "git://github.com/msgpack/msgpack-ruby.git;protocol=https;branch=master"
S = "${WORKDIR}/git"
inherit ruby
+FILES:${PN} += "${libdir}/*"
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb b/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
index b823a033..160237c3 100644
--- a/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
@@ -20,13 +20,13 @@ SRCREV = "1de7611a7f7cedbe7a4c6cf3798c88d00637582d"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/net-ssh/net-ssh-gateway.git \
+ git://github.com/net-ssh/net-ssh-gateway.git;branch=master;protocol=https \
file://gemspec-don-t-force-the-use-of-gem-private_key.pem.patch \
"
inherit ruby
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
net-ssh \
"
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb b/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb
index 7da05668..d95042e5 100644
--- a/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb
@@ -20,13 +20,13 @@ SRCREV = "5b668d5ef34102c9ac159a8f21c889fdc7f99f1b"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/net-ssh/net-ssh-multi.git \
+ git://github.com/net-ssh/net-ssh-multi.git;branch=master;protocol=https \
file://gemspec-don-t-force-the-use-of-gem-private_key.pem.patch \
"
inherit ruby
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
net-ssh \
net-ssh-gateway \
"
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh_git.bb b/meta-openstack/recipes-devtools/ruby/net-ssh_git.bb
index f2591ffa..344b34bb 100644
--- a/meta-openstack/recipes-devtools/ruby/net-ssh_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh_git.bb
@@ -18,7 +18,7 @@ SRCREV = "9f8607984d8e904f211cc5edb39ab2a2ca94008e"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/net-ssh/net-ssh.git \
+ git://github.com/net-ssh/net-ssh.git;branch=master;protocol=https \
file://gemspec-don-t-force-the-use-of-gem-private_key.pem.patch \
"
diff --git a/meta-openstack/recipes-devtools/ruby/ohai_git.bb b/meta-openstack/recipes-devtools/ruby/ohai_git.bb
index 5820c44d..f7bad071 100644
--- a/meta-openstack/recipes-devtools/ruby/ohai_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/ohai_git.bb
@@ -20,12 +20,12 @@ SRCREV = "5c166cf3fa4b2af541ee54855aae73c809044b3d"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/opscode/ohai.git \
+ git://github.com/opscode/ohai.git;branch=master;protocol=https \
"
inherit ruby
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
mime-types \
ipaddress \
mixlib-cli \
diff --git a/meta-openstack/recipes-devtools/ruby/pry_git.bb b/meta-openstack/recipes-devtools/ruby/pry_git.bb
index a4eb63cd..d2c33256 100644
--- a/meta-openstack/recipes-devtools/ruby/pry_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/pry_git.bb
@@ -18,7 +18,7 @@ SRCREV = "191dc519813402acd6db0d7f73e652ed61f8111f"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/pry/pry.git \
+ git://github.com/pry/pry.git;branch=master;protocol=https \
file://rdoc-fixup-opt.banner-heredoc.patch \
"
@@ -26,7 +26,7 @@ inherit ruby
RUBY_COMPILE_FLAGS = ""
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
coderay \
method-source \
slop \
diff --git a/meta-openstack/recipes-devtools/ruby/rack_git.bb b/meta-openstack/recipes-devtools/ruby/rack_git.bb
index 41f01c54..2c03cff3 100644
--- a/meta-openstack/recipes-devtools/ruby/rack_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/rack_git.bb
@@ -20,7 +20,7 @@ SRCREV = "134d6218d0881d87ae6a522e88eafbddb6cd1bb7"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/rack/rack.git;branch=1-6-stable \
+ git://github.com/rack/rack.git;branch=1-6-stable;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/rest-client_git.bb b/meta-openstack/recipes-devtools/ruby/rest-client_git.bb
index 923e9f26..706af39c 100644
--- a/meta-openstack/recipes-devtools/ruby/rest-client_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/rest-client_git.bb
@@ -18,12 +18,12 @@ SRCREV = "40eddc184a7b3fe79f9b68f291e06df4c1fbcb0b"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/rest-client/rest-client.git \
+ git://github.com/rest-client/rest-client.git;branch=master;protocol=https \
"
inherit ruby
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
mime-types \
"
diff --git a/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb b/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb
index 1ed8f9e9..553c5673 100644
--- a/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb
+++ b/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb
@@ -4,10 +4,14 @@ HOMEPAGE = 'https://rubygems.org/gems/serverengine'
LICENSE = 'Apache-2.0'
LIC_FILES_CHKSUM = 'file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57'
-SRC_URI = 'git://github.com/treasure-data/serverengine.git;protocol=https;tag=v2.2.1'
+SRCREV = '99d44a0989ab3e64e14ac0367aadf76aa13b3583'
+
+SRC_URI = 'git://github.com/treasure-data/serverengine.git;protocol=https;branch=master'
S = '${WORKDIR}/git'
-RDEPENDS_${PN} = "sigdump"
+RDEPENDS:${PN} = "sigdump"
inherit ruby
+
+FILES:${PN} += "${libdir}/*"
diff --git a/meta-openstack/recipes-devtools/ruby/sigdump_0.2.4.bb b/meta-openstack/recipes-devtools/ruby/sigdump_0.2.4.bb
index fbf651eb..fc5152e8 100644
--- a/meta-openstack/recipes-devtools/ruby/sigdump_0.2.4.bb
+++ b/meta-openstack/recipes-devtools/ruby/sigdump_0.2.4.bb
@@ -4,8 +4,12 @@ HOMEPAGE = "https://github.com/frsyuki/sigdump"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=07d6218b18fb6826f04fd32b4918f085"
-SRC_URI = "git://github.com/frsyuki/sigdump.git;protocol=https;tag=v0.2.4"
+SRCREV = "57570f04456560512e4efc1c6fa695b76c17dc0d"
+
+SRC_URI = "git://github.com/frsyuki/sigdump.git;protocol=https;branch=master"
S = "${WORKDIR}/git"
inherit ruby
+
+FILES:${PN} += "${libdir}/*"
diff --git a/meta-openstack/recipes-devtools/ruby/slop_git.bb b/meta-openstack/recipes-devtools/ruby/slop_git.bb
index 043284cd..14debbf2 100644
--- a/meta-openstack/recipes-devtools/ruby/slop_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/slop_git.bb
@@ -16,7 +16,7 @@ SRCREV = "50c4d5a6553c9d0b78dee35a092ea3a40c136fa1"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/leejarvis/slop.git \
+ git://github.com/leejarvis/slop.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/strptime_0.2.3.bb b/meta-openstack/recipes-devtools/ruby/strptime_0.2.5.bb
index 20a1f5bc..d568272d 100644
--- a/meta-openstack/recipes-devtools/ruby/strptime_0.2.3.bb
+++ b/meta-openstack/recipes-devtools/ruby/strptime_0.2.5.bb
@@ -4,10 +4,14 @@ HOMEPAGE = "https://github.com/nurse/strptime"
LICENSE = "BSD-2-Clause"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f19575067ffc5f1ddc02c74eeef9904f"
-SRC_URI = "git://github.com/nurse/strptime.git;protocol=https;tag=v0.2.3"
+SRCREV = "1583aaa510cae4660907b22c8262ab31b1eb1864"
+
+SRC_URI = "git://github.com/nurse/strptime.git;protocol=https;branch=master"
S = "${WORKDIR}/git"
-RDEPENDS_${PN} = "bash"
+RDEPENDS:${PN} = "bash"
inherit ruby
+
+FILES:${PN} += "${libdir}/*"
diff --git a/meta-openstack/recipes-devtools/ruby/systemu_git.bb b/meta-openstack/recipes-devtools/ruby/systemu_git.bb
index 606103e3..fa407f1d 100644
--- a/meta-openstack/recipes-devtools/ruby/systemu_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/systemu_git.bb
@@ -17,7 +17,7 @@ SRCREV = "cb253a8bf213beea69f27418202e936a22d7308f"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/ahoward/systemu.git \
+ git://github.com/ahoward/systemu.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/tzinfo-data_1.2019.3.bb b/meta-openstack/recipes-devtools/ruby/tzinfo-data_1.2019.3.bb
index 5fb6005d..46407553 100644
--- a/meta-openstack/recipes-devtools/ruby/tzinfo-data_1.2019.3.bb
+++ b/meta-openstack/recipes-devtools/ruby/tzinfo-data_1.2019.3.bb
@@ -4,8 +4,12 @@ HOMEPAGE = "https://tzinfo.github.io/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c326926e773a4e99e89820f5d8a0966f"
-SRC_URI = "git://github.com/tzinfo/tzinfo-data.git;protocol=https;tag=v1.2019.3"
+SRCREV = "74d5a2529d585e1d1ab47b6bbb2449cba29f6907"
+
+SRC_URI = "git://github.com/tzinfo/tzinfo-data.git;protocol=https;branch=master"
S = "${WORKDIR}/git"
inherit ruby
+
+FILES:${PN} += "${libdir}/*"
diff --git a/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb b/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb
index 2ea1f2d3..504e3a89 100644
--- a/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb
+++ b/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb
@@ -4,10 +4,14 @@ HOMEPAGE = "https://tzinfo.github.io/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c326926e773a4e99e89820f5d8a0966f"
-SRC_URI = "git://github.com/tzinfo/tzinfo.git;protocol=https;tag=v2.0.1"
+SRCREV = "16b0ff837923401da52325312c51baf9bec700e1"
+
+SRC_URI = "git://github.com/tzinfo/tzinfo.git;protocol=https;branch=master"
S = "${WORKDIR}/git"
-RDEPENDS_${PN} = "concurrent-ruby"
+RDEPENDS:${PN} = "concurrent-ruby"
inherit ruby
+
+FILES:${PN} += "${libdir}/*"
diff --git a/meta-openstack/recipes-devtools/ruby/yajl-ruby_1.4.0.bb b/meta-openstack/recipes-devtools/ruby/yajl-ruby_1.4.0.bb
index 43934763..f91d414a 100644
--- a/meta-openstack/recipes-devtools/ruby/yajl-ruby_1.4.0.bb
+++ b/meta-openstack/recipes-devtools/ruby/yajl-ruby_1.4.0.bb
@@ -4,8 +4,12 @@ HOMEPAGE = "http://rdoc.info/projects/brianmario/yajl-ruby"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7dbd3a9f471247a243db5b62fe091587"
-SRC_URI = "git://github.com/brianmario/yajl-ruby.git;protocol=https;tag=1.4.0"
+SRCREV = "8830754ac1ca04a0c14f71f6e7c1d240934366fe"
+
+SRC_URI = "git://github.com/brianmario/yajl-ruby.git;protocol=https;branch=master"
S = "${WORKDIR}/git"
inherit ruby
+
+FILES:${PN} += "${libdir}/*"
diff --git a/meta-openstack/recipes-devtools/ruby/yard_git.bb b/meta-openstack/recipes-devtools/ruby/yard_git.bb
index e7a25b1f..2728802e 100644
--- a/meta-openstack/recipes-devtools/ruby/yard_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/yard_git.bb
@@ -20,7 +20,7 @@ SRCREV = "d83194e1a09098ec5be28b616cde3b9a15380873"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/lsegal/yard.git;branch=main \
+ git://github.com/lsegal/yard.git;branch=main;protocol=https \
"
inherit ruby