aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb b/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb
new file mode 100644
index 00000000..5452c126
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb
@@ -0,0 +1,26 @@
+SUMMARY = "simple callback-based HTTP request/response parser"
+HOMEPAGE = "https://rubygems.org/gems/http_parser.rb"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE-MIT;md5=157efc3766c6d07d3d857ebbab43351a"
+
+SRCREV = "c8dae7c6c2c78a5016d082a7fbda7e362292c14a"
+
+SRC_URI = "gitsm://github.com/tmm1/http_parser.rb.git;protocol=https;branch=master"
+
+S = "${WORKDIR}/git"
+
+# Bitbake doesn't allow the underscore in file name, hence the dash
+SRCNAME = "http_parser.rb"
+
+DEPENDS = "git"
+
+inherit ruby
+
+# Download the submodules
+do_configure:prepend() {
+ cd ${WORKDIR}/git
+ git submodule update --init --recursive
+}
+
+FILES:${PN} += "${libdir}/*"