aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb')
-rw-r--r--meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb b/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb
index 768bc218..dc984d3a 100644
--- a/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb
+++ b/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb
@@ -3,17 +3,19 @@ HOMEPAGE = "https://www.fluentd.org/"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=1ffc336af228834e68e0a4d38da165f7"
-SRC_URI = "git://github.com/fluent/fluentd.git;protocol=https;tag=v${PV}"
+SRCREV = "9d113029d4550ce576d8825bfa9612aa3e55bff0"
+
+SRC_URI = "git://github.com/fluent/fluentd.git;protocol=https;branch=master"
S = "${WORKDIR}/git"
-RDEPENDS_${PN} = "cool.io http-parser.rb msgpack serverengine sigdump strptime tzinfo tzinfo-data yajl-ruby"
+RDEPENDS:${PN} = "cool.io http-parser.rb msgpack serverengine sigdump strptime tzinfo tzinfo-data yajl-ruby"
inherit ruby
-do_install_append() {
+do_install:append() {
install -d ${D}/etc/fluent/
install ${S}/fluent.conf ${D}/etc/fluent/fluent.conf
}
-INSANE_SKIP_${PN} = "installed-vs-shipped"
+INSANE_SKIP:${PN} = "installed-vs-shipped"