aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-xstatic-angular-schema-form_0.8.13.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-xstatic-angular-schema-form_0.8.13.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-xstatic-angular-schema-form_0.8.13.0.bb24
1 files changed, 22 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-xstatic-angular-schema-form_0.8.13.0.bb b/meta-openstack/recipes-devtools/python/python3-xstatic-angular-schema-form_0.8.13.0.bb
index eae97b28..e74accaf 100644
--- a/meta-openstack/recipes-devtools/python/python3-xstatic-angular-schema-form_0.8.13.0.bb
+++ b/meta-openstack/recipes-devtools/python/python3-xstatic-angular-schema-form_0.8.13.0.bb
@@ -1,2 +1,22 @@
-require python-xstatic-angular-schema-form.inc
-inherit setuptools3
+DESCRIPTION = "Angular Schema Form packaged for setuptools (easy_install) / pip."
+HOMEPAGE = "https://pypi.python.org/pypi/XStatic-Angular-Schema-Form"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=0e4430cb0dfdb98d3008c66d8339f31a"
+
+PYPI_PACKAGE = "XStatic-Angular-Schema-Form"
+
+SRC_URI[md5sum] = "d0faab81c36f4cfc03e092fedc30018d"
+SRC_URI[sha256sum] = "7c08634901751267fe26d266fc027cf6ed2e5f422696985cec750594b3f4e300"
+
+inherit setuptools3 pypi
+
+# DEPENDS_default: python-pip
+
+DEPENDS += " \
+ ${PYTHON_PN}-pip \
+ "
+
+# RDEPENDS:default:
+RDEPENDS:${PN} += " \
+ "