aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-wsme_0.10.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-wsme_0.10.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-wsme_0.10.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-wsme_0.10.0.bb b/meta-openstack/recipes-devtools/python/python3-wsme_0.10.0.bb
new file mode 100644
index 00000000..2f5fa1f7
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-wsme_0.10.0.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Simplify the writing of REST APIs, and extend them with additional protocols"
+HOMEPAGE = "https://pypi.python.org/pypi/WSME/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5a9126e7f56a0cf3247050de7f10d0f4"
+
+PYPI_PACKAGE = "WSME"
+
+SRC_URI[md5sum] = "7e5d5c6dbee2ad1e82c518ef3bfdf108"
+SRC_URI[sha256sum] = "965b9ce48161e5c50d84aedcf50dca698f05bf07e9d489201bccaec3141cd304"
+
+DEPENDS += " \
+ ${PYTHON_PN}-pip \
+ ${PYTHON_PN}-pbr \
+ "
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ ${PYTHON_PN}-pbr-native \
+ "
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-pbr \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-pytz \
+ ${PYTHON_PN}-netaddr \
+ ${PYTHON_PN}-webob \
+ "
+
+inherit setuptools3 pypi