aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-suds-jurko_0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-suds-jurko_0.6.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-suds-jurko_0.6.bb21
1 files changed, 19 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-suds-jurko_0.6.bb b/meta-openstack/recipes-devtools/python/python3-suds-jurko_0.6.bb
index d230c8de..a590cfb3 100644
--- a/meta-openstack/recipes-devtools/python/python3-suds-jurko_0.6.bb
+++ b/meta-openstack/recipes-devtools/python/python3-suds-jurko_0.6.bb
@@ -1,3 +1,20 @@
-inherit setuptools3
-require python-suds-jurko.inc
+DESCRIPTION = "Lightweight SOAP client (Jurko's fork)"
+HOMEPAGE = "https://bitbucket.org/jurko/suds"
+SECTION = "devel/python"
+LICENSE = "LGPL-3.0-only"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=847e96bce86d8774f491a92924343a29"
+
+PYPI_PACKAGE_EXT = "tar.bz2"
+
+SRC_URI[md5sum] = "1309e9bc2454aa3434041f0a24ae4e11"
+SRC_URI[sha256sum] = "29edb72fd21e3044093d86f33c66cf847c5aaab26d64cb90e69e528ef014e57f"
+
+inherit pypi setuptools3
+
+DEPENDS += " \
+ ${PYTHON_PN}-pip \
+ "
+
+RDEPENDS:${PN} += " \
+ "