aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-rfc3986_1.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-rfc3986_1.4.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-rfc3986_1.4.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-rfc3986_1.4.0.bb b/meta-openstack/recipes-devtools/python/python3-rfc3986_1.4.0.bb
new file mode 100644
index 00000000..d338a9e4
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-rfc3986_1.4.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Validating URI References per RFC 3986"
+HOMEPAGE = "https://rfc3986.rtfd.org"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=03731a0e7dbcb30cecdcec77cc93ec29"
+
+SRC_URI[md5sum] = "1b03ad2853e33d47eea698571255247c"
+SRC_URI[sha256sum] = "112398da31a3344dc25dbf477d8df6cb34f9278a94fee2625d89e4514be8bb9d"
+
+inherit setuptools3 pypi
+
+# DEPENDS_default: python-pip
+
+DEPENDS += " \
+ ${PYTHON_PN}-pip \
+ "
+
+# RDEPENDS:default:
+RDEPENDS:${PN} += " \
+ "