aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-retrying_1.3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-retrying_1.3.3.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-retrying_1.3.3.bb22
1 files changed, 20 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-retrying_1.3.3.bb b/meta-openstack/recipes-devtools/python/python3-retrying_1.3.3.bb
index 9f001fe6..706f978c 100644
--- a/meta-openstack/recipes-devtools/python/python3-retrying_1.3.3.bb
+++ b/meta-openstack/recipes-devtools/python/python3-retrying_1.3.3.bb
@@ -1,2 +1,20 @@
-require python-retrying.inc
-inherit setuptools3
+DESCRIPTION = "Retrying"
+HOMEPAGE = "https://github.com/rholder/retrying"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e"
+
+SRC_URI[md5sum] = "2a126aeef8b21324ecdeac15ff46ef17"
+SRC_URI[sha256sum] = "08c039560a6da2fe4f2c426d0766e284d3b736e355f8dd24b37367b0bb41973b"
+
+inherit setuptools3 pypi
+
+# DEPENDS_default: python-pip
+
+DEPENDS += " \
+ ${PYTHON_PN}-pip \
+ "
+
+# RDEPENDS:default:
+RDEPENDS:${PN} += " \
+ "