aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-python-editor_1.0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-python-editor_1.0.4.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-python-editor_1.0.4.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-python-editor_1.0.4.bb b/meta-openstack/recipes-devtools/python/python3-python-editor_1.0.4.bb
new file mode 100644
index 00000000..3f4dd5da
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-python-editor_1.0.4.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Programmatically open an editor, capture the result"
+HOMEPAGE = "https://github.com/fmoo/python-editor"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
+
+inherit setuptools3 pypi
+
+SRC_URI[sha256sum] = "51fda6bcc5ddbbb7063b2af7509e43bd84bfc32a4ff71349ec7847713882327b"
+
+DEPENDS += " \
+ ${PYTHON_PN}-pip \
+ "
+
+RDEPENDS:${PN} += " \
+ "