aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-positional_1.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-positional_1.2.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-positional_1.2.1.bb23
1 files changed, 21 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-positional_1.2.1.bb b/meta-openstack/recipes-devtools/python/python3-positional_1.2.1.bb
index 3081cd2c..d160ac92 100644
--- a/meta-openstack/recipes-devtools/python/python3-positional_1.2.1.bb
+++ b/meta-openstack/recipes-devtools/python/python3-positional_1.2.1.bb
@@ -1,2 +1,21 @@
-inherit setuptools3
-require python-positional.inc
+DESCRIPTION = "Library to enforce positional or key-word arguments"
+HOMEPAGE = "https://github.com/morganfainberg/positional"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5335066555b14d832335aa4660d6c376"
+
+SRC_URI[md5sum] = "4afcffd8e2ba733fd7a50f137a2ee893"
+SRC_URI[sha256sum] = "cf48ea169f6c39486d5efa0ce7126a97bed979a52af6261cf255a41f9a74453a"
+
+inherit setuptools3 pypi
+
+CLEANBROKEN = "1"
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ ${PYTHON_PN}-pbr-native \
+ "
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-wrapt \
+"