aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-pathlib_1.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-pathlib_1.0.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-pathlib_1.0.1.bb25
1 files changed, 23 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-pathlib_1.0.1.bb b/meta-openstack/recipes-devtools/python/python3-pathlib_1.0.1.bb
index afed21ec..048eeb5c 100644
--- a/meta-openstack/recipes-devtools/python/python3-pathlib_1.0.1.bb
+++ b/meta-openstack/recipes-devtools/python/python3-pathlib_1.0.1.bb
@@ -1,2 +1,23 @@
-require python-pathlib.inc
-inherit setuptools3
+SUMMARY = "Object-oriented filesystem paths"
+DESCRIPTION = "pathlib offers a set of classes to handle filesystem paths. \
+It offers the following advantages over using string objects: \
+- No more cumbersome use of os and os.path functions. \
+- Embodies the semantics of different path types. \
+- Well-defined semantics, eliminating any warts or ambiguities. \
+"
+HOMEPAGE = "https://pypi.python.org/pypi/pathlib"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b6557c860f0fc867aeab30afd649753"
+
+SRC_URI[md5sum] = "5099ed48be9b1ee29b31c82819240537"
+SRC_URI[sha256sum] = "6940718dfc3eff4258203ad5021090933e5c04707d5ca8cc9e73c94a7894ea9f"
+
+inherit setuptools3 pypi
+
+DEPENDS += " \
+ ${PYTHON_PN}-pip \
+"
+
+RDEPENDS:${PN} += " \
+"