aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-pastedeploy_2.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-pastedeploy_2.1.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-pastedeploy_2.1.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-pastedeploy_2.1.0.bb b/meta-openstack/recipes-devtools/python/python3-pastedeploy_2.1.0.bb
new file mode 100644
index 00000000..7fc062a5
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-pastedeploy_2.1.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Load, configure, and compose WSGI applications and servers"
+HOMEPAGE = "http://pythonpaste.org/deploy/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=57609488f8ad28ebf6844a5169a85215"
+
+PYPI_PACKAGE = "PasteDeploy"
+
+SRC_URI[md5sum] = "f1e62dc76092433b7ae150cd81603fbd"
+SRC_URI[sha256sum] = "e7559878b6e92023041484be9bcb6d767cf4492fc3de7257a5dae76a7cc11a9b"
+
+inherit setuptools3 pypi
+
+DEPENDS += "${PYTHON_PN}-pytest-runner-native"
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-paste \
+ ${PYTHON_PN}-setuptools \
+"