aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-oslo.rootwrap_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-oslo.rootwrap_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-oslo.rootwrap_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-oslo.rootwrap_git.bb b/meta-openstack/recipes-devtools/python/python3-oslo.rootwrap_git.bb
new file mode 100644
index 00000000..b873afdb
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-oslo.rootwrap_git.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Oslo Rootwrap"
+HOMEPAGE = "https://launchpad.net/oslo"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c46f31914956e4579f9b488e71415ac8"
+
+PV = "6.1.0+git${SRCPV}"
+SRCREV = "ff61e1577c3aaec6242951876263108559d1a203"
+
+SRCNAME = "oslo.rootwrap"
+SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+# DEPENDS_default: python3-pip
+
+DEPENDS += " \
+ python3-pip \
+ python3-pbr \
+ "
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python3-pbr-native \
+ "
+
+# RDEPENDS:default:
+RDEPENDS:${PN} += " \
+ python3-pbr \
+ python3-six \
+ "