aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-os-vif_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-os-vif_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-os-vif_git.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-os-vif_git.bb b/meta-openstack/recipes-devtools/python/python3-os-vif_git.bb
new file mode 100644
index 00000000..a8fe3c01
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-os-vif_git.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "OpenStack integration library between network and compute providers."
+HOMEPAGE = "https://github.com/openstack/os-vif"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
+
+SRC_URI = "\
+ git://github.com/openstack/os-vif.git;branch=master;protocol=https \
+ "
+
+PV = "2.2.0+git${SRCPV}"
+SRCREV = "d7928102d69dadf653c9f734e5cf8fd504335849"
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += " \
+ python3-pbr \
+ "
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python3-pbr-native \
+ "
+
+RDEPENDS:${PN} += " \
+ python3-pbr \
+ python3-netaddr \
+ python3-oslo.concurrency \
+ python3-oslo.config \
+ python3-oslo.log \
+ python3-oslo.i18n \
+ python3-oslo.privsep \
+ python3-six \
+ python3-stevedore \
+ "
+